Previous 1 4 5 6 7 8 Next 110 Replies Latest reply: Jan 17, 2015 3:02 PM by Mick Reeve Go to original post
  • Kingsley Kingston Esq Level 1 Level 1 (0 points)

    I am the CHAMPIONS my friends

    No time for LOSERS

    I am the CHAMPIONS


    Sorry about that - a little excited, me.

    Woke up in the middle of the night with a voice in my head saying 'turn off File Vault'.

    Took 45 minutes for all of my data to unencrypt, but EUREKA! Now my Garageband is back to saving all of the files as it should.

    I don't know what on earth prompted me to this solution, but it worked.


    So . . . how many others who are having this problem have File Vault activated?

  • Webcast01 Level 1 Level 1 (0 points)

    Hello. I'm a new user here and I think I can fix this issue. I called like 5-7 apple stores/training centers to find out the answer and they said, the problem is in garageband so you have to re-install iLife. Delete all the iLife apps then using your apps install disc, install iLife. Hope that helps!

  • dkmart Level 1 Level 1 (0 points)

    I had the same issue.  After trying lots of things and spending some time on the phone with the Apple support people, here is what finally solved the issue for me.


    BEFORE you move your projects to the new computer or BEFORE you update to GB 11, make sure you open each project go to FILE then SAVE AS and make sure you check the ARCHIVE PROJECT check box before you save it somewhere. (Or if you still have GB 09 installed do the File-Save As-Archive Project.)


    Then either move the project files to the new computer or do the GB 11 install.


    It worked perfectly for me everytime.


    Best of luck.


    DavidArchive Project.jpg

  • xiaomayte Level 1 Level 1 (0 points)

    A big big thanks to Kappaclone for your suggestion! It really helped... Even when I thought my file was completely lost!


    So here's another hint for all the rest of you guys: I had the same problem, right after upgrading to iLife'11 I recorded a live performance right from the mixer, it played back alright, so I saved the project. But then I "closed" the lid of my macbook pro (didn't close GB nor shut down the laptop... when I opened back, it was gone: track was there, but you wouldn't listen to it. Tried saving an mp3 version, nothing, it was 115Mb and last one hour, but it wouldn't listen.


    I wasn't aware of this bug before that time, so I just restarted GB and my Mac, thinking that it might help.... Then I got the fatal error: The file "No effects#08.aif" was not found.


    Thanks toh all your posts I tried many things, restoring permissions and preferences, creating new users. Nothing... Then I started to check all the "Package Contents" for the "trials" projects I had created and I actually noticed that GB had saved my track "No effects#08.aif" within another project I had been just trying out that night (you know, when you do the previous tests just to check everything's alright), not only that, it had saved many "no effects#0x.aif" files into the same "My song" project.


    What I did: I copied the "No effects#08.aif" GB was asking for my track and put into the root folder of the project. GB couldn't find it at the beginning, but I click on "Search" (instead of "Ignore") and then it recognized and imported/restored it into its media folder inside the package content. Worked like a charm. Didn't even had to lock the track as Huggart suggested on a previous post.


    My suggestion then: check all the other projects/tracks you've been working on before, specially the last one you worked before creating your new GB project. Because you're file might just be there, and not lost at all!


    Hope you guys solve your problem... cheers!

  • xiaomayte Level 1 Level 1 (0 points)

    @Monsi.nani, I thought I had lost my track forever too, but then I was checking within the Package Content folder for the project I had been trying on just before creating the new one (the one I got the error on), and the missing file was there! (in my case was "No effects#08.aif") And if you try to search it through the computer with the "Search" facility, it just won't show up, you gotta go look for it.

    Then copy the file into the root folder of your project, and when you click open your track again, maybe it will still tell you it can find the file, just click again on search, and then it'll recognize it from the root folder and copy/restore it into the package content. Hope it helps...

  • domjom Level 1 Level 1 (0 points)

    I'm glad you found that solution worked for you xiaomayte,


    Today i got together with friends and a paid performer to record.

    I checked for half a minute that GB was working before doing 4 hours recording work.

    Took MacBook (10.6.8) home, when i looked in all my  .band files' Package Contents recorded earlier today, there were no  .aif files except in the first test .band file which only had the .aif for it - not the 4 hours work.


    I searched for other fellow-Apple sufferers - found your guys.


    I have observed problems on this subject since 26 March 2010.TWO YEARS!!!!!!!    It is evident that Apple are either not reading these discussions, or probably reading them but not bothering to fix them  - because two years is a LONG time. At this point in time, I am glad i kept my old windows PC in the house cause its got a simple, reliable piece of recording software.  I am now extra happy that i sold my iphone 3Gs and got a Samsung Galaxy Note (its AWESOME), and I've moved from being a 7/10 Apple almost-fan to a 2/10 keeping-eye-out-for-macbook-alternative hater of junk-ware writers in Apple corp.

    Yep - I have having my (and other people) time wasted. Thanks Apple - youve actually made me wish i'd stuck to Microsoft.

  • domjom Level 1 Level 1 (0 points)

    message relocated to correct location

  • domjom Level 1 Level 1 (0 points)


    bug-ridden GB just wasted 3 hours of my recordings (Male Basic#x files not saved).


    thanks for the link you provided - but Apple are in such a state of denial - they removed the page!!

    I just visited the main Apple service centre here in Malaysia and they said "files are lost, nothing can be done about it".

    I might not be able to do anything about those files - but i'll made sure i'm using MS Windows environment for my future recordings - never lost a day's work due to flaky software on my old PC.

  • BluePingu Level 1 Level 1 (0 points)

    Just thought I'd wade in here and indicate that I've had exactly the same problems recently, including some bizarre goings on with imovie sound imports vanishing or being scrambled together when I close a project.


    Saving as archive seems to have solved some of the problems for me, but I've also taken to creating up to three backup files for ANY 'live' recordings (vocal etc) which cannot be re recorded. It particularly seems to cause trouble if I copy regions between projects- often the copy vanishes but the original remains intact. And as xiaomayteabove has indicated, if you're working with several versions of a project concurrently, ie demo versions or different keys, sometimes missing files turn up in earlier versions of projects.


    My most recent issue has been GB deleting individual 'takes' on multi take recordings. Weird and very worrying.

  • HangTime Level 9 Level 9 (50,315 points)

    BluePingu wrote:


    It particularly seems to cause trouble if I copy regions between projects- often the copy vanishes but the original remains intact.


    to understand why:


    (Let the page FULLY load. The link to your answer is at the top of your screen)

  • BluePingu Level 1 Level 1 (0 points)

    Thanks, I found that on your advice archiving projects containing copied regions ended to stop said regions from vanishing.

    For me it's funny that I've only discovered this 'vanishing files' bug now I've started working on a project involving numerous sources from other projects- live sound from one, imovie sound from another, a piano riff from a third, etc. Until now I've had no such issues, with nearly 30 projects. I wonder if this is a common factor (xiaomayte's post above mentions the problem occurring with missing files appearing in other recently active projects).

  • dkmart Level 1 Level 1 (0 points)

    Every GB project I do now I ALWAYS save with the "Archive Project" box checked.  Thankfully, since doing this I have not had any problems even with some very complex multi-track recordings and even Final Cut Soundtracks.

    I hope for everyones' sake Apple will get the message and do something.

    Apple used to be the best for extremely high end professionals.  It seems like they are now simply trying to dominate the world with sheer volume of products and less on the quality.  Sad. :-(

  • sanjampet Level 5 Level 5 (7,745 points)

    Try this open your HD this is easiest in 3 colum veiwclick on home>music>garageband>iTunes>garageband>garageband again then your music is there, at least that's how I have to find my projects.

  • ToddMcCann Level 1 Level 1 (0 points)

    I know this is going to sound weird, but here goes. I have this same problem with GB not being able to find files. Wonder if anyone else has had this particular thing happen?


    I went into 9 different GB files to make a few edits. Each time, I clicked "Save As," changed the file name (the only thing I did different was capitalize a few of the words; they were titles of podcasts), and checked the "Archive Project" box (as suggested by this thread). I later tried to reopen these files and got the "file not found" message. I also noticed in the Finder that all the file icons had changed to the piece of paper with the guitar on it. Before they had all been mini screenshots of the GB project window.


    I wondered if it was the change of file name or the "Archive Project" part that caused the problem. I opened an existing file and everything was fine. I then did "Save As," checked the "Archive" box, and closed the file. I DID NOT change the file name. When I reopened the file, everything was fine.


    Next, I opened that same file, hit "Save As," left the "Archive" box UNCHECKED, and CHANGED the file name. This time the error happened. I confirmed this with another file. So could this be just because of renaming a file? If so, it's still a bug, but at least I know I can just put some good thought into the file name before I save it. Any thoughts would be appreciated.


    GarageBand 08 (4.1.2)

    Snow Leopard 10.6.8

    iTunes 10.6

  • TheBishman Level 1 Level 1 (0 points)

    I just had the same problem crop up out of nowhere, immediately after a software update.


    Sounds like the # definitely has something to do with it.


    I'm also stunned that Apple who have usually been bulletproof have let this one through for so long.


    Surely with the number of views to this post a solution will be found. Weight of numbers will surely win out over what seems to be a very common bug. Surely ... I'm not convincing myself. Two years, that's huge.


    Best of luck all!

Previous 1 4 5 6 7 8 Next