4 Replies Latest reply: Jan 10, 2010 7:49 PM by MuzikJunky
MuzikJunky Level 2 Level 2 (280 points)
I’ve been using a FAT32-formatted PNY 4-gigabyte flash drive for some time to transfer files between my Mac and PC partitions. Recently, I got an invalid node structure error that required me to wipe the entire drive and reinstall Mac OS X and Windows, which I upgraded to 7 professional. I backed up the contents of the flash drive, put the contents of a Win 7 Pro install DVD on it in order to burn the disc as required for a Macintosh to be able to install Win 7, and then deleted the contents of the flash drive so that I could put what I previously backed up back on to where it belonged.

When I copied the files in that folder to restore them where they belonged, I got several errors that said certain contents could not be moved. I put those items in the trash because they weren’t that important anyway and said not to replace the files that were already copied, but eventually the entire flash drive filled up with space because of weird redundancies. Fed up, I went into Disk Utility and reformatted the drive as a FAT32 volume and kept reformatting the drive, copying, and erasing files until everything was where it belonged. Keep in mind, however, that I originally reformatted the drive from FAT32 to HFS+ journaled when I got it and reformatted in FAT32 when it became necessary for the flash drive to be used in Windows and had no problems with it for years.

Now, however, I inserted the drive into Win 7, and I got a message that the flash drive needed to be formatted, which is a crock of you-know-what. I clicked on the format button, and an information window came up that gave you several options to consider. What was most disturbing was that the available size of the device said only 200 Megabytes. I didn’t erase the contents of the drive, and Mac OS X correctly identifies the device as a 4-gigabyte flash drive formatted in FAT32 with all of my contents on it. I put it into machines running Win XP and got the same message that Win 7 gave me. What’s wrong? Is the flash drive kaput? What must be done? Help is appreciated! Peace.

2.4 gHz Intel MBP; 1.42 gHz PPC Mac mini G4 DVD±RW, Mac OS X (10.6.2), 4 gb RAM, 7200-rpm hard drive, 256 Mb VRAM; 1 gb RAM, 32 Mb VRAM
  • jim seo Level 1 Level 1 (0 points)
    I was also facing this similar problem, but still looking for some help
  • MuzikJunky Level 2 Level 2 (280 points)
    I found a solution after speaking to the company that made my flash drive. Thereʼs a program by Hewlett-Packard called HP USB Disk Storage Format Tool that will reformat your USB flash drive in FAT 32 in such a way that both Mac and Windows will read it,and it will function as it did before. Unfortunately, it only runs on Windows, but this is a very useful tool to have in your arsenal. It takes about a half-hour to reformat the drive, but it worked beautifully. Hope this helps! Peace.
  • andrew platt Level 4 Level 4 (1,445 points)
    I had the same problem, I formatted the drive and it came out as a 200mb drive. However if you then boot into OSX and re-format as FAT it seems to work.
    bw
    Andrew
  • MuzikJunky Level 2 Level 2 (280 points)
    Reformatting it in Mac OS X as FAT32 worked fine on the Mac side, but the Windows side couldn’t read it and thought it was an unformatted 200-Mb drive. The Hewlett-Packard solution mentioned above worked for both sides. Peace.