7 Replies Latest reply: Jan 11, 2010 9:26 PM by MechanicalMonster
Macbooknewbie2009 Level 1 (0 points)
Hi,

I have been using Safari adblock for a long time now. However, it is no longer blocking any ads even in common websites like cnn.com or news.bbc.co.uk. I have tried uninstalling and re-installing and made sure safari is running in 32 bit mode. But it doesn't seem to work. Did any one face a similar problem?

Macbook White, Mac OS X (10.6.2)
  • ~Bee Level 7 (31,425 points)
    Hi Macbook --
    I just started using GlimmerBlocker.
    I love it.
    No fuss, no muss. And NO ads!
  • Doc M Level 3 (785 points)
    Newbie--

    Humor me. Is your popup blocker still on? Check: Safari>Block Popup windows (should be checked).

    Doc
  • Macbooknewbie2009 Level 1 (0 points)
    Doc M wrote:
    Newbie--

    Humor me. Is your popup blocker still on? Check: Safari>Block Popup windows (should be checked).


    yes it is!

    Message was edited by: Macbooknewbie2009
  • Macbooknewbie2009 Level 1 (0 points)
    ~Bee wrote:
    Hi Macbook --
    I just started using GlimmerBlocker.
    I love it.
    No fuss, no muss. And NO ads!


    Sure. Will install it right away! Adblock worked fine till today. Really wondering what caused it to stop blocking ads all of a sudden...
  • Doc M Level 3 (785 points)
    Fair enough--just wondered.

    also--Check Safari>Preferences>security--and make sure that's checked as well. Otherwise, ~bee's got a winner.

    Doc
  • Macbooknewbie2009 Level 1 (0 points)
    Doc M wrote:
    Fair enough--just wondered.

    also--Check Safari>Preferences>security--and make sure that's checked as well. Otherwise, ~bee's got a winner.


    yup it is too.... n installed glimmerblocker.... its working perfectly fine! Thanks ~bee and Doc.
  • MechanicalMonster Level 1 (0 points)
    I am having the same problem and it started today and manifests itself on two separate MacBook Pros

    - Both running Safari AdBlock 0.4.0 RC3.
    - One laptop is running Leopard the other Snow Leopard.
    - The Laptop running Snow Leopard is running Safari in 32-Bit mode.
    - In Safari>Preferences>Security> Block pop-up windows is enabled
    - In Safari>Preferences>Ad Block> is enabled
    - Safari>Block Popup windows> is checked

    Since this thread is marked as answered I created a separate thread to continue this discussion.
    <http://discussions.apple.com/thread.jspa?threadID=2296367&tstart=0>

    Message was edited by: MechanicalMonster