13 Replies Latest reply: Jan 12, 2010 12:51 PM by frazzo2
frazzo2 Level 1 (0 points)
cannot install software updates and cannot run safari. keep receiving 'installer unexpectedly quit' message. looks like 'installer' utility is corrupt. any way to reset without using original installation disks?

Message was edited by: frazzo2

mac mini 1.5 GHz PowerPC G4, Mac OS X (10.4.11)
  • Király Level 6 (9,635 points)
    Do you have the same problems when logged in to a different user account?
  • frazzo2 Level 1 (0 points)
    i haven't tried that. i'm the only user on the account. should i setup a second account?
  • Király Level 6 (9,635 points)
  • frazzo2 Level 1 (0 points)
    not sure had to add user. also running filevault if that makes a difference.
  • Király Level 6 (9,635 points)
    System Preferences -> Accounts -> unlock the padlock -> click the + button to add a new user account. Also click Login Options, and enable Fast User Switching so that you can toggle back and forth between the two accounts without having to log out of either of them.
  • frazzo2 Level 1 (0 points)
    same issue under new user. installer quits when attempting to open .pkg. in this case it was safari upgrade. consequently, will not open software update.
  • Király Level 6 (9,635 points)
    Okay, that's helpful. Now we know it's not a problem with your user account, which in my experience is the most common cause of misbehaving apps.

    It might be some sort of system cache problem. Try downloading OnyX and use it to clear out all your system caches. Reboot before trying the installer again.
  • frazzo2 Level 1 (0 points)
    thx for the onyX idea. good to have it on the system anyway. upon verification, it says my volume is damaged and needs to be accessed through utilities from the install dvd. which i can't find.
    installer still quitting unexpectedly. cannot open certain .pkg's. safari .pkg will not open at all, replaced by the installer quit message, and software updates will reach the installation screen, but once clicking 'continue' to move to the 'read me' section of the installation screen, installer quits. attempting to reopen brings up my user menu.
  • BDAqua Level 10 (121,615 points)
    Hi frazzo2, and a warm welcome to the forums!

    Two things you can try without your Install Disc or 3rd party Software...

    Safe Boot from the HD, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, reboot when complete.

    PS. Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.

    Tough without the Install disc, but some things to try...

    Does it boot to Single User Mode, CMD+s keys at bootup, if so try...

    /sbin/fsck -fy

    Repeat until it shows no errors fixed.

    (Space between fsck AND -fy important).

    Resolve startup issues and perform disk maintenance with Disk Utility and fsck...


    Tough without the Tiger Disk problems, but try fsck...

    To use fsck, you must run it from the command line. Unlike using your mouse to open an application to do something, you'll need to type a text command at the prompt (#) to tell fsck what to do. The Terminal application (/Applications/Utilities) and single-user mode are two examples of command-line interfaces in which you can type such commands. To use fsck:

    1. Start up your computer in single-user mode to reach the command line. Hold CMD+s keys down at bootup.
Note: If necessary, perform a forced restart as described in the Emergency Troubleshooting Handbook that came with your computer. On desktop computers, you can do this by pressing the reset/interrupt button (if there is one) or holding down the power button for several seconds. On portable computers, simultaneously press the Command-Control-power keys. If your portable computer doesn't restart with this method, you may need to reset the Power Manager.

    2. At the command-line prompt, type /sbin/fsck -fy

    (SPACE between fsck AND -fy important)

    3. Press Return. fsck will go through five "phases" and then return information about your disk's use and fragmentation. Once it finishes, it'll display this message if no issue is found:

    The volume (nameofvolume) appears to be OK 
If fsck found issues and has altered, repaired, or fixed anything, it will display this message:

Important: If this message appears, repeat the fsck command you typed in step 2 until fsck tells you that your volume appears to be OK (first-pass repairs may uncover additional issues, so this is a normal thing to do).

    4. When fsck reports that your volume is OK, type reboot at the prompt and then press Return.


    Then Safe Boot, (holding Shift key down at bootup), & use Disk Utility from there to Repair Permissions, reboot once more.
  • frazzo2 Level 1 (0 points)
    THANKS for the welcome. glad to be here. apologies for the delay. did the above stepbystep verbatim, and while the volume appears to be ok and all permissions are repaired, the install application still closes unexpectedly while attempting to open files.

    i ran the self-test.pkg out of the installer menu and it claimed to encounter an error evaluating javascript for the package. i'm running J2SE 5.0 and java appears to work fine. any other suggestions on perhaps how to re-install 'installer' w/o the OS DVD?
  • BDAqua Level 10 (121,615 points)
    Might try Pacifist...


    Not sure if it uses the built in installer or not though.
  • frazzo2 Level 1 (0 points)
    THX!! for future reference, pacifist has that downloadable zip file as an alternative to the .dmg. so unless stuffit's not working, it should still open even if 'installer' is damaged.

    in this case, the downloaded pacifist.dmg did mount and install. everything worked after that.

    i reinstalled safari, followed by the latest OS update downloaded from the apple site. after those two, installer (unexpectedly) worked fine, including in self-test mode, and i was able to run software update successfully. must've needed that OS update. not sure. i'll keep pacifist in apps just in case.

    would not have worked without pacifist or your suggestions. thnks again. hope you get lots o points for thisone!
  • BDAqua Level 10 (121,615 points)
    Good news, great to hear, thanks!