Previous 1 2 3 Next 38 Replies Latest reply: Nov 3, 2012 9:26 AM by Michael FitzGibbon
Steve Gallisdorfer Level 2 (180 points)
I am trying to get ANY iTunes music to show up in iPhoto '09 (version 8.1.1) or in iMovie, but in the settings under music, I can't get the toggle bar to show me anything. It's just like it is frozen when I click on it. Just the canned music from Apple plays. Yuk.

I have d'load iTunes music, plus ripped it in from CDs I own, and made several playlists, long and short. But nothing shows at all. All the music is on the same drive iPhoto is... nothing is across a network, a partition or a separate drive.

Another suggestion was to check to see if the file "iTunes Music Library.xml" was corrupted, but that appears to be fine.

I have reinstalled the iLife Media Browser (and repaired permissions) as suggested in the iPhoto forum, with no change.

Any help would be greatly appreciated.

Dual core MacBook Pro-Mac OS X (10.6.2), Mac OS X (10.6.2)
  • mahippos Level 3 (870 points)
    Just for the record, I have the same problem as posted by Steve. The music popup for slide shows doesn't show any available music. There are at least three songs available, but these seem to be selected at random by iPhoto. None are in my iTunes library. Does anyone know where they are hiding?

    I think the problem is in iPhoto itself, not iTunes. I can turn off the music in a slide show, but if I then change its style the music is automatically turned back on. The undead as it were.

    I got my MacBook Pro last month at Christmas. The software is up to date and permissions are OK as far as Disk Utility can make them. The music bug was probably introduced recently.

    (reposting as requested)

  • jdnell52 Level 1 (0 points)
    I have exactly the same problem as Steve (above) and have done the same "fixes" as identified in this thread. Still no luck.

    Geesshh, I was hoping someone had a solution by now...I was beginning to think I'd have to report it, when I found this thread. But, this is EXACTLY the same problem I'm having.

    I'll be watching for a solution....hopefully soon!

    Using iPhoto '09 Version 8.1.1 (419)
    Using iTunes 9 Version 9.0.2 (25)
    Mac OS X 10.6.2
  • Steve Gallisdorfer Level 2 (180 points)
    Maybe the Apple Genius Bar is will have the answer. I have an appointment next Tuesday. I will post the results of the visit one way or another!
  • Steve Gallisdorfer Level 2 (180 points)
    OK, can I say here first of all that the people at the Mac Genius Bar are great? I have never had a bad experience at one, and the Arden Fair Mall location in Sacramento is no exception. They resolved my music issues, and all is great now. Here is what they discovered, and how they resolved my problem...

    The iLife Media Browser Plug-ins that are installed aren't working correctly, as several suggested solutions have eluded to. These files are stored on your Mac at:
    YourHardDrive /Library/Application Support/iLifeMediaBrowser/Plug-Ins

    There is no version number for the set that was installed, but when he replaced them with the earlier version, 2.1.3, it all started working just fine again. The Apple Store maintains a set of external drives there with various Apple software on them, and he just copied it over, replaced it the files, restarted and VOILA!

    I have a zipped archive of these plug-ins that he created and suggested I could upload them here for the others of you that are having the same trouble I was having, but I see no way to do that. If someone can point out a way to upload a file here, I will. I also see nothing in Apple's downloads for version 2.1.3, so that may be out as an option, too. If there is not a way for me to put the archive up here, I would suggest one of two things to you:
    1) Make an appointment at the Apple Genius Bar and tell them what is going on with your Mac, and what the solution was for me. (It took quite a bit of hunting & discussion between 4 of them to figure this out, so be sure to let the guys there know what the solution was that resolved it.)
    2) Send me an email, and I will send you back the archive. At 922k, it is not very big. Be sure to unzip it before you use it.

    As always, back-up your computer before replacing the files, and save the old version of the plug-ins until you are sure the replacement ones work correctly.

    Message was edited by: Steve Gallisdorfer
  • Steve Gallisdorfer Level 2 (180 points)
    This problem is now completely resolved. This post is just to get it posted as 'answered'.
  • jdnell52 Level 1 (0 points)
    Steve -

    I would like to obtain the archive from you, since I have an iMac, and it's not as easy to tote into the Apple store! But, I couldn't find you email address anywhere to PM you. If you wouldn't mind, please forward it to me via (without the xxx's for the robots)

    Thanks for your efforts and sharing the results! Hopefully, it will resolve my problems, too!

  • Chris CA Level 9 (78,695 points)
  • Steve Gallisdorfer Level 2 (180 points)
    Perfect, Chris... THANKS!

    John... let me know if that works or not, OK? If it doesn't, I'll send across the files when I get home (next week).
  • mahippos Level 3 (870 points)
    I downloaded the iLife package and installed it, but nothing changed with the music. I still cannot access anything in iTunes from iPhoto. I checked the date/time of all the plugs-in in the directory /Library/Application Support/iLifeMediaBrowser/Plug-Ins afterward; and they were all Jan 1, 2010 11:39AM. These obviously are not the old plug-ins. Did you get something else?


  • Steve Gallisdorfer Level 2 (180 points)
    That must install the 'new' non-working plug-ins then. I will email you the files on the 28th, when I have access to my Mac again. I would do it right now, but am away on a business trip, harnessed to a PC.
  • jdnell52 Level 1 (0 points)
    Steve / Clint -

    I had done the iLife support 9.0.3 updates already, too. Nothing changed for me, either. I'll wait until you can forward the archive before trying anything else. Thanks again for all your legwork and sorry to hear you're tied to a PC while on-the-road! I understand such things. Been there myself!

  • 68vette Level 1 (0 points)
    I'm also a victim of this plugin atrocity. I would definitely appreciate the 2.1.3 file you have provided an Apple Store is a 2 hr. drive. blairb(xxxx) No (xxxx)'s... of course. Thanks Steve.
  • Silversorcerer Level 1 (0 points)
    Hi Steve, same problem exactly, tried the above download, nothing changed. Send it to all of us at once, please. :>)

    David Powell
  • Silversorcerer Level 1 (0 points)
    I figured out a work around to fix mine. I still have iLife '06 on my Macbook, so I:

    created an airport network, computer to computer

    looked in the flolder.../Application Support/referred to above and

    verified with get info that the plugins' versions were indeed 2.1.3.

    Then copied a folder called iLifeMediaBrower, its' subfolder "Plugins" and the plugins inside.

    and pasted the whole folder "iLifeMediaBrower"into the same flolder.../Application Support/ on my newer iMac where iLife 09 is original equipmemt;- where the problem is.

    I noted that in this process, this folder replaced no existing folder at all.

    The folder and the plugins were simply missing from the program. There apparently are no new versions of them.

    If you have a way by network to access a computer still running iLife'06 you can borrow the files. I might be able to e-mail them as well. In my case, this completely fixed the iTunes integration with slide shows in iPhoto '09.
Previous 1 2 3 Next