4 Replies Latest reply: Jan 13, 2010 9:37 AM by Mike Kormendy
Mike Kormendy Level 1 Level 1 (0 points)
I am resurfacing the following related comment made in another post that discusses the same issue I am having with VNC on Snow Leopard. This is still an issue and I cannot connect to our Xserve's Snow Leopard Server with a VNC client on Windows.

I don't want to install another third party VNC server onto our SL Server, and am looking for a VNC client for windows that will connect to our SL Server.

Does anyone have any solutions?


Re: Newbie: Connect Windows -> OSX Server
Posted: Nov 4, 2009 9:26 AM in response to: Antonio Rocco

I would politely disagree. Yes, definitely, the Mac 'Screen Sharing' app works a treat, and Apple Remote Desktop.app works as well, but I am coming from a Window's PeeCee.

For me, connecting to my 10.5(.8) Server via tightvnc gives 'Server did not offer supported security type!". Using RealVNC to this machine states "No matching security types Do you wish to reconnect to ... ?" a telnet to this AppleVNCServer service (port 5900), shows RFB 003.889 *, or Remote Frame Buffer Major 3, minor 889.

Also, connecting to multiple 10.6(.1) Clients with Tightvnc correctly asks for a password but then hangs at "Status: Security type requested". Using RealVNC opens, connects, asks for authentication, and exits. Telneting to this AppleVNCServer service (port 5900), also shows RFB 003.889 *.

The Current Version of the protocol is supposed to be 3.8, that is Major version 3, minor version 8. Not 80 or 800 but Eight). http://www.realvnc.com/docs/rfbproto.pdf and I believe that tightvnc only supports up to version 3.7.

On each station I have installed the 'old' OSXVnc.app as a service (to a unique port). OSXVnc utilizes protocol 3.3 and I can control them successfully, but that is of my own doing because of this issue.

Now JollysFastVNC works a treat to any machine I have EVER tried to connect to. I have not tried COTVNC or any of the others (too slow for me, when they wer e around)

Also, I just noticed that RealVNC states that their free and personal version will not connect to Mac OSX (x86 and PPC) but the Enterprise one will. I just Dl'ed the Enterprise Viewer and it gave essentially the same thing ('protocol is not valid' message, even after it asks for a password). Anyway, I am not here to hijack this thread, just trying to keep the info flowing and open.

Maybe I am the only one with these problems but the bottom line is I cannot use Real or Tight, or UltraVNC to administer my server or clients as long as AppleVNCServer gives out the 003.889 protocol version.


* The ProtocolVersion message consists of 12 bytes interpreted as a string of ASCII characters in the format "RFB xxx.yyy\n" where xxx and yyy are the major and
minor version numbers, padded with zeros.

Other OS, Multiple Systems & Devices, Multiple OS's