10 Replies Latest reply: May 4, 2010 7:08 AM by Jeff Lambert
Jeff Lambert Level 1 Level 1 (5 points)
Hi,
I've posted this in the Mac OS X SL -Finder section but was told this was more of a Server issue so here it is again.

I'm having a big time troubleshoothing this. I have a couple a mac clients connecting to a Mac OS X serveur 10.6.2. Most clients are running 10.5.8 and some 10.6.2, me included. Now some users both with SL and Leopard have the following issue. When the connect to the server, navigate to a folder, the finder resets the window to there computer or home folder depending what's in there prefs. This is really annoying since if you navigate to some place on the server to copy something, it resets before you can do it! On user even has this happen when in a dialog box (like save or open) mainly from Indesign. She is running 10.6.2, a machine I just setup from the ground up. The server is also newly installed and running 10.6.2 but I also had the problem with 10.5.8 server. I also redid the whole permission on the server when I migrated from the old server to the new, redid every user. I didn't copy preferences from finder or any other system files besides colorsync profiles and prefs for Adobe CS4 so I don't think those are responsible.

Anybody as seen this? Please Help! This is driving her (and me) crazy!

TIA
Jeff

iMac 24", core 2 duo, 2.8Ghz, Mac OS X (10.6.1), 4Gb RAM
  • kkarcher Level 1 Level 1 (0 points)
    Jeff Lambert wrote:
    Anybody as seen this?


    Unfortunately yes. Our server is nearly unusable as it's happening all the time. We have no idea how to solve the problem so all I can do is to to join your cry for help

    Klaus
  • kkarcher Level 1 Level 1 (0 points)
    did you already submit a bug report to Apple?

    https://bugreport.apple.com/

    Klaus
  • Jeff Lambert Level 1 Level 1 (5 points)
    kkarcher,

    I've contacted apple and they think its a client issue, not a server issue, altough I'm starting to think it has more to do with the server. I reinstalled everything on one of the machine exhibiting the problem, and it stopped, but for how long? In the mean time, I'm seeing the problem too, not as systematic as the other machine, but still. It also seem to happen on certain folders and not others. Permission were reset and reapplied on the server, users were recreated, I don't know where to look anymore.

    What are the things you tried?

    Jeff
    PS, I did contact apple, I have a case number and all, don't know if I can post it here for reference though.
  • kkarcher Level 1 Level 1 (0 points)
    Hi Jeff,

    thanks for your reply

    {quote:title=you wrote:}What are the things you tried?{quote}
    hmm ... the usual: loged on/off, verified disks and permissions, checked POSIX and ACL permissions on the server, ...

    {quote:}I'm starting to think it has more to do with the server.{quote}
    I think so too as it started after we migrated our Server to SL and there are both 10.5 and 10.6 clients affected. We found an indication that it might be caused by corrupted Access Control Lists on the server. We will try to delete and recreate them tomorrow.

    {quote}PS, I did contact apple, I have a case number and all, don't know if I can post it here for reference though.{quote}
    Ok. I just wanted to make sure that Apple is aware of the problem.

    Klaus
  • Jeff Lambert Level 1 Level 1 (5 points)
    Klause,

    You're free to try to reset the ACL, but I've been there, done that as they say, and it didn't solve the problem. It is also causing all sorts of other problem with my backup since TimeMachine thinks everything as change. Same thing with Retrospect. I had to reset those backup since I was running out of space.
  • kkarcher Level 1 Level 1 (0 points)
    Gosh!

    thanks for the warning!

    Klaus
  • Greg Miller11 Level 1 Level 1 (20 points)
    i am having this same issue as well. it happens with our 10.4 server, so it isn't just a snow leopard issue. We have all clients, tiger, leopard, snow leopard, and all are at times hit by this bug. and it *****.
  • arch@ngel Level 1 Level 1 (0 points)
    Hi.

    I am having the same problems with one customer server running 10.6.2. Clients updated to 10.6.2 as well.

    New server that came with 10.6 (not updated) and I have been troubleshooting the problem for a day and come to the follwoing conclusion.

    The problem starts when opening Indesign document off the server (from one of the folders where we are seeing the problem, have only one group that have read/write permissions to everywhere on the sharepoint ACL and Posix). Once the problem starts the only way is to disconnect and reconnect to server from the client and the problem go away. I can reproduce the problem in seconds and happens from every client in this office.

    The problem never occurs when accessing the folders from the Finder, only within Indesign and from indesign it affects the Finder.

    My workaround is to connect with SMB as i seems to be working. Been talking to Apple and they blame Adobe and Adobe does not support working on files residing on a fileserver.
  • fotakis Level 1 Level 1 (0 points)
    Hello,

    I am having the exact same problem with a Snow Leopard client with all updates installed connecting to a Snow Leopard Server on a Mac Mini.

    I don't know if this might help the thread but my filenames contain non-latin characters (el_GR.UTF-8) to be specific. What I am noticing is that the letters of the filenames are switching from Uppercase to Lowercase constantly. When I manage to click on a folder, then I am too reset back to the base folder since from what I can gather, the path has changed in that time.

    Hope someone can help on this, because it is very anoying, and basically renders the SL AFP Server useless.

    Best Regards,
    Fotis
  • Jeff Lambert Level 1 Level 1 (5 points)
    arch@ngel,

    You were quicker than me to find the SMB fix:-) I still have a problem though, my folders have for the most part a red circle on them like if they're locked, but I can still go in them and browse my stuff. Also is there any drawback to connecting via SMB, like labels not working or stuff like that?

    I'm not sure about the Indesign Only part though, because I use PS exclusively on some folders and they show the behaviour too. Granted, it's still an adobe issue.

    Thanks
    Jeff