4 Replies Latest reply: Apr 14, 2010 12:40 AM by alienated user
Billybobvi Level 1 Level 1 (0 points)
I have the 3g with the lastest firmware. About 2 weeks ago i noticed that i was not connecting to my home network automaticly. I then tried to connect manually and it asked for my password. I entered the password and then it says it i was not able to join the network. I have done this several times with no success. The password is right as I have my laptops connected to the same network and they are fine.
I have called AT$T and Apple with no success. I have reset the Network settings and still no luck.
Anyone else had this problem and if so is there a solution to this problem?

Thanks,
Billy

PC
  • wjosten Level 10 Level 10 (93,750 points)
    If you've reset network settings with no luck, the only remaining troubleshooting steps are:

    1. Reset: Press the sleep/wake button & home button at the same time, keep pressing until you see the apple logo, then release(ignore the slide to power off).

    2. Restore the phone from your backup, however if the backup has corrupt data that might be causing the problem, the problem will simply be restored.

    3. Restore as a "new" phone & re-sync your itunes content.

    If none of this resolves the problem, a trip to an Apple store is in order.
  • John Ghadimi Level 2 Level 2 (255 points)
    I'm having the same issue with my phone! my Wifi used to connect with no issues, but recently its not finding any wifi hotspots. How do you go about resetting the network settings? Is there a specific procedure for that? Appreciate the help.

    thanks;
    John
  • sadrian80 Level 1 Level 1 (0 points)
    Same problem here since 3-4 weeks now.
    After upgrading my iphone 3G from 3.1.2 to 3.1.3 via iTunes wifi couldn't connect anymore. I enter the correct wifi password and it tells me it "couldn't connect" without any further explanation, then the password prompt reapears.

    When I try to connect to an unprotected network it does exactly the same, on 6 different routers for now. (I definately don't think that this is related to the routers at all!)

    I tried resetting everything, I downgraded to 3.1.2 and upgraded to 3.1.3 again, I wiped the phone and installed it as new device - with absolutely no change.

    No help from Apple because my phone is 14 months old, no clue what to do now. Without wifi the iPhone is 70% useless for me. -.-

    Anyone any idea??
  • alienated user Level 1 Level 1 (0 points)
    After installing the newest Iphone firmware update, my phone lost the ability to connect to any wifi signal. Upon some investigation I found out I am not the only one who has had this problem. After days of resetting, re-downloading, hours of conversations with Apple Rep's and trips to the Apple Store, my phone still does not work. I don't make these things, but I can tell you without question this is not a hardware issue...Nothing was damaged or broken in the phone, the Wifi Antenna is fully functional and attached to the motherboard (logic board...whatever you call it these days). After all this, I can say that I am disappointed to the extent that I would not buy another Apple product again - not because I think they are of poor quality - but because of the terrible support I received. "You're eligible for an upgrade" is not technical support...that is evidence that your "firmware update" was never tested with this product because you've moved on to other versions and expect me to as well.

    If anyone figures this out I would love an answer....I took my phone apart and tested my connections, all good to go...next thing is to swap out motherboards with another 3g and make sure the antenna isn't fried....but I can't seem to get this to work with older versions of the software....any tips on loading older firmware without ******* off Apple?