2 Replies Latest reply: Jan 14, 2010 6:08 PM by mrstee
mrstee Level 1 (80 points)
Hi-I am having issues with my iPhoto '09 publishing to MobileMe Gallery. I have had 2 chats with MobileMe technicians and after a lengthy discussion it appears that it's a problem with iPhoto '09. I get a message that the request to server failed. It attempts to publish but then I get that message.

In talking with the MobileMe guys I tried all sorts of things: logging in to MobileMe with a test MobileMe user name and password; tried publishing just one photo; I had repaired permissions already; logged out of my main admin account and logged into a test user account (this was the only method that worked to publish) and; uploaded pictures from my MobileMe Gallery to iPhoto (this worked). There were all sort of other tricks I tried but I can't remember them all.

I should mention that earlier this week I had an issue that resulted in me having to do an Erase and Install of my operating system. My MBP had an "Invalid Node Structure." I restored my stuff from my Time Machine backup and all seems to be working fine except for publishing to MobileMe. I also installed the 10.6.2 Combo update thinking that maybe there was a small piece missing from the update I did via Software Update. It didn't make any difference.

I also used my husband's MacBook to see if I could publish from his iPhoto '08 and yes, I was able to.

The last MobileMe guy I talked to said to talk to Apple but since I am not home and don't have my case number with me, I thought I'd try posting here first.

I have some great pictures of my grandson that are just waiting for my family to see so I would be grateful if someone could help me. One thing I was wondering is that when I installed my operating system, I did not install any apps from the Application disk-could that be the problem? Well, anyway, any help would be appreciated! Judy

15" MacBook Pro, Mac OS X (10.6.2), 2.53mhz/500G hard drive/24" second monitor
  • Old Toad Level 10 (133,265 points)
    Let me summarize what you've tried:

    1 - deleted iPhoto's pref file.
    2 - cleared the cache by logging out of MMe (System/MMe preference pane), logging in with bogus username and password which clears the cache and then logging back in with the correct username and password.

    logged out of my main admin account and logged into a test user account (this was the only method that worked to publish) and; uploaded pictures from my MobileMe Gallery to iPhoto (this worked).

    That indicates that there's something amiss with your primary account that is causing the problem. It could be a preference file other than iPhoto's. Here's how to determine if that's the case:

    Trouble Shooting Preferences in Leopard

    1 - Create a folder titled "Preferences A" on the Desktop.
    2 - Open the working Preferences folder, HD/Users/your_name/Library/Preferences, and move the contents to the Preferences A folder on the Desktop.
    3 - With the working Preferences folder empty run the application again and determine if the problems is fixed.

    NOTE: you may have to drag the contents of the working folder to the trash and empty if moving the contents to the A folder only copies them instead of moving.

    4 - If the problem is fixed:
    A - open the working Preferences folder (HD/Users/your_name/Library/Preferences).
    B - Open the Preferences A folder on the Desktop, select all of the contents and drag them into the working Preferences folder.
    C - When the Copy window pops up check the "Apply to All" check box and then click on the Don't Replace button.

    Click to view full size

    5 - If the problem is NOT fixed, empty the working Preferencess folder and move the contents of the Preferences folder on the desktop back into it.

  • mrstee Level 1 (80 points)
    Hi Old Toad! You won't believe what was causing the problem (you probably will believe it-you seem to have encountered every situation dealing with iPhoto!): the photos that were in the albums that I couldn't publish were sent to me from my daughter-in-law via email. I saved them to my desktop and then imported them into iPhoto, just like I always do. I was at my daughter-in-law's at the time and I had borrowed her SD card to import more pictures she had taken of my grandson and as they were all importing I wondered why I wasn't getting the message that some of them were duplicates, did I want to skip them...... That got me thinking. So I selected one of the photos in one of the albums that wouldn't publish that I knew was a duplicate and saw that that picture had 0kb!! The photo was there, I even showed the photos as a slideshow and all the photos were visible. Very odd. I am sure there is some explanation for this but I have no idea what! But I am a happy MeMaw now, now that I can publish the photos of my sweetie!

    I appreciate you taking all that time to respond to my dilemma-but maybe it will serve as an answer to someone else's problem....... Take care, thanks again, Judy