4 Replies Latest reply: Feb 22, 2010 12:39 AM by Guy Constant
lemack-j Level 1 Level 1 (0 points)
Hi,

Firstly let me say I'm a non-techie... which is why I finally decided to go with Apple products - which I love immensely (when they work).

This brings me to the subject of my post. I have an Airport Express primarily to stream iTunes to my stereo speakers. It was working fine until recently and now it's not. The problem is that the Status light constantly flashes amber. I've tried resetting the unit by pressing the reset button for 10 secs + but it does not seem to reset and the amber light continues to flash.

My instincts are that the unit has developed a fault but before I explore the possibility of returning the unit to Apple, I thought I'd ask around a bit.

Thanks for your patience. lemack-j.

iMac 24" 3.06Ghz, Mac OS X (10.5)
  • Bob Timmons Level 10 Level 10 (88,310 points)
    If you held in the reset button for 10 seconds, this erased all of the current configuration settings in the device and moved it back to its new, out of box condition.

    You need to reconfigure the Express using AirPort Utility.
  • whycohen Level 1 Level 1 (0 points)
    I am having the same problem. I am unable to change settings as the Airport Express does not appear in the Airport Utility from MacPro or G4. I had an Express in my home for 4 years which worked fine and then stopped shortly after upgrading to snow leopard. I thought that might be the problem, took the express to the apple store and was told that the express was busted. I bought a new one and still have only flashing amber.
  • Bob Timmons Level 10 Level 10 (88,310 points)
    Try powering off your computer and the Express and temporarily connecting an ethernet cable from your computer to the Express.

    AirPort Utility should be able to "see" the Express if it is functioning correctly. Once you have the Express configured, you can remover the ethernet cable and move the Express to the desired location.
  • Guy Constant Level 1 Level 1 (5 points)
    I am having a similar problem with my Airport Express. I want to use it to stream from itunes to my stereo. I have an Airport Extreme that has worked fine up until I tried to connect to Express to the network. Now both just flash amber. I spent the whole of Sunday afternoon resetting them but Airport Utility can't see either of them. The instruction manual just says "follow the onscreen instructions" but I'm not a techie so the instructions are in a foreign language. I did what you suggested by attaching the ethernet cable to the Extreme (I'm concentrating on that now as I've got no access to the internet without it)so at least my mac can see the Extreme but the instructions give no clue as to how to configure it. I used to have a secure network which isn't showing up anymore but I've no idea whether it was WPA WPA2. I don't know whetehr I should be trying to create a new network if I can't find the old one or joining the old netwrok that my computer now can't find. I love my Apple stuff dearly but for the first time am thinking of ditching them - I can't believe they get away with such useless instructions.