7 Replies Latest reply: Jan 17, 2010 6:57 AM by Jeff Hoogmoed
Jeff Hoogmoed Level 2 Level 2 (170 points)
...every time I restart my computer.

Hello all,
Like I said every time I restart my mini (10.5.8, Safari Version 4.0.4 (5531.21.10), the toolbar has returned to the state before I customized it, the status bar is gone, and its going to the Safari start page (I had it opening to a blank page and the home set to google).

Has anyone else experienced this? Really frustrating to have to redo this stuff every time.

Any help would be appreciated.

Thanks.

2009 Mac Mini, G5 Dual 2.0 2 GHZ, 4 GB RAM, 47" HD Monitor, Original Mac Mini, Mac OS X (10.5.8), 10.5.8, 2 TB HD, 47 HD Monitor
  • Carolyn Samit Level 10 Level 10 (98,795 points)
    Hi Jeff,

    Try maintenance...

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Go here for trouble shooting 3rd party plugins or input managers which might be causing the problem.

    http://support.apple.com/kb/TS1594

    Make sure Safari is not running in Rosetta. Right or control click the Safari icon in your Applications folder then click Get Info. In the Get Info window click the black disclosure triangle so it faces down. Where you see Open using Rosetta... make sure that is NOT selected.

    From the Safari Menu Bar click Safari/Preferences and click the Security tab. If you have: Warn when visiting a fraudulent website selected, that could be why Safari isn't loading the Google page. Read the post by Klaus1 here. http://discussions.apple.com/thread.jspa?messageID=10905055#10905055










    Carolyn
  • Jeff Hoogmoed Level 2 Level 2 (170 points)
    Thank you for responding. What I should have also posted was that I've. Done all of the usual maintanances, both within and out of Safari.
  • Carolyn Samit Level 10 Level 10 (98,795 points)
    You're quick. Ok.. at least you tried that.

    Try setting your Home Page in Safari Prefs to CNN and see if that makes a difference... just to see if Safari behaves.

    http://www.cnn.com/

    Also, since you are running SL...

    If you are running Safari in 64 bit mode, try running in 32-bit mode instead. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode.

    I've asked a Safari guru to help with this. He has more experience then I do. Hopefullly he can shed some light on this that I might be missing.







    Message was edited by: Carolyn Samit
  • Jeff Hoogmoed Level 2 Level 2 (170 points)
    Thank you again. I did but it keeps reverting as well. Frustrating!
    And I'm running 10.5
  • Carolyn Samit Level 10 Level 10 (98,795 points)
    Ok Jeff,

    You're welcome.. that is frustrating, I agree.

    Try Clearing Just Your Google History:

    1. Go to the Safari Menu
    2. Select Preferences
    3. Select Autofill tab
    4. Select the Edit button from the Other Forms Line
    5. From the AutoFill list of sites select Google.com
    6. Select Remove
    7. Select Done

    Restart your Mac.

    If Safari still resets itself, go to the Safari Menu Bar, click Safari/Preferences. Make note of all the preferences under each tab. Quit Safari. Now go to ~/Library/Preferences and move this file com.apple.safari.plist to the Desktop. Relaunch Safari. If Safari behaves, then that .plist file is corrupted and needs to be moved to the Trash.










    Carolyn
  • Klaus1 Level 8 Level 8 (46,790 points)
    Hi Jeff!

    Try this:

    Go to Safari Preferences/General and delete your entry for whatever Home Page you have set.

    Then close Safari.

    Go to Home/Library/Safari and delete the following files:

    History.plist
    form values
    download.plist
    LastSession.plist
    TopSites.plist

    Then go to Home/Library/Preferences and delete

    com.apple.Safari.plist

    Now go to Home/Library/Cookies and drag (do not delete) the cookies.plist file to the desktop.

    Repair permissions (in Disk Utility).

    Start up Safari again and test whether the error still occurs.

    If it does not, if everything seems OK, close Safari and replace the cookies.plist in the Library/Cookies folder.

    Test Safari again. If the error has returned delete that cookies.plist file (sorry, you will lose all your bookmarks).

    Restart your Mac and test Safari again.

    Please post back with results.
  • Jeff Hoogmoed Level 2 Level 2 (170 points)
    Thank you all for your quick responses. Safari seems to be behaving itself for a few days now with several restarts since. Since its not broken (at the moment), I'm not going to do anything, if it starts to act up I will go right back to the forum and implement your suggestions.

    Again, thank you.