4 Replies Latest reply: Apr 7, 2010 9:48 AM by bbold
BJNYC Level 1 Level 1 (0 points)
I can't use Photobooth - when I open the app, I get the message: "Photo Booth couldn't save your photos - Photo Both encountered an error when trying to save your photos. You photos cannot be saved at this time."

I've tried deleting the photobooth preferences file and rebooting. Doesn't work.


iMac 24 2.33 GHz Intel, Mac OS X (10.6.2), Photo Booth and Insight cam
  • BJNYC Level 1 Level 1 (0 points)
    A new wrinkle:
    I note that when I use a different account on this iMac, there's no problem with saving files. So this must have something to do with my (administrator's) account?
  • maahs_k Level 1 Level 1 (0 points)
    check your photo booth folder permissions

    macintosh hd/users/your_user/pictures/"photo booth"

    I've had a number of the machines at my building have that folder's owner become blank or change to system.

    once you have the folder selected in the finder go to
    File->"Get Info"
    and if your user isn't listed as the owner with
    read & write
    privileges then click the + to add your user and/or change your privilages then try to take a picture in photobooth.
  • MisterL1 Level 1 Level 1 (0 points)
    i did this and the pictures folder came back, i can see my pictures now and now the Photo Booth app takes a picture but it freezes after taking the picture and still doesn't save it. It doesn't come back either as if its ready to take another picture. I'm having a problem with iPhoto and i'm sure the two issues are related. iPhoto won't open at all, i've restored it from backup etc but i guess i'll have to find another discussion for that one but ...my Photo Booth no longer gives me the "can't save your photo's" message but won't save the photo's just the same.
  • bbold Level 1 Level 1 (5 points)
    I did what you suggested Maahs and it fixed my own Photo Booth problem that no one else on here could fix. Permissions were wrong on the Photo BOoth folder. Thanks!