1 2 Previous Next 24 Replies Latest reply: May 25, 2010 6:02 AM by Seriph Go to original post
  • 15. Re: Mac Mail Not Receiving New Mail from Exchange
    bg1999 Level 1 Level 1 (40 points)
    The rebuild command is located under the Mailbox item in the mail menu. It will create a fresh index of all messages in your inbox. Right now I have about 10,500 and it has helped to rebuild it occasionally.

    I guess you could rebuild trash but it's better to start with inbox and sent.

    bg
  • 16. Re: Mac Mail Not Receiving New Mail from Exchange
    gangee Level 1 Level 1 (0 points)
    Hi everyone,

    I've received all the emails, tried every suggestion. Nothing works.
    I hope Apple is paying attention here.
  • 17. Re: Mac Mail Not Receiving New Mail from Exchange
    bg1999 Level 1 Level 1 (40 points)
    My next thought is to take down the existing account and start again. I've also had great luck with Applecare in dealing with Exchange issues.

    If you're connecting to Exchange 2007, you can choose that as an option in Snow Leopard. The advantage is it supports auto-discover that determines what the config should be and sets it up.

    Another option is trashing the mail plist and starting fresh. That specifically solved a problem I had with duplicate messages but it also sped things up nicely. Here's that link.

    http://discussions.apple.com/message.jspa?messageID=10605469#10605469
  • 18. Re: Mac Mail Not Receiving New Mail from Exchange
    KooKooo Level 1 Level 1 (0 points)
    I have same problem... snow leopard latest, apple mail and exchange server. It hangs with 'adding messages' usually and I tried again and again to show up latest mails on my inbox. Connection doctor told there is no problem. Sometimes rebuilding message index helps (quitting Mail, removing ~/Library/Mail/Envelop Index and running Mail and wait for rebuilding message index) but from yesterday it doesn't work also.

    My mailbox is big (~3G) so it might be a problem but Outlook (same PC but on vmware fusion) and Entourage works well.

    I think it's a critical problem for Mail.app with Exchange server.
  • 19. Re: Mac Mail Not Receiving New Mail from Exchange
    KooKooo Level 1 Level 1 (0 points)
    I removed ~/Library/Mail and re-configure my Exchange.
    I had to reconfigure my rules setting but it works ok for now.
  • 20. Re: Mac Mail Not Receiving New Mail from Exchange
    Level 6 Level 6 (11,035 points)
    I have also tried all these suggestions and nothing helps. It happens on my laptop and on a Mac Pro that never goes to sleep. This has to be a bug in Mail.app
  • 21. Re: Mac Mail Not Receiving New Mail from Exchange
    tobyintheUK Level 1 Level 1 (0 points)
    I am also experiencing this problem. I really don't know what the root cause is, but it is certainly very frustrating.

    Another thread suggested that this issue might be to do with corrupt messages in the mailbox. However, I'm not entirely certain how one goes about finding corrupt messages. I gather that the Event Log on the Exchange server may say something (but getting IT at my institution to try and help with this would be futile...).

    For now, I just deleted everything in ~/Library/Mail and am just re-syncing after setting the account going again. Will see what happens...
  • 22. Re: Mac Mail Not Receiving New Mail from Exchange
    D-OveRMinD Level 1 Level 1 (0 points)
    I just said screw it and upgraded my old Entourage 2008 to the new web services edition. Works great now and MUCH faster than before. Haven't had an issue since. Way faster and less clunky than the built in Mail client. Plus my contacts, calendars, email, etc are all in the same program so I don't have to keep switching back and forth. Nice try Apple, but your mail client is just not ready for business prime time yet.
  • 23. Re: Mac Mail Not Receiving New Mail from Exchange
    rstockm Level 1 Level 1 (0 points)
    Same problem here. Things got better with 10.6.3 but I have to restart Apple Mail every two days or so. I see this bug on two computers - one never going to sleep, the other one on a regular basis.
    Would love to see this fixed, is there an official record in the support database for this? It doesn't seem that rare a problem...
  • 24. Re: Mac Mail Not Receiving New Mail from Exchange
    Seriph Level 1 Level 1 (15 points)
    I've been seeing this problem for months too. From various experiments and searching on the net I suspect that it's down to a problem with delivery rules running on the Mac. If it's an option, you could set up server side delivery rules on the Exchange 2007 server (using an Outlook client) to perform the same actions as your local rules and then disable the local rules. It's still a shame that this has not already been fixed, or at least acknowledged, by Apple.
1 2 Previous Next