Previous 1 9 10 11 12 13 Next 189 Replies Latest reply: Jan 24, 2015 8:13 AM by fiberhome Go to original post Branched to a new discussion.
  • erik kane Level 1 Level 1 (0 points)

    This was helpful. I have generic DvD-Rs for my superdrive, on a macmini.

    Trying to burn a disk failed immediately.

    I lowered the copy speed from 8X to 4X (and quit all applications) and it failed at the verify stage.

    I lowered the burn speed to 2X and it completed the copy and verify.  (Success)

     

     

    I took the time to post because this is a long standing Mac issue and I see that people are lowering the speed from 24X... it may come down to really slow burn rates. 

     

    For sake of trouble shooting you should start with lots of available RAM/processer and low speeds.  Increase the speed from there if successful, otherwise trying burning smaller bits as a capacity test. Buying 4 brands of disks takes much longer, but that would be the next trouble shooting step.

     

    As a final aside, I have had 'disk burning' issues for as long as I can remember on both PC and Mac. In most cases it was a fail on verify and I found certain disk brands had better or worse fail rates. I do believe the brand/type matters - but in relation to this thread, the speed I tried to write to disk had a direct impact on how far through the process I could get before it errored out.

     

    Good Luck!

  • krbusby Level 1 Level 1 (20 points)

    OP here;

     

    It's been more than four years since my original post. I have posted an update or two but not for a while.

     

    I have now owned four Macs and the drives have all failed except one, and it's starting to not read reliably, so I guess that means it is actually failing as well.

     

    Apple sometimes refuses to correct something if they plan to phase it out anyway (another example of this is the MacBook White cracking case issue), and these drives seem to be one of those things. I hardly use discs any more and will probably just use the bay for an SSD drive.

     

    The only reason I still have a Mac at all is that it's the lesser of two evils, having earned five programming Certs on the Windblows environment I switched to Mac out of disgust for Microsoft, I found that I can usually just get my work done on a Mac... usually.

     

    People have pointed out that some brands of discs are more reliable than others, and that may be true, but most discs come from one of about three producers and are just labeled by different companies.

     

    Reducing burn speed helps, I always burn at half speed. But these are temporary fixes, well, not really fixes at all.

     

    I appreciated everyone that's contributed to this topic.

     

    In another year or two we won't even have Macs with optical drives anyway so Apple needn't worry about it any longer.

  • beekayApple Level 1 Level 1 (0 points)

    I too have have this problem since I bought a Mac and my luckily PC seems to bail me out.  The one thing that I do seem to have luck with is R/W disks.  I burn to the R/W disc, verify that I like what I did, then I use my PC to copy the disk and burn it to a regular disk.

     

    I know that doesn't help with people who don't have addtional computers around, but that is my work around.

  • beekayApple Level 1 Level 1 (0 points)

    By accident I finally found a solution to my error code "0x80020022".

     

    I am using an external USB connected Blue Ray burner.  I decided to connect the drive to my mac via a USB hub instead of directly to the computer.

     

    My drive burns fine now.  I have burned a few CD-R and a few DVD-R to verify, and it seems to work everytime now. 

     

    I have no idea why this would really matter but it seems to work this way.  ( I even went back to a direct connect to make sure it still had issues, and it did.)

  • krbusby Level 1 Level 1 (20 points)

    OP here.

     

    Another disaster. So annoyed I have to vent;

     

    Walked to my ex's in the pouring rain to scan some important receipts to PDF on her iMac and bring them home. Forgot thumb drive. Decided to burn the images to disc (ikr). Burned supposedly successfully. Took the disc out, put it back in, images were there.

     

    Walk back home. Insert disc into my only remaining Apple computer, 15" MacBook Pro. (Wait for it...) Optical drive failed.

     

    I've had a lot of DVD/CD players in my time. And really cheap crap, not quality brand names, and I've never had any of them fail, but I can officially say that EVERY Apple optical drive I've owned has failed! Every $@*^ing one!

     

    I'm glad this is the only Apple computer I have left. Next payday it's back to Windblows.

  • Oratsa Level 1 Level 1 (0 points)

    Hi krbusby,

     

    same here: OSX 10.9.5 on MacBookPro Mid 2009.

     

    DVD writer worked fine until today when it quit writing a DVD (using same kind of medium i used ever before), throwing:

     

    "The disc can’t be burned because communication between the computer and the disc drive failed (error code 0x80020022)."

     

    Nothing helped so far: SMC Reset, lower writing speed, changing burn-application, checking disk permissions - nothing.

    Reading CD's/DVD works fine! Hardwaretest also! And using an external USB-Writer of course as well...

     

    Just wanted to chime in: never had issues with any optical writer of any provenance, including cheap road warriors PC Laptops that really have been rocked hard. But have mutliple issues with Mac's optical drives, be it for iMacs or laptops: at some point they always die. Being in charge of maintaining my organisations macs for years now may entitle me to claim my experiences are representative here.

    By the way never really bought what was so "super" with these "Superdrives", given that they are just stock drives, but crippled by APPLE's firmware to prevent them to write DVD-RAMs and dying later on...

     

    For me this particular aspect has always been one of the dark spots on the Mac-Myth: "Super" should also deliver "Super", this is a premium product, after all...

  • gillfromsolihull Level 1 Level 1 (0 points)

    Hi I also have been getting the same error code it has been driving me mad. I also have problems with my Apple Mac pro recognising memory sticks this is infuriating as I store a lot of work on to them and then my laptop refuses to recognise them I have had to transfer my memory stick on to a windows laptop and then transfer them on to memory stick the Mac pro will read. Does anyone know how to get around this as I have loads of memory sticks which my Mac Pro won't recognise.

     

    The solution i have found to burning DVD or CD is to download a different software the one I have downloaded is called BURN and it works I have managed to burn films on to a larger gb DVD

  • nerveonepro Level 1 Level 1 (0 points)

    Same Same still destroying my blank DVD's

  • AHappyMacUser Level 1 Level 1 (0 points)

    "By accident I finally found a solution to my error code "0x80020022".

    I am using an external USB connected Blue Ray burner.  I decided to connect the drive to my mac via a USB hub instead of directly to the computer.

    My drive burns fine now.  I have burned a few CD-R and a few DVD-R to verify, and it seems to work everytime now.

    I have no idea why this would really matter but it seems to work this way.  ( I even went back to a direct connect to make sure it still had issues, and it did.)"

     

     

     

    This solved my problem also!  It seams very odd that connecting via a USB hub would fix the problem, but it works for me.  Thanks for the idea!

  • fiberhome Level 1 Level 1 (0 points)

    I've had an odd variation after upgrading my MacMini 2010 to Mavericks. The internal Superdrive seems to burn a DVD correctly, but then stops somewhere along the line of burning and verification, as if it forgot about the whole thing. The DVD does not show up in the finder or in Disk Utility, but it is ejected on restart. When I reinsert it, the Mac thinks it's a blank DVD, but I can see that it was written about 3/4s of the way out from the center. My MacBook Pro also sees it as a blank disk, but it does let me run Disk Utility to check it. I get an error saying "Invalid B-Tree node size." So far I've had two DVD burns fail (using the finder), but I was able to burn a CD-ROM with the same set-up.

     

    The MacMini still is able to read DVDs that it burned earlier.

     

    Any ideas what might be wrong?

Previous 1 9 10 11 12 13 Next