1 5 6 7 8 9 Previous Next 183 Replies Latest reply: Jun 16, 2014 10:38 AM by beekayApple Go to original post Branched to a new discussion.
  • 90. Re: I get "error code 0x80020022" when I try to write to disc.
    treedodger Level 1 Level 1 (0 points)

    i keep getting both error boxes the laser calibration and the 0x80020022,

    everytime i try and burn a dvd i had no problems on snow leopard its just started when i upgraded to lion a month ago,

    now i wish i hadden't bothed.

    oh ya with trying to burn with just using finder i only get the option of 4x burn speed why it can be asked to ask you for the option and the drop down box as only got 4x i don't know.... and it doesn't do it anyway,

    i feel a little let down by apple....

  • 91. Re: I get "error code 0x80020022" when I try to write to disc.
    aricfromhouston Level 1 Level 1 (0 points)

    Can anyone tell me if purchasing an application like Toast will resolve this issue?

  • 92. Re: I get "error code 0x80020022" when I try to write to disc.
    .:SiLo:. Level 1 Level 1 (0 points)

    This is an ongoing problem all the way back to OSX Tiger. It has been posted elsewhere and there are many threads you can follow.

    I'm sorry to say, but it is likely that Toast or any other similar application will not work. My Macbook Pro lost it's ability to burn discs (both with the SuperDrive or external burmers!) when I upgraded to Snow Leopard.

    I am convinced from my own research that this is due to a bug or risk that occurs when flashing your computer's EFI .

  • 93. Re: I get "error code 0x80020022" when I try to write to disc.
    treedodger Level 1 Level 1 (0 points)

    hi ... no toast tried that doesn't work once you got this efi update you've finish burning dvd's no programs out there will help its the systems firm ware thats the problem its not communicating with anything to do with dvd burning with toast all you get is internal hardware failed box mind you toast does wright the lead out rendering the disc unusable same as visual hub just destroys a disc ..finder just give you the error 0x80020022... itunes still burns music cd's .....

  • 94. Re: I get "error code 0x80020022" when I try to write to disc.
    .:SiLo:. Level 1 Level 1 (0 points)

    Yeah - weird that audio CD's can still be burned. My guess is that newer cd disc drives have higher power - more accurate lasers than in the recent past due to dual layer discs. I think the EFI wants to calibrate the hardware to a newer standard that the older drive isn't capable of. What is so frustrating is that I know that my SuperDrive is technically fine; however, even if I downgrade my OS to as far back as Tiger (YIKES!), the EFI flashing only goes one way - meaning I cannot roll back my EFI to a former iteration where my system worked. I tried a complete wipe and install of Leopard (when everything was still fine) and no dice - waste of 3 hours and back to square one.

  • 95. Re: I get "error code 0x80020022" when I try to write to disc.
    Kronstat_Kid Level 1 Level 1 (0 points)

    I had a similar experience on my iMac.

    For whatever reason, I actually LOOKED at the speed at which the burn was to take place.

    Mine said 24X - yes Twenty-Four.

    Check the default speed.

  • 96. Re: I get "error code 0x80020022" when I try to write to disc.
    stoduk Level 1 Level 1 (0 points)

    This is quite some thread!

     

    I've got a 2008 Macbook Pro (with OS X 10.6.8) and a while back started hitting the infamous 0x80020022 error code when burning disks.  I've used my DVD burner for ages without problems - recently I was part way through burning a bunch of files to disk over a couple of days - everything worked for the first couple of disks, then the last one failed - and since then every disk has failed.  I'm not sure if an upgrade got installed part way through this, unfortunately I wasn't looking out for it..

     

    So - what to do when this error is hit?  It seems there are plenty of people here who have ideas about what can/can't fix this, so thought I'd try to pull this all together.  Hopefully this list will help anyone who hasn't tried the "obvious" stuff, and maybe someone out there can suggest something I've missed

     

    1) try other brands of disk

    -- I'm using verbatim, these worked for *ages* (same pack of disks - I picked up a couple of 50 disk packs when they were cheap, I was half way through one when things broke), now consistently don't work.  I've tried other known brands I have around, again with no luck.  Just throwing away bad disks is getting expensive

     

    2) try external drive

    -- I tried a known-working USB DVD burner, and had no luck - hit the same error.  This makes me assume the drive in my MBP is ok, so this is probably a software (or firmware/EFI?) issue.

     

    3)  fix permissions

    -- I've told OS X to fix system file permissions a couple of times, each time it completes ok but on the next run through finds more files that aren't fixed (which suggests each run isn't necessarily doing what is intended).

     

    4) create new account

    -- I've not tried this yet.  Have people actually had success with this? Do I simply need to create another user account on my laptop and everything will then work?  Or are there more steps?

     

    5) Language settings

    -- some people have reported that this can fix things, others have suggested this has been shown to not be doing anything.  Anyone know anything more definitive?

     

    Is there anything else to be added to the list?

     

    It seems that changing the drive is futile if an external drive is broken.  It seems that paying for Toast is equally pointless, for similar reasons.  I could get to an Apple store, but that means a day trip to London and not convinced from what people said that it would necessarily help (as they'll just want to charge me to replace what is probably a functional DVD drive!).

     

    TIA,

    Anthony

  • 97. Re: I get "error code 0x80020022" when I try to write to disc.
    treedodger Level 1 Level 1 (0 points)

    Hi Anthony nice list

    with the fix permissions i also tried the osx to fix permissions and i tried main menu pro i run them both one after the other still finding files to change .. but this didn't help any way just wasted a couple of hours, still got the error codes

    I been reading though all these treads and came across one guy in the states having the same problems with apple changing his drive with a new one and still having this issue so it looks like having it replaced as you say is futile

    brand of disks yes i done the same bought 400 disks that worked in a closing down shop cheap used about 20 of them and now cant use them i have tried 6 or 7 different brands but you just know this isn't the problem just wasted about 10 or 12 discs trying ....

     

    terry.

  • 98. Re: I get "error code 0x80020022" when I try to write to disc.
    .:SiLo:. Level 1 Level 1 (0 points)

    Thank you Athony for putting a list together for everyone! Makes it a lot faster for people to learn about and then try these different methods to see if it helps.

     

    There is one more possible fix to add, but it will only apply to a few people and you must be a bit more of an advanced user. It is possible to rollback your EFI to a previous version, but only for EFI 1.8 or earlier and only for a late 2008 unibody MBP - so that means it's useless for most! After doing some searching, you might find the tool which was accidentally released into the public from a Genius to a customer in Russia (Sorry, but I can't include the link due to forum rules). They (the Genius) gave the user a tool for downgrading the EFI. From what I read, everyone that had a configuration suitable for the tool had 100% success: burning was restored along with random beachball temp lock-up issues fixed.

     

    FYI: the EFI update is normally part of the regular Software Update tool built into OSX and is almost always 'hidden'. To see if an EFI update is applicable to your OS update (normally a combined update) you must read all of the details! My EFI was updated when I had a message that my SUperDrive needed updating due to a noise the drive wuld make when starting up. The update didn't fix the noise, and my SuperDrive or anything else would not burn after that.

     

    What I keep saying - corrupt EFI. I am not a programmer, but I believe it could be possible for Apple to make a simple tool which reads a systems hardware configuration and compares that to the tables written in the EFI for errors. If there is a problem, the tool could make a correct EFI set to re-flash. Of course this would mean that Apple would have to admit that flashing can 'damage' your hardware (which is the truth about flashing) and this would open themselves up to hundreds of thousands of customers rightfully demanding fixes. Do the math - if we can't prove, they won't act. Period.

     

    My bottom line - and I'm sorry for being so negative but - you will probably never be able to burn again on your system, no matter what you do. Of course try all of the fixes. Some people claim success, but I feel if there was truly a way to fix this ongoing problem, we would know about it by now.

  • 99. Re: I get "error code 0x80020022" when I try to write to disc.
    Singwith Level 1 Level 1 (0 points)

    I had the same issue and tried the CD lens cleaner and it works fine now.

  • 100. Re: I get "error code 0x80020022" when I try to write to disc.
    Motorcycle Michael Level 1 Level 1 (115 points)

    Quite a thread indeed, and the problem just confuses the heck outta me (for one). Just when I was convinced it was a firmware issue - and still might be - in comes a 2.4GHz C2D MBP 15" with a physically damaged drive that only spins and spits out all discs. Replaced it with a new, identical, apple-branded (important for boot firmware) S10N-A drive. Then installed OS upgrade from 10.5.x to 10.6.3. Test burn a DVD and bingo: 0x80020020 error (using a quality Sony disc).

     

    But, after running all available updates to top of Snow Leopard (10.6.8), it burns full speed (8X) both Sony and Memorex DVDs perfectly. Go figure. People running Lion on new machines are also complaining about this error, and it goes back to Tiger (if memory serves). Anthony might have actually worn out his drive and arrived here from use (maybe?), but new machines and working machine that fail after updates/upgrades? Very strange.....

  • 101. Re: I get "error code 0x80020022" when I try to write to disc.
    stormko Level 1 Level 1 (10 points)

    Considering that Apple appears to be moving away from physical media, even taking optical drives out of the MacBook Air, perhaps they no longer care about issues with burning discs, even if their customers are stressing about it. They also don't update iDVD anymore for iLife. They just don't seem interested in dealing with this sort of topic. It wouldn't be the first time Apple left their customers behind on an issue.

     

    The message seems to be: If you want to back up something, do it on another hard drive (via Time Machine) or in the cloud. Wanna burn a DVD? We don't care about that anymore. And Blu-ray—what's that?

     

    So that's it. It's over. They'll never address this. Apple has moved on.

     

    By the way, I say this right after my Super Drive wasted three DVD's as I tried to burned something. Another victim of the ol' 0x80020022.

     

     

  • 102. Re: I get "error code 0x80020022" when I try to write to disc.
    treedodger Level 1 Level 1 (0 points)

    my imac 27" was running quite happily on snow leopard burned off some holiday pictures for a friend in the morning really go pleased with my mac then in the afternoon upgraded to lion ... my mate came around that evening slipped the disk in to show him and the machine just spat it back out after serival times thought it might be a dodgy disk pushed a new disk in tried to burn the pictures again all i get is this error code and have done since ...so snow leopard guy's don't upgrade because quite possibly you will never be able to burn anything again ...looking now to upgrade to a machine that i can relie on for burning so sorry apple looking at windows you left us we leave you thats about it isnt it! ..

  • 103. Re: I get "error code 0x80020022" when I try to write to disc.
    diveactive Level 1 Level 1 (0 points)

    They still have allot to answer for ref to this matter. Cleaning up to do. They are like a politicle goverment .

    Now matter what we say, They hold the reins . It breaks the trading standards, And dtrade discrition act. If your in the UK.

  • 104. Re: I get "error code 0x80020022" when I try to write to disc.
    tonyfromhenderson Level 1 Level 1 (0 points)

    I ... FINALLY ... tracked down pertinent feedback from "Snapple";

    http://support.apple.com/kb/HT2718?viewlocale=en_US     As I discover more to help you, I'll post it ...

    And I must say, it's pitifully inadequate. You may opt to curtail "Chasing The Dragon". The TRUTH is, Apple stays in bed with Them that Brung 'em, & for ANYONE using different hardware than what Apple installs ( or extorts licensing $ from), you/we are outta luck.

    My G3, G4, eMac & iMacs have ALL required replacement parts. Some work, some don't. Being on Social Security @ 65 & Physically Wasted from DECADES of Rock & Roll Tours, I am NOT spending the Insane Yuppie-Snot $ to "upgrade" to a $600 Used G5 just to say I'm still hangin' w/ Apple. I just bought an '88 Benz 560SEL for $650! Passed smog & carted my Ol' Behind to Vegas & back with ...comfort, speed & lunatic handling" ...

    My FrankensteinPC was put together in 2 days w/ spare parts for chump change, & the Toshiba COMBO Super Drive 109 ($27 @ Action Computers here in Denver) works PERFECTLY with it, yet All THREE Apples give the S.P.O.D. Stream of 0x80020023 errors ... Speaking JUST for Me ... selling all the Apples, & spending the $ on my Grandsons, while I burn 28 GB of iTunes on 8 DVDs of MP3s so they can hear the bands I used to work for & tour with. I'm too Old to be bothered with "Status BS" ... Toast, Patchburn, Burn apps all are Valiant Efforts, but 10.3.9, 10.4, 10.5 despise your feeble attempts to "Burn DVDs", & will drive you to drink ... Time for ANOTHER Guinness! Cheers ...

1 5 6 7 8 9 Previous Next