7 Replies Latest reply: Feb 16, 2010 11:42 PM by Erik Juhl
MikeCarbone Level 1 Level 1 (0 points)
Just today, my MacBook Pro was acting strangely. I inserted my flash drive, and some error message came up. Earlier, the flash drive was acting fine, so I figured something must have gone wrong, no big deal. To my memory, it mentioned "the disk you have inserted could not be read on this computer". So I erased it via disk utility, not much of a problem. Anyway, later on I plugged my camera in, to which i received a message stating I had a problem with some "family.kext" file. So I restarted my computer. Instead of starting up, I saw a Circle With Slash, and loading gear. Completely out of nowhere. Didn't install any strange software, it was working perfectly the night before. So I started it up on Safe Mode, which fortunately it did. After investigating Disk Utility, I knew that it could not be a hardware problem, seeing as my disk was verified in SMART status.
Now I've tried everything I could. Verify Disk, Repair Disk, Verify Disk Permissions, Repair Disk Permissions, in Disk Utility. I've also reset the PRAM. Personally I'd like to fix this issue myself as I've received my certification in Apple Repair, and to have to surrender it to the Genius Bar for a few days would be a great inconvenience. Although I guess I might not have any choice in the matter.
If you can help in any way. I will be very grateful. Thank you

15" MacBook Pro - Late 2008, 2.66 GHz, 4GB RAM
  • 1. Re: Circle With Slash - Kernel Panic
    Barney-15E Level 8 Level 8 (35,295 points)
    See [this article|http://support.apple.com/kb/TS1892]. What you see generally means something bad has happened to a critical boot file and reinstalling is probably the only solution. But, there are some things to try.

    However, I had a drive go bad with various strange behaviors and verified SMART until it failed completely.
  • 2. Re: Circle With Slash - Kernel Panic
    thomas_r. Level 7 Level 7 (27,985 points)
    Instead of starting up, I saw a Circle With Slash, and loading gear.


    That's not actually a kernel panic. A kernel panic is when you see a screen with the same message repeated over and over in multiple languages.

    For help with the problem you're seeing, try this document:

    http://support.apple.com/kb/TS1892?viewlocale=en_US

    After investigating Disk Utility, I knew that it could not be a hardware problem, seeing as my disk was verified in SMART status.


    That does not remotely indicate that you don't have a hardware problem. SMART status is notorious for being a bit unreliable, and for indicating that a drive is just fine moments before it dies. It also has nothing to do with other places that you could have a hardware failure. You could try running [Apple Hardware Test|http://support.apple.com/kb/HT1509], though it is also not foolproof.

    I'd like to fix this issue myself as I've received my certification in Apple Repair


    Not meaning to be offensive, but that's a little scary. Seems like this ought to be something you ought to know more about if you're certified to service Macs...? Not that this has anything to do with solving your problem, I just find it interesting, and wonder what the certification entails.
  • 3. Re: Circle With Slash - Kernel Panic
    MikeCarbone Level 1 Level 1 (0 points)
    I don't have my Snow Leopard DVD on me, so basically I'm trying to get creative. And yes, I'm following all the steps that I have been trained to do. And as much as I don't have to explain myself to you, I just have to search around for different ideas, as most of my equipment, along with my DVD, are back up in college. While you're not trying to be offensive, you are. So if you'd be so kind, leave your comments out of the discussion forums.
  • 4. Re: Circle With Slash - Kernel Panic
    thomas_r. Level 7 Level 7 (27,985 points)
    I don't have my Snow Leopard DVD on me, so basically I'm trying to get creative.


    You're probably not going to be able to solve this one without your Snow Leopard DVD.

    While you're not trying to be offensive, you are.


    I'm sorry, I really wasn't meaning to insult you. I'm not questioning your intelligence... I was questioning the teaching you received as part of your certification, since there did seem to be a couple gaps. Either that or it's just a matter of miscommunication. In any case, I apologize for the offense.
  • 5. Re: Circle With Slash - Kernel Panic
    MikeCarbone Level 1 Level 1 (0 points)
    It's alright. Let's just forget it. At any rate...It's definitely not a hardware problem, as I'm using the computer on Safe Mode now. And have restarted several times with safe mode successfully. I'm having a friend do an archive and install tomorrow, afterwards I'll do a Time Machine backup (can't now because IOStorageFamily.kext got screwed up and won't accept USB/firewire or any input for that matter) and then do a clean install when I get my DVD back, and do a clean install, and add my Time Machine backup with it.

    No hardware issues were detected with TechTool Deluxe. Somewhere in my system files, something got messed up. Along with IOStorageFamily.kext

    I'm just wondering how this might have occurred. As I can't find any real reason it may have. Either way the problem should be resolved tomorrow.
  • 6. Re: Circle With Slash - Kernel Panic
    Bobby L. Level 1 Level 1 (0 points)
    Wow Mike,

    I am so glad I found this. This too also just happened to me. Strange that it happened to you as well only a week earlier.

    Perhaps we can retrace our steps to find any similarities so that others can be aware and maybe resolve our issues.

    It all started when I tried to reconnect a HD I had originally plugged into an hacked ATV. It would not mount. After a few restarts and switches from FW400/USB and back, it finally mounted. Concurrently I ended up installing some apple updates I've been neglecting figuring that I had to restart anyway. I was going to copy the content onto another drive two daisy-chained Lacie D2 via FW800. Then I got the same message as you:

    SYSTEM extension cannot be used:
    The system extension "/System/Library/Extensions/IOStorageFamily.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update.

    Upon restart i get the gray screen with the apple logo and spinning circle then it turns into the circle with the slash through it. Won't boot or anything. I was able to boot in safe mode and trying to figure it out as we speak. I had tried to copy an old iostoragefamily.kext file from a backup but same result (although I havent tried a restart). I also still can't get anything to mount so I can't access my time machine.

    Had booted under the original MBP restore disc that had the older 10.5. Did a repair disc and under volume it read:
    Invalid volume file count (It should be 833415 instead of 833416)
    Invalid volume directory count (It should be 233458 instead of 233457)
    Repairing volume

    It repaired it but upon restart, same result.

    ***

    This is where my stupidity comes in, I did not realize that I had checked to exclude my system folder from Time Machine. So I can not just revert back to last save. My question is, if I am running 10.6.2, and have my original MBP system restore disc, is it possible to restore to 10.5 then copy everything over from TM. From there should I then upgrade back to 10.6? Or should I try and find 10.6 and restore from that disc and copy everything back from TM. Reason why I ask is cause I've read SL is optimize to be as a Leopard update install as oppose to stand alone.

    What was your final solution to this issue? Did you ended up going straight to the 10.6 disc to restore or did you restore from TM?

    Thanks

    -Bobby
  • 7. Re: Circle With Slash - Kernel Panic
    Erik Juhl Level 1 Level 1 (10 points)
    I had this. Same deal: disk repair, disk permissions, hardware test all were clean and didn't help, safe boot worked but didn't magically get things set right, etc., etc. Was resigned to an archive and reinstall, or an erase and reinstall.

    But here's how I avoided that and got up and running again:

    Held shift-command-v down at startup (as described here in the "safe boot" section). Got a screen that displays the system's status during its bootup steps.

    In my case there were a number of references similar to this:

    <pre>Kext com.apple.driver.DiskImages - library kext com.apple.iokit.IOStorageFamily not found.</pre>

    In each case, IOStorageFamily was cited as not found. I safe booted and found the .kext file /System/Library/Extensions/IOStorageFamily.kext, so I assumed it was corrupt. I was able to go back into my Time Machine folders and manually locate an older backup of that file. I right-clicked it and was given the opportunity to restore it to any location, so I did so, selecting the option to keep both the apparently corrupt version and the older, probably clean one. In order to restore a system .kext file I had to supply my password. The corrupt version was saved as IOStorageFamily (original).kext next to the new version.

    Caveat: The only time I would do this is when I've resigned myself to reinstalling the OS anyway. I bet a lot of you are smart enough to know what's safe etc. but I am better off playing it safe. I felt it couldn't hurt in this case. I would strongly recommend that if you try this you keep the "original" or "corrupt??" version of any file you replace with an older one.

    As they say: HTH, YMMV.

    Now to figure out if something is going to keep corrupting that file.......