10 Replies Latest reply: Jan 23, 2010 2:11 PM by bphsmac
bphsmac Level 1 Level 1
I have a game that I'm trying to download, however it is not allowing me too. It is saying that I need "Admin Privileges." I'm the administrator and I've gone through all the steps that make me the admin. I'm stuck! Can anyone help?

iMac, Mac OS X (10.6.2)
  • musicwind95 Level 4 Level 4
    What game? Where are you downloading it from?
  • dechamp Level 4 Level 4
    What browser?
  • bphsmac Level 1 Level 1
    It's not a download from a website. It's called Diner Town Tycoon. It was a Christmas gift. It says in fine print on the box that Admin Priv. are required. Im very new to the Mac world. All I know is it says Safari on the icon i click to get to the WWW.
  • bphsmac Level 1 Level 1
    I believe 10.6.2.
  • bphsmac Level 1 Level 1
    Im new to the Mac world. By browser do you mean Safari?
  • dechamp Level 4 Level 4
    Yes, a browser is a program that's used to go online and view web sites. Mac's come with Safari and some people prefer FireFox. Windows comes with Internet Explorer and some people prefer FireFox. There are many others available like Chrome from Google, and Opera.

    So you are not downloading a game, you are trying to install it from a disc. Big difference in terminology. Since nobody can look over your shoulder we assumed you were trying to download a program over the internet.

    The web site for your game is here: http://www.diner-tycoon.com/

    There is a "Contacts" link at the bottom of their page that you can use to ask them questions. The site says the program is good for 10.4 and 10.5 but doesn't mention 10.6 at all. That doesn't mean it won't work, but their site doesn't say so.

    When you begin the install from the disc, you might be getting a warning that the installer requires an Admin account. It should also pop up another window with your User Account filled in and a place for you to type your Admin password.

    Games like this could also require Rosetta (a technology Apple provides for compatibility with older programs or to run PPC code on an Intel Mac). If Rosetta is not installed on your Mac, another window should pop up asking you if you want to install it. Here again you'll have to type in your Admin password.

    It's possible that the game is not compatible with Snow Leopard at all. Here is an earlier post about the same game, with no resolution: http://discussions.apple.com/message.jspa?messageID=10394245

    Hope some of this makes sense.
  • musicwind95 Level 4 Level 4
    In that case, and assuming that you have indeed made yourself the admin, then whenever it asks for administrator privileges, just type your password and let it continue.
  • bphsmac Level 1 Level 1
    That other window you are talking about doesn't show up. It just says Admin Priv. required and quit. I have an appointment with a genius, so I'll just wait. I'm new to the Mac world, so I'm going to wait to download Rosetta. I'm also going to assume that it's not compatible with 10.6.2. We'll see. Thank you for your help.
  • wdarby Level 1 Level 1
    I am having the same problem with a game called 'Wedding Dash'. Logged in from an account with admin privileges, I attempt to start the installer and get an error 'This installer requires admin privileges to run.' There is no option to login as an admin, it just returns an error. I enabled the root account and still get the same results. I'm going to email the support desk, but it looks to me that the installer does not correctly prompt for the admin password. I'll follow up with the game producer, but am doubtful of resolution.
  • bphsmac Level 1 Level 1
    I tried contacting the program company but to no avail. I don't think the game recognizes 10.6.2. Oh well. Thanks anyway.