Previous 1 2 Next 18 Replies Latest reply: Feb 26, 2010 5:26 PM by JE3
Stuart Dobbs Level 1 (0 points)
Dear God, please can someone help me with this problem?!!! I have made phone calls, checked websites and forums and no where can I obtain any help on what I would guess is a basic problem. I have a MobileMe account and an iPhone. I can't get the 'Find my iPhone' function to work on my iPhone. Whenever I switch it 'on' and then press 'allow', it instantly switches it off again. Why can't I get this simple thing to work. I'm desperate and getting angry. Please help me sort this problem. I have 'fetch' and 'push' all switched on.
Thanks in advance
Stuart

iPhone 16g, iPhone OS 3.0.1
  • wjosten Level 10 (94,210 points)
    Settings > General > Location Services On...Have you turned location services on?
  • Stuart Dobbs Level 1 (0 points)
    Yep, 'location services' switched on. The most aggravating thing is you go to switch the 'on' button on, then 'allow' and it instantly turns 'find my phone' off
  • wjosten Level 10 (94,210 points)
    Since iPhone OS 3.1.2 is recommended to use Find My Phone and required for Remote Passcode Lock, why don't you try updating your phone's software.
  • Byram Christensen Level 1 (20 points)
    Also under your me.com mail acct on the phone you have a Find my phone toggle switch..
    Setting>Mai,Contacts,Calendars>(Accounts)Me.com>Fidn My Phone -ON

    I hope that helps
  • Stuart Dobbs Level 1 (0 points)
    Thanks. Just checked 'about' in my settings and I do indeed have the latest 3.1.2 software (I'll update my user profile just now!). So, any other ideas because I am stumped and have tried everything. I am based in Glasgow, Scotland in the UK so am confident this service should work on my iPhone
  • Stuart Dobbs Level 1 (0 points)
    That's exactly where I am trying to turn it on from, I wasn't aware there was another way to turn 'find my iPhone' on?
    Thanks. Any other thoughts?
  • wjosten Level 10 (94,210 points)
    I'm out of suggestions, but here's the only support article I could find on the subject. Perhaps something here might help:

    http://support.apple.com/kb/TS2734

    Another simple thing to try is a reset:

    Try a simple reset: Press the sleep/wake button and home button at the same time, keep pressing until you see the apple logo, then release(ignore the slide to power off). You will not lose any data or settings.
  • Stuart Dobbs Level 1 (0 points)
    Thanks, I tried to reset but still no joy. Is there like a high level at Apple that I can get to sort this out as this us ridiculous. I am paying for a service that I can't fully use and it's **** frustrating. Why I can't just talk to a Human on a phone too is beyond me. Thanks for trying to help, if anyone else out there got any ideas I'd love to hear them.
  • wjosten Level 10 (94,210 points)
  • Stuart Dobbs Level 1 (0 points)
    Thanks, have been on this site too, thanks for trying though. Stuart
  • varjak paw Level 10 (169,822 points)
    Why I can't just talk to a Human on a phone too is beyond me.

    You can: (44) 0844 209 0611

    (it's not a toll-free number, though).

    You can also make an appointment at to the Apple Store on Buchanan Street and talk to a tech there.

    Good luck.
  • josephine davies Level 1 (0 points)
    I had the same problem, and I realised the @mac.com on my iphone needed instead to be @me.com... it was set up a while ago. I deleted the whole mobileme account on my iphone and started again, this time using username@me.com and then when i turned on find my iphone it worked. hope this helps.
  • JE3 Level 1 (0 points)
    wjosten and other experts,

    I have to turn "airplane mode on and off" to make the "find my iphone" work each time I start my iphone. But it only lasts 30 minutes or so. (with the iphone being switched on continuously) Then FMiP will stop working until I repeat turning on and off the airplane mode again. This sequence needs to be repeated after each 30 minutes or so.

    Is there any fix available for this problem? A friend said Apple has issued iphone software v 3.3 in Japan but I cannot find it here in Canada.

    Thanks.
  • Graham Outterside Level 4 (2,910 points)
    JE3 wrote:
    A friend said Apple has issued iphone software v 3.3 in Japan but I cannot find it here in Canada.


    Your friend is mistaken and also cannot write accurately

    Its 3.1.3 and has been available for quite a while.
Previous 1 2 Next