11 Replies Latest reply: Mar 18, 2010 2:26 AM by andrew_mcelvenney
andrew_mcelvenney Level 1 Level 1 (0 points)
Sometimes when i import an album from iTunes to my iPod, drag and drop the album not individual tracks, the tracks can become jumbled even when there in the right order on iTunes.
Why is this and how can i stop it as it's annoying.

Windows XP
  • iClive Level 1 Level 1 (0 points)
    Yea same here! It`s always happened since i stated using itunes years ago. I only ever drag and drop a whole album`s worth of songs into an itunes playlist and it rearranges the order such that the first few songs end up being the last few songs, and the last few end up being the first few. Mucho frustrating!!! It takes me a very long time to add a significant number of albums or artists to my itunes...
  • andrew_mcelvenney Level 1 Level 1 (0 points)
    Annoying dosn't come into it if you've got a "themed" album where the tracks follow on from/into each other.
  • aameerp Level 1 Level 1 (0 points)
    Sort by track number.

    You'll have to enable that column in your library browser through (right click and select from dropdown)
  • andrew_mcelvenney Level 1 Level 1 (0 points)
    Thanks but how/where do you do that.
  • ruso1989 Level 1 Level 1 (0 points)
    the fact is i fixed that sh*t to play pink floyd's "The wall" (wwoooooohhooo) err is smt like : select the album you want to rearrange, then : right click> get info > options. there is a check box : "remember playback position" that should do for the order. there is also gapless album (for albums like the wal in which a song etnters inton the next one without stop) ofc this optionwill change to gapless the whole library, since apple has messed up with this softwares
  • ruso1989 Level 1 Level 1 (0 points)
    the fact is i fixed that sh*t to play pink floyd's "The wall" (wwoooooohhooo) err is smt like : select the album you want to rearrange, then : right click> get info > options. there is a check box : "remember playback position" that should do for the order. there is also gapless album (for albums like the wal in which a song etnters inton the next one without stop) ofc this optionwill change to gapless the whole library, since apple has messed up with this softwares
  • aggiedad Level 1 Level 1 (0 points)
    I have tried everything listed in the responses in this thread. They SHOW in the correct order in iTunes when they are listed by Artist but the order of the songs (within an album) still get jumbled when they are transferred to my iPod. Any other suggestions?
  • andrew_mcelvenney Level 1 Level 1 (0 points)
    Yes i have the same problem as well.
    I've clicked on the ipod song menu in itunes (to bring up what i have on my ipod) chosen the option to show the album songs in number order which it shows they are but when i have disconnected and look on my ipod it still shows them as not being in order?????
  • metalhead29 Level 1 Level 1 (0 points)
    you might wanna try right clicking on the first song when you right click on the song click 'get info' a box will pop up with 7 options on it first one is summary and the last one is artwork click the one that says info and there you can correct things like track numbers,album names,song names,genre this usually will do the trick it work for me hope it helps ya'll
  • andrew_mcelvenney Level 1 Level 1 (0 points)
    The album track order MAY be in the right order doing that in the menu but shows in the WRONG order on the ipod screen. That is the annoying problem.
  • andrew_mcelvenney Level 1 Level 1 (0 points)
    In reply to my own question i've found out that if some of the album tracks have/have not got the "ALBUM ARTIST" either listed/not listed correctly this will cause them to be listed on ipod incorrectly.
    The solution is to either insert or delete, which ever you want, and the album tracks will appear in the right order.