Previous 1 2 3 4 Next 85 Replies Latest reply: May 17, 2015 4:20 PM by runningflames Go to original post
  • Hen3ry Level 2 Level 2 (495 points)
    Hello,

    Trying to print from an iMac running 10.6.x to a shared Canon Pixma iP4500 printer USB-connected on another local iMac running 10.5.x, I encountered the "printing on hold (authentication required)" blockage.

    I fixed it. At least for one test case.

    Here is what I did:

    After checking all the usual issues in the Sharing and Print-Fax Control panels without any improvement, and verifying that local printing functioned normally, I went to the local machine, opened a browser window, and entered this URL:

    http://localhost:631

    This is the control interface for the CUPS printing subsystem on that machine. (CUPS stands for "Common UNIX Printing System" and appears be the mechanism that makes printing work on MacOS X.) Then I chose the Administration tab. This revealed a button "Edit Configuration File". I clicked on that and got a editable window containing the configuration file. I located the following text sequence:

    ...
    <Location />
    Allow From None
    Allow From @LOCAL
    ....

    Interpretation: No printing request from a remote machine would be accepted. (Note: I neglected to write down the text I found there. I am fairly certain of the word "None" -- it was either that or something synonymous.)

    I changed this to

    ...
    <Location />
    Allow From All
    Allow From @LOCAL
    ....

    and saved the edit. At that point I was informed of a printing subsystem reset.

    I walked over to the "remote" machine and attempted to print on the Canon. It now worked.

    Note 1: The configuration file is available on the local 10.5.x machines that I checked, but it doesn't seem to be accessible on my 10.6.4 machine. Clicking on "Edit Configuration File" has no effect. Why? I think it may be a permissions issue. Security has been tightened on 10.6.4, I think.

    Note 2: There's an option to use the default configuration. But the default doesn't seem to say "Allow from None" or anything similar in the Location section.

    Here's my interpretation of what I'm seeing:

    Most, maybe all, adjustments that affect local printing end up modifying this configuration file. It accumulates changes over time, and gets progressively harder to read, and perhaps the printing subsystem becomes a bit confused. Maybe for that reason, or some completely different one, the text denying all remote accesses was inserted on the 10.5.x machine. Changes to GUI printing setup in the Print&FAX control panel or elsewhere may not be able to undo the damage, so a manual modification was required.

    hen3ry
  • mjcarlson Level 1 Level 1 (5 points)
    Henry, I'm working on this problem right now. I have the following setup:

    MacBook Pro 5,5 running 10.6.4 with Canon MX310 attached via USB
    iMac 5,1 running 10.6.2
    Both are connected to a NetGear WPN824v3 'RangeMax' wireless router.

    One thing I noticed is that the browser you use to configure CUPS makes a difference. I tried to edit the CUPS server configuration using Google Chrome and it just blinked at me. I then tried the exact same thing with Safari 5 and was presented with an authentication dialog before being allowed to continue through to the editing screen.

    At present, I can't contribute much to an actual solution. Hopefully I will not have to upgrade the iMac to 10.6.4, but I think that's in my near future...
  • Wild Woman Level 1 Level 1 (0 points)
    Thank you!!! It worked when I changed Deny from all to allow from all.
  • cyberlawprof Level 1 Level 1 (0 points)
    We have two Minis on airport Extreme wireless hardware with a hidden network. Shared printing from my wife's Mini to mine stopped working after a recent O/S upgrade (within 10.5) on her machine. It still didn't work after we upgraded her machine to 10.6.

    In "System Preferences: Print & Fax" I tried deleting the shared printer (a Canon MP610) and adding it back on both Mac Minis (mine, attached to the printer, and my wife's, the remote). That didn't work.

    However, after I deleted and re-added the printer on both machines, I went into the sharing preferences on my Mini (the one with the printer attached), Changed "Everyone Can Print" to "Everyone No Access" and back. That worked.

    It looks as if there's some flag in the programming that some programmer forget to reset in all instances. Apple should fix this. (I also noted that I couldn't connect, even with authentication, from my wife's Mini to mine in Network: Go. But that's a problem for another day; maybe it's due to my allowing no file sharing.)
  • TheClapp Level 1 Level 1 (0 points)
    I, too, finally got the "authentication required" to go away. Sadly it was not by figuring out how to authenticate, which would've been ideal, but by removing the requirement to authenticate.

    After much fiddling, I believe that the net change was a) delete the printer where it's attached (i.e. on the machine where it's plugged into a USB port), 2) re-add it, 3) go to localhost:631 (the CUPS interface, as described previously in this thread), click the "administration" tab, and then on the right under Server, select "allow printing from the Internet". ("share printers connected to this system" should already be selected; this is the analog of the Mac Preferences setting Sharing -> Printer Sharing -> Enable.) 4) Then go to any other computer that shares that printer and try to print. If it doesn't work, delete it and re-add it and try again.

    Since the Internet cannot reach this machine, this is safe. It may not be safe for you. The net end result in the CUPS config file (again, I think this was the only net change) was to add "allow all" to the Location line, as mentioned above.

    So I guess this is a long winded way of saying "me too", but I just wanted to document my findings a little more verbosely.
  • eroeder Level 1 Level 1 (0 points)
    Delete and restall on the iMac now allows my macbook to work fine. Finally a simple fix!
  • Trekiemum Level 1 Level 1 (0 points)
    My fix for the "on hold" authentication required message

    1. opened the printer window and selected the printer name
    2. selected the Hold icon
    3. held down the control button and clicked my mouse
    4. a dialogue box opened where I could change my password and check a box appear where I could choose to save the password.
  • FelipeV Level 5 Level 5 (5,865 points)
    This worked for me. Thanks
  • alan263 Level 1 Level 1 (0 points)

    Had this issue following a Lion upgrade.* 

     

    For me, the solution was not to touch CUPS admin at all. Instead, the 'remote' printer (shared as an smb://<printer-ip>/<queue>  target), was also asking for Authentication. I tried my valid usernames/passwords, no luck. Finally tried authenticating as "guest" with password "guest" and it worked.  This is well worth trying first, because it is quick to do, versus the relatively painful method of nuking all configurations (which i also did, only to end up with this 'fix'). 

     

    *Incidentially, in snow leopard, i learned how to installl a non-discoverable smb printer by usint the ALT+"+" key combination in order to obtain the "Advanced" printer setup button (System Preferences->Print/Scan->[Windows][Internet] ... buttons).  But under Lion the ALT+"+" combo didn't work for me. But i found that i could just rightmouse near to the existing printer-type buttons in order to 'customize' the toolbar, and then it was possible to drag n drop the Advanced cog icon, and I could then proceed to define a smb printer as expected.

  • grandepatron Level 1 Level 1 (0 points)

    "guest"

    "guest"

     

    worked for me  Lion 10.7.2 been frustrated about printing all day.

  • b-dogg Level 1 Level 1 (0 points)

    Hi All,

     

    **before doing this, make sure you've installed Bonjour for Windows and enabled Printer Sharing on the Windows7 PC**

     

    Ok found the fix - it's to do with workgroups and being logged on to your windows network correctly.

     

    1. In windows 7: Control Panel > System.

    Make a note of the workgroup name.

     

    2. In OSX Lion: System Preferences>Network>Advanced>WINS

    Enter the windows workgroup name in the second workgroup drop down menu. Click OK and Apply.

     

    3. Open finder and WAIT! The Windows 7 computer should show up in a minute or so in the Shared section in the sidebar. (Check this Shared devices view is enabled by pressing cmd+, in finder and looking at the advanced tab. Make sure Devices section is ticked).

     

    4. Connect to Win7 Computer: When the Win7 computer pops up in the Devices side bar, click on it. In the finder menu that pops up, hit "connect as". Input your Win7 username and password and tick REMEMBER IN KEYCHAIN! Hit ok.

     

    5. Add Win7 Printer: System Preferences> Print&Scan> Click + button> Add Other Printer or Scanner... * do not select your printer if it appears from the nearby printers*

    Add Other Printer> Windows Tab>

    You'll now see your workgroup in first window pane. Select it, Select the Win7 computer and Click the printer name.

     

    7. Enter a Name and location (for your own reference), and in the Print Using select Generic Postscript Driver.

     

    Print a test page.

     

    Hope this does the trick - did for me after days of googling without luck.

     

    Baz

  • coday Level 1 Level 1 (0 points)

    I have been battling this problem intermittantly for over a year, and Hen3ry's solution seems to have finally done the trick.  In a slight alteration of his sugestion, I simply changed "Allow @LOCAL" to "Allow All" instead of adding another line.  The problem has come and gone without pattern, so I cannot say whether this solution will stick, but for now it is working.  Thanks!

  • hobbes273 Level 1 Level 1 (0 points)

    This solved my problem. Thanks

  • RGS89 Level 1 Level 1 (0 points)

    THANK YOU ALAN263!!! Took me like 4 hours to finally find this solution thanks to you! I believe this is the solution for anyone running Lion. Thanks again, great news!

  • Rob Faucett Level 1 Level 1 (0 points)

    I used this strategy succesfully to solve a very similar problem between several iMacs and a mac mini running as a print server.   OS 10.7.3 on the mini and a range from 10.5.8 - 10.6.8 on the iMacs.  Thanks for taking the time to explain what you did.  Very helpful.

Previous 1 2 3 4 Next