Previous 1 2 3 Next 90 Replies Latest reply: Jan 26, 2016 6:45 AM by fmike7
caw35slr Level 1 (10 points)
My set-up:

2 x iMac running 10.6.2 attached to AEBS via ethernet
1 x MacBook running 10.6.2 attached to AEBS via wireless
1 x HP PSC 1600 printer/scanner USB atached to one of the iMacs

Printer sharing is enabled: everyone can print can print from either iMac.

On the MacBook I can add the printer easily enough but, when I try to print, the job is held with the status: On hold (authentication required):


What's happening here. I've found the same problem in networks involving Windows machines, but I'm all OSX.

iMac: 2 GHz Core 2 Duo, 4 GB RAM. MacBook: 2.13 GHz Core 2 Duo, 4 GB RAM, Mac OS X (10.6.2)
  • ACA4134 Level 1 (5 points)
    I have the same problem -- iMac attached to AEBS via ethernet, with HP c5180 attached to iMac via USB. Printer sharing is turned on for all users. But when I try to print from MacBook, I get the same error message as you. I have tried deleting and re-installing the printer to no avail. I have no problems printing from iMac to printer, only when I try to send print job via the network.

    Notably, I did not have this issue prior to my upgrade to Snow Leopard, even though equipment set-up was exactly the same as current.
  • ACA4134 Level 1 (5 points)
    An update ... I was able to resolve this problem, although I am not sure exactly how. I disconnected the printer from the iMac and hooked it up to the AEBS via USB (side note: I know this works to share my printer, but don't use this as my default printing system, as then I can't make use of the scanning function on my printer). On the MacBook, I deleted the old printer, and installed the new set-up via AEBS. Successfully printed. I then disconnected printer from AEBS, and reconnected it to iMac via USB, and reinstalled the printer to the iMac, and ensured that printer sharing was turned on. Went back to MacBook, reinstalled printer connected to iMac, but did NOT delete the printer via AEBS option; this meant that the same printer showed up 2x on the MacBook just in different locations; made the option via the iMac default. Was then able to successfully print from MacBook w/out the error message problem.

    I don't know why this worked, but it did. Perhaps will be helpful to you.
  • caw35slr Level 1 (10 points)
    ACA4134 wrote:
    An update ... I was able to resolve this problem, although I am not sure exactly how.

    Heh, me too. I'd already been through the whole uninstall-reinstall the printer with no improvement. Yesterday I repeated the exercise and it worked. Who knows why.

    I'll keep an eye on things.
  • caw35slr Level 1 (10 points)
    This is fixed although I'm sorry to reiterate that I'm not exactly sure what did it. If you have the same problem, persist! Good luck.
  • Eric Anderson Level 1 (5 points)
    I had a similar problem, but my HP 7310 is connected directly to my imac (intel core2 duo) and shared through that machine via airport express to my two macbooks.

    I deleted the printer from all the machines, and then set it back up from the imac system prefs. Then, set it up on the macbooks printer system prefs. Worked like a charm. Took all of 2 minutes, but oh the frustration.
  • OrangeKid Level 1 (45 points)
    This solution did not work for me. I have two MacBook Pros networked via Time Capsule to an iMac with a Canon Pixma IP5200 connected via USB. I can print from one MacBook over the network without a problem. From the other I get the "authentication required" message. All three Macs are running 10.6.2. I tried removing and reinstalling the printer driver from all three Macs to no avail.

    Any one have any other ideas
  • OrangeKid Level 1 (45 points)
    I solved my "authentication required" printing problem. I changed my printer setup so that my printer is connected to my network through the Apple Time Capsule. I had to remove and reinstall the printer driver on all three computers. All three computers now print to my Canon Pixma IP 5200.

    I still do not know why I had the "authentication required" on one MacBook but not the other with my previous setup where the printer was connected directly to my iMac and shared from there.
  • ChrisHerman Level 1 (0 points)
    We had a similar problem and it was self inflicted:
    I deleted and re-installed a printer and shared it using the same name (that was on a Mac Mini running 10.6.2).
    After that my wife got that same error message (authentication required).
    Deleting the printer on her MacBook did NOT resolve the problem. I had to delete the printer on the "server" (the Mac Mini) and reinstall it using a different name. Then delete and re-install it on my wife's computer (the MacBook). Now printing works again = wife happy.
  • Paula Galland1 Level 1 (10 points)
    After much frustration with the "on hold (authentication required)" message, I read this thread. Just deleted the printer from its host computer by clicking the minus sign then added it back by clicking the + sign. No more message!

    The only thing we did which might have caused this to happen after years of successful sharing was to update the Airport software. I'm thinking the printer problem was caused by this update.
  • nucleon2000 Level 1 (0 points)
    Help! I am getting the same error with an Olympus P-10 connected directly via USB. The uninstall-reinstall didn't help at all.
  • nucleon2000 Level 1 (0 points)
    And to make it weirder, the printer works on my son's MacBook, and I can access it via his computer without difficulty!!!!
  • nucleon2000 Level 1 (0 points)
    FIXED!!!! (Although early prints on the Olympus P-11 are coming out too large...)

    I did a MacOS X reinstall, and selected the printer support and Rosetta options. Voila! Working printer.

    My son's machine was upgraded to Snow Leopard from an earlier version and probably had Rosetta already installed.

    Live and learn.
  • Mom2KidsDog Level 1 (0 points)
    Have been trying since 830a this morning to print to my iMac printers via shared network. Did not realize that upgrade to Snow Leopard was causing the problems as printers had worked on shared network previously. Read this forum at 1230p, quickly used my "+" and "-" buttons on the Mac Book to delete all the shared printers, used "+" and "-" buttons on the iMac to delete, then add back, the USB-attached printers, then added printers to Mac Book. It is now 1255p. Those little "+" and "-" buttons are rock stars!
  • charleydeppner Level 1 (0 points)
    Please assist.

    My situation:

    • Shared Canon MP150 printer on Power Mac G5 (Leopard). Previously worked fine as shared printer.
    • New dynamic= Power Book G4 "died" and was replaced by MacBook Pro 13" (v10.6.3)

    Results when attempting to use shared printer:

    "On hold (authentication required)"


    • Deleted printer from all computers sharing printer
    • Added and renamed printer to G5
    • Added printer with new name to other computers

    Same result:

    "On hold (authentication required)"

    I would hesitate in declaring this problem "solved."

    The people who have resolved this problem seem quite uncertain as to how it was resolved.
Previous 1 2 3 Next