8 Replies Latest reply: Apr 15, 2010 10:15 PM by alangeo
parkermcclelland Level 1 (0 points)
So i've searched and searched and i can't figure out how to set the f10, f11, and f12 keys on my Apple Wireless Keyboard to control my computer's volume. When I go to System Preferences> Keyboard> Keyboard Shortcuts I was able to set all the other F keys to their proper functions but I can't figure out how to assign volume control to any keys. Anyone know how to do this?

Macbook Pro 17, Mac OS X (10.5.8)
  • saintjordan Level 1 (0 points)
    I am also having this problem, is there some software update we need or something?
  • Barry Hemphill Level 8 (37,327 points)
    Hello p:

    Welcome to Apple discussions.

    I may not understand your question, but.......

    Go to system preferences>keyboard and then highlight keyboard. Are either of the boxes checked? If the first one is, uncheck it.

    Barry

    Message was edited by: Barry Hemphill
  • parkermcclelland Level 1 (0 points)
    thanks Barry but that box was unchecked. I'll try and clarify this better:

    I can change the shortcuts for all of the f keys in system preferences. In the "keyboard shortcuts" menu there are a bunch of shortcuts that can be assigned - dock, exposé, dashboard, screen brightness/contrast, etc.

    However, the problem is that the shortcuts for volume control, play/pause and previous/next song are not present in the "keyboard shortcuts" menu (System Preferences > Keyboard > Keyboard Shortcuts). Therefore, I'm not able to assign these to their proper keys, F7-F12, even though the icons for these functions are present on said keys.
  • Barry Hemphill Level 8 (37,327 points)
    Hi party:

    The reason that I am puzzled is that those keys should work automatically. The function should be just what is on the key. I frankly do not know how one would change that behavior. I have used wireless KB's on several iMacs (both OS X 10.5 and OS X 10.6) and they worked automatically.

    Try a couple of things:

    Reset PRAM (although that probably will not help):

    http://support.apple.com/kb/HT1379

    Check to see if you need to install this firmware update:

    http://www.apple.com/downloads/macosx/apple/firmware_hardware/bluetoothfirmwareu pdate201.html

    Barry
  • parkermcclelland Level 1 (0 points)
    problem solved. I had to download and install the Wireless keyboard Update 2.0. I was caught up because I assumed that software update would show this automatically if I needed it but I should have guessed it doesn't automatically show updates for external hardware.
  • petersod Level 1 (0 points)
    This download did NOT work for me. I still cannot adjust the volume by using my keyboard volume keys (F11/F12) at all. In fact F11 moves all open windows off to the side.
    This worked great when using the keyboard with an older iMac, just won't work now with my new iMac.

    I'm becoming very frustrated with the new iMac - I am also having issues with my Sony eReader
  • dodgert Level 1 (0 points)
    On Mac-Forums.com Website the advice to select Keyboard from System Preferences and then go to System Updates worked for me after a File "Aluminium Wireless Keyboard Update" was downloaded. The Volume controls worked first time after the download and a restart but I had to reprogram the shortcuts for Spaces and Dashboard which didn't work straight away although for the Spaces shortcut I have to add the Fn key but for the Dasboard shortcut the function Fn key is not required. Hope this might help somebody.
  • alangeo Level 1 (0 points)
    GENIOUS!
    A SIMPLE SOLUTION!
    IN OUR FACE, BUT WE THINK IT'S COMPLICATED....
    THINGS ARE CLOSER THAN APEARS