4 Replies Latest reply: Jan 25, 2010 9:35 AM by BPZdiver
Jeremylovesher Level 1 Level 1 (0 points)
I recently plugged my computer into the wall and it will not take a charge. It will power the maching when I plug it in, but the battery will not charge and the charge time in the corner reads 10:00.... What should I do?

iMac 3.06 gHz, 27", Mac OS X (10.6.2)
  • 1. Re: Mac Book will not take a charge - Charge time stuck at 10 hrs!
    S.U. Level 6 Level 6 (8,360 points)
    Welcome to Apple Discussions!

    You might try a SMC reset and see if this helps:

    http://support.apple.com/kb/HT1411?viewlocale=en_US

    If no joy, post back with what the System Profiler has to say about your battery.

    Good luck!
  • 2. Re: Mac Book will not take a charge - Charge time stuck at 10 hrs!
    BPZdiver Level 1 Level 1 (0 points)
    I had/have the same issue, but my charge always shows about 1:35 when plugged in. Had about 10 minutes battery left before I closed it up last night (on a plane got the warning "on reserve power.") When I plugged in this am, and when I opened the computer (with the adapter plugged in) first saw a series of lights across the bottom of the screen, one by one come on, before the keyboard lit up and then my login screen. Unplugged the mac and the screen went blank. Plugged in again and ony had to login again. Tried the smc reset above, and rebooted fine. Now it still shows 1:32 as the charge when plugged in. Now if I pull the plug I still have power, but shows 2:09 remaining. Can't be as it's only been plugged in for under 30 minutes, doesn't charge that fast, at least historically. Battery is the second for this MBP, replaced in August 2008.

    Battery info from System Profiler (unplugged):


    Model Information:
    Serial Number: Sony-ASMB012-3ad9-13bb
    Manufacturer: Sony
    Device name: ASMB012
    Pack Lot Code: 0001
    PCB Lot Code: 0000
    Firmware Version: 0110
    Hardware Revision: 0500
    Cell Revision: 0303
    Charge Information:
    Charge remaining (mAh): 2697
    Fully charged: No
    Charging: No
    Full charge capacity (mAh): 5051
    Health Information:
    Cycle count: 80
    Condition: Good
    Battery Installed: Yes
    Amperage (mA): -1286
    Voltage (mV): 11663
  • 3. Re: Mac Book will not take a charge - Charge time stuck at 10 hrs!
    BPZdiver Level 1 Level 1 (0 points)
    Just tried again and unplugging the computer puts it to sleep, so SMC reset didn't work. Off to the Apple Store!
  • 4. Re: Mac Book will not take a charge - Charge time stuck at 10 hrs!
    BPZdiver Level 1 Level 1 (0 points)
    FWIW, the SMC reset appears to have solved the problem. Thanks.