9 Replies Latest reply: Feb 7, 2010 11:36 AM by BDAqua
David Bisi Level 1 Level 1 (110 points)
I'm having a heck of a time getting VNC set up on my father's iMac G4. His configuration is a Westell DSL modem to a Netgear wireless router, and a wired connection between the wireless router to the iMac's ethernet port. So far I've made these settings:

* On the Westell modem, made sure the firewall was off and forwarded global-to-local ports 5500, 5800, and 5900 using TCP.

* On the Netgear router, forwarded port 5900 to the iMac's local IP.

* In Sharing/Services, turned on Personal File Sharing, Personal Web Sharing, and Apple Remote Desktop. For Apple Remote Desktop, I have 'Guests may request permission to control screen' and 'VNC' viewers may control screen with password:' checked on the Access Privileges panel.

* In Sharing/Firewall, I created a new service ("VNC") for TCP ports 5900-5902 and UDP port 5900. I also have 'Block UDP Traffic' unchecked.

When I check this at gotomyvnc.com, it reports that nothing is responding. When I check port 5900 at canyouseeme.org, it says the connection was refused. I've tried forwarding ports 5500 and 5800 on the Netgear router and turning of the OS X firewall completely, but still get the same results.

Any help or advice would be appreciated - thanks!

24" iMac, Mac OS X (10.6), iPod G5, iPod nano 2G, iPod Suffle 2G, iPhone 8 GB
  • j.v. Level 5 Level 5 (4,155 points)
    Are you trying to control his screen or are you trying to let him control yours? I assume you are trying to control his.

    If you could get everyone on at least 10.5.8, this would be very easy to do by using iChat as two of the options under the "Buddies" menubar item is "ask to share remote screen" and "share my screen" -- I presume that you would most likely NOT be doing unattended screen sharing. IF his iMac G4 doesn't want to install Leopard because it is not at least 867 MHz, if you can boot his machine up in target disk mode and tether it via firewire to a machine that is Leopard-capable, you can install Leopard on the iMac G4 that way. That's how I had squeezed Leopard onto a Quicksilver G4/800 at work a number of years ago.

    You only need personal file sharing enabled on his computer if you are going to do AFP file transfers remotely mounting his computer on your desktop as an external drive. That uses port 548 anyways. You only need personal web sharing on his computer if he is going to be running his own web server. That uses port 80. For remote screen access to his iMac G4, it sounds like you have configured his computer properly with the ARD and extra VNC steps.

    However, I don't have Tiger anymore, but I seem to recall that you also had to declare which users were allowed to connect via ARD/VNC. I seem to recall that that this was done on the same "Access Privileges" page as the VNC viewers checkbox and password field, in the other window panel. You didn't make mention of enabling which users were permitted to login. They have to be users on the iMac G4. Did you do that?

    If at all possible, it would be best if you could see whether VNC screen sharing works properly from another computer on his same network, in order to figure out whether it is the router that is the culprit or the whether it is the iMac G4 that is the culprit.

    I don't know about gotomyvnc or canyouseeme websites, but with the configuration as you have described it, then with either Screen Sharing client on your computer (if you are at 10.5.x or higher) or with a VNC client like CHickenoftheVNC or JollysFastVNC on your computer (if at 10.4.x or lower), it seems that things should work. If it is just not possible to get everyone up to 10.5.8, I would really suggest that you first get a computer onto the same LAN as the iMac G4 and see if you can VNC screen share in that situation. Can you do one of these things or the other?
  • David Bisi Level 1 Level 1 (110 points)
    Hi. Yes, I'm trying to control his screen from my iMac running 10.6. And his G4 is only 800 MHz, which is why it's still on Tiger. Haven't tried putting Leopard on it.

    I don't have a Mac more portable than my iMac, but using Mocha VNC on my iPhone, I'm able to connect to his G4 using the "internal" IP address (10.0.0.2). However, not by using the external IP address (don't even know if that's possible from within the network) or by using the cellular network with the external IP. Does that sound like the DSL modem is stopping it?
  • j.v. Level 5 Level 5 (4,155 points)
    OK - if you can connect when on the same LAN then that points to the modem as the culprit. Not reliable to try to connect via public IP address when on the same network - different modems behave differently when doing that and I'm not familiar with Westel. Next time you are there, from an admin privileged account on his computer, try launching Terminal.app (in /Applications/Utilities/). Type
            tcpdump -i en1 port 5900
    and press the \[return] key (interface en1 is wireless, en0 is ethernet). control-C will interrupt it. Try connecting via the iPhone through the internet at large. If it is getting through the modem and router, you should see some packet activity there.

    Also refer to the modem and router user manual -- I don't know about either but the router may not like port forwarding to dhcp-assigned addresses and the imac G4 might need to be set up for a manual address using DHCP or fully configured manually if that's the case. Also, if the Westel has a built-in router itself, you may be "double-NATted" and could conceivably require the Westel being put into transparent or bridged mode and the firewall function controlled fully by the netgear, or the netgear put into transparent mode if the westel has built-in dhcp and firewall, or if you keep NAT and firewall up on both (if applicable), then both need port forwarding so the signal can pass. That would be one other test -- if the westel is routing and firewalling, connect the iMac G4 to it directly and see if you can get through to it.
  • David Bisi Level 1 Level 1 (110 points)
    Thanks, I'll try that the next time I'm there in a couple of weeks.
  • David Bisi Level 1 Level 1 (110 points)
    Thanks, but that's what I've done. Seems to be something with the interaction between the westell modem and the netgear router.
  • BDAqua Level 10 Level 10 (120,350 points)
    How do I use VNC through my firewall?...

    http://www.realvnc.com/support/faq.html#firewall
  • David Bisi Level 1 Level 1 (110 points)
    Went to the realvnc pages, and their VNC Network Test page reported the same public IP address that I've been using but also reported "Connecting to port 5900 ... succeeded. Waiting for server to send version string... Unknown server (RFB 003.889)". I don't know that this means, but I was able to remotely access the iMac using Mocha VNC on my iPhone and the cellular network. Didn't make any other changes to the modem or router settings, so I don't know why it "just worked" today, but glad it did. Thanks for the links.
  • BDAqua Level 10 Level 10 (120,350 points)
    Hmmm, well good to hear it working anyway.