7 Replies Latest reply: Jul 8, 2010 4:23 PM by Gorrarr
AJUSer Level 1 Level 1 (0 points)
I've been very happy with this wireless machine until the last couple of weeks, when I've begun getting "a communication error has occurred" in the print window.

I re-run the Canon setup CD, download the latest driver for Snow Leopard (10.26.2.0) and all is well - for one or two operations. Then the communication error returns....

I can't think of any particular new application or programme I've installed to provoke the issue.

It's become exasperating and I've resorted to using the USB connection, which defeats the purpose.

Any suggestions most welcome!

Macbook 2.16 Intel Core Duo, Mac OS X (10.6.2), 2GB RAM 120GB
  • PAHU Level 6 Level 6 (15,710 points)
    With regards to the error you are getting, I suggest you need to check if the printer is still connected to the wireless network when this occurs. This would rule out it being a software/driver issue on the Mac and actually something wrong with the printer.

    If you were to make a note of the printers IP address, then you could PING this address when it fails to print to check that it is still connected to your network. I don't have your model, so I cannot be sure of the procedure, but to check the IP address on my MP980 I do the following via the control panel on the printer - Settings > Device Settings > LAN Settings > Wireless LAN Setting List.

    Once you have the IP address, and when you get the communication error, open Network Utility, select the Ping tab, enter the IP address and set the number of Pings to 5. Press the Ping button and see if you get a response. If you don't, then this would explain the error and indicates that the printer has lost its connection to the wireless network.

    If you do get a response to the Ping when the printing error occurs, then it would indicate that the problem is software related. When the error has occurred to date, how do you normally resolve it? Can you turn the printer off then back on and get the print job out from the Mac? Or do you have to go through the process of deleting the printer queue and re-adding it?

    Pahu
  • AJUSer Level 1 Level 1 (0 points)
    Thanks for this. I ran the ping and got no response.

    When I've deleted and re-installed the software previously, I get a connection for one or two documents, then the error occurs.

    Any further suggestions welcome.
  • PAHU Level 6 Level 6 (15,710 points)
    AJUSer wrote:
    Thanks for this. I ran the ping and got no response.

    The no response to the ping is a concern. This indicates that the printer is losing its connection to the wireless network. This is either a fault with the machine itself or with the wireless router. If your Mac is not losing its IP address then it does look like it would be the printer at fault.

    If you have the wireless router set to allocate IP addresses (called DHCP), then I would suggest you try setting a manual IP address in the printer for the subnet you are using to see if that helps. If you don't have that many devices on your wireless network, then if you set the printer's network address to a large number, say 50, then this should be okay.

    If you need some help with determining your subnet and network address, then please reply.
  • AJUSer Level 1 Level 1 (0 points)
    Many thanks for your analysis.

    There's certainly no problem with the wireless connection to my laptop.

    On the printer, the blue wi-fi light is on, and the wireless LAN settings describe the connection as active.

    Happy to be talked through the manual submask setting if you think it'll help.

    Is there any value in somehow un-installing all the software and starting again? I couldn't find an uninstall on the set-up CD from Canon.

    BTW - the printer is working flawlessly when connected via USB.
  • zekr Level 1 Level 1 (0 points)
    I was having the same problem. After getting very frustrated and a call to Canon this seems to have solved the problem:

    1. Go to System Prefs/ Print & Fax
    2. Delete (minus button) Canon MP640
    3. Add (plus button) Canon MP640 (kind: canonijnetwork)

    I can now print successfully.
  • four.eyed.tardis Level 1 Level 1 (0 points)
    I am having this problem as well. I tried pinging the printer as suggesting above and that went perfectly well. My computer and the printer are both on the network; they just don't want to talk to each other.
  • Gorrarr Level 1 Level 1 (0 points)
    I had one "USB printer" set up, it worked like a charm.
    I tried various "LAN printers", scanning worked fine, I could manage the printer, I could even print test pages (to check if the print nozzles where fine) from the management tool. But I could not print to the printer via LAN using the Print menu command.

    I tried installing new driver software, it did not help. I tried reconfiguring the printer via the web interface. It did not help. I then tried deleting the "printers" I had created, except for the USB printer. I did the following:
    1. Opened System Preferences, Print & Fax
    2. Deleted all printers except the USB printer
    3. Clicked the + to add a new printer
    4. Selected the Default tab, and could then see the printer there.
    5. I added that printer, and could then see the printer with the canonijnetwork added to it.
    6. I added that, and now I can print using that "printer"!

    Thanks a lot for the help. Please notice that, at least for me, it was essential to go to the Default tab and ad the printer from there, and that it was a two-step process (add the printer without canonijnetwork, then add it with canonijnetwork).

    I wonder if anyone gets their MP640 printer to work via LAN or wireless without any problem (on OS X 10.6).

    Anyhow, I can now also print successfully using LAN (the printer is connected to the router via LAN, my MacBook Pro is connected to the router wirelessly).