9 Replies Latest reply: Jan 27, 2010 8:31 AM by Roger Wilmut1
Nathan_24 Level 1 Level 1
I'm brand new at podcasting; however, itunes is no longer updating my feed and haven't made any changes to the .xml file I originally loaded. I've added a new episode to the .xml, but itunes has not updated it and it's been several days. I've pinged the servers, but still nothing. Any help with my feed language or errors would be greatly apprciated.

http://itunes.apple.com/WebObjects/MZStore.woa/wa/viewPodcast?id=351987219

Nathan
Solved by Roger Wilmut1 on Jan 27, 2010 12:47 AM Solved
You have an unclosed tag; line 14 reads

<itunes:name>B-K Lighting, Inc.<itunes:name>

it should read

<itunes:name>B-K Lighting, Inc.</itunes:name>

This renders the feed unreadable but correcting it should make it work OK: you can test it by subscribing manually from the 'Advanced' menu in iTunes.
Reply by Roger Wilmut1 on Jan 26, 2010 3:26 PM Helpful
Your feed is missing the declaration at the top, without which iTunes cannot read any of the 'itunes' tags. The top section of your feed should look like this:

<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:itunes="http://www.itunes.com/dtds/podcast-1.0.dtd" version="2.0">
<channel> - and so on

Also, 'keywords' is not a recognized tag (though it will just be ignored); and 'author' should be 'itunes:author'.

Your feed is missing a number of tags, which probably won't prevent it working, but it would be better to use them. This page gives you a basic feed:

http://www.wilmut.org.uk/pc
Reply by Roger Wilmut1 on Jan 27, 2010 8:31 AM Helpful
It normally takes 1-2 days, but sometimes several days.

All replies