Previous 1 2 3 4 5 Next 117 Replies Latest reply: Feb 11, 2015 3:10 PM by tbirdvet Go to original post
  • apedance Level 1 Level 1 (0 points)

    Same problem.


    OS X 10.7.2


    2x Samsung Story Station USB


    Anyone heard about the FAT32 fix for this?

  • kiwibrew Level 1 Level 1 (0 points)

    I have this issue. I am using a 2TB external Seagate drive via USB. It's just there for time machine - there's absolutely no reason for it to hang the computer while activating and spinning up at random times.


    Model Name:          iMac

      Model Identifier:          iMac11,1

      Processor Name:          Intel Core i7

      Processor Speed:          2.8 GHz

      Number of Processors:          1

      Total Number of Cores:          4

      L2 Cache (per Core):          256 KB

      L3 Cache:          8 MB

      Memory:          16 GB

      Processor Interconnect Speed:          4.8 GT/s

      Boot ROM Version:          IM111.0034.B02

      SMC Version (system):          1.54f36

      Serial Number (system):          7303500NDMZ

      Hardware UUID:          4B9AB092-3F97-53E5-ACBE-733C97EE9C49

  • W. Raider Level 3 Level 3 (545 points)

    This has been happening with most versions of OSX (Don't recall it happening in System 7, 8 or OS9 and in fact had a shareware app called Sleeper installed back then without problems).


    I typically see/hear the HD spin up:


    A: Randomly. Completely randomly; I don't even need to be doing anything on the computer.


    B: When using the Save dialog window in only SOME apps, not all. Some spin up ALL THE DRIVES attached to the Mac while the App beachballs, while other apps don't spin up the drives (same drives in fact) until you actually hit Save. Weird.


    C: Accidently mousing over "Open With..." in contextual menus.


    D: When ejecting a mounted .DMG for some bizzare unknown reason.

  • Zoomster Level 1 Level 1 (0 points)

    Bump.  Me, too.  This is extremely annoying.  I have an external LaCie FW800 drive for Time Machine, and I'm constantly watching the beach ball while it spins up at random times.  I went searching for a solution, but haven't found one yet.

  • cduerr Level 1 Level 1 (10 points)

    Thankyou for this thread. I've been researching the issue for some time now, but even with correct search terms, filtering out the useless results is painful. Anyway, now i detach the drives if i dont need them. I am considering buying the next iteration of the Macbook Pro together with the Thunderbolt display to act also as a stationary solution, but i certainly want to play disk jockey because of Apple's lack of communicating proper behavior or, more ideally, fixing the behavior in the first place.

  • Declan25 Level 1 Level 1 (0 points)

    Argh, I have this problem too. My external drives are woken unnecessarily when saving anything. Also occasionally when using firefox. It is incredibly irratating.

               I am using Snow Leopard now, anyone know if upgrading to Lion would help?

  • Kevin Jacobs Level 1 Level 1 (0 points)

    I have this too


    1x USB HDD 320gb hub

    1x Firewire 800 HDD which used for TimeMachine


    the drive randomly starts up slowing machine down sometimes when i turn off the screen or even when i put to sleep after midnight especially they spin up spin down all the time... it wakes me up!! which im sure is also shortening the lifespan of the drives


    this also doesnt make a difference if i unmount drives before sleeping screen or machine


    anyone know aside from shutting the machine down how to solve this?



    27-inch, Mid 2011

    Memory  12 GB 1333 MHz DDR3

    Graphics  AMD Radeon HD 6970M 2048 MB

    Software  Mac OS X Lion 10.7.2 (11C74)

  • MacGregorLikesMacs Level 1 Level 1 (0 points)

    OMG.  This has been going on since at least Jan 2010?  Are you serious Apple???  How about fix the **** problem.  Why should your fancy, shiny UI freeze every fifteen minutes because something in your OS decided to spin up an external drive randomly for no good reason?  Dudes, get on it and fix it.  It's been far too long.  I've already told your operating system that you should perform Time Machine backups only every three hours, yet your OS wants to spin up the TM drive all the time.  ***???  Oh right, and it pauses every other function in the **** UI while it does it.  Thanks for the forced "me time".  There is NO REASON WHATSOEVER FOR YOU TO TOUCH MY TIME MACHINE DRIVE AS OFTEN AS YOU DO.  Stop doing it.  This is obviously a problem that every Mac user faces and it is not becoming for what is usually a very intelligent operating system.  Get a grip Apple.




    1.  unplug external drives while using them.  LAME.


    2.  implement a script to "touch" your drive periodically to prevent it from spinning down during a specific timeframe.


    small tutorial:


    step one,


    create script file "" (or whatever you want to call it) with code:



    if [ -d /Volumes/$1 ]; then

        touch /Volumes/$1/.touchMe



    step two,


    create a file on the root folder of your external drive named ".touchme".  The dot in front will make it a hidden file in general (linux idiom).  This file is obviously referenced in the script... name it whatever you want as long as the script matches the name in its code.



    step three,


    create a cron job to call this script periodically.  from terminal:


    crontab -e  <--this opens crontab for editing


    now your in "vi editor"... press "i" for insert mode... enter this:


    */5 08-23 * * * /Users/yourusername/Library/Scripts/ "Time Machine"


    (or wherever the path is to your script, but username/Library/Scripts is a great place to put it) (Notice the name of your drive is getting passed into the script as the first parameter (in quotes))


    press "esc" to exit insert mode... press :wq (that is colon w q) to Write then Quit.


    The "*/5" syntax means every five minutes.  Change the 5 to whatever minute interval you want (Different drives have different spin down times).   The "08-23" part says " within the hours of 8am to 11 pm run the script, otherwise in the middle of the night lay off".  Change "Time Machine" to whatever the name of your external drive is.


    If you have multiple external drives, then create an additional line in the cron tab file and replace "Time Machine" with the name of your external drive.  Each cron job needs it's own separate line in the file.


    Good luck my friends. 


    God bless the bureaucracy.  Hopefully we can get a fix within four score and seven years from now.

  • MacGregorLikesMacs Level 1 Level 1 (0 points)

    UPDATE:  The tutorial/solution in my previous post does not seem to work with drive names that have spaces.  So, "Time Machine" as a name will not work, but "Time_Machine" will work... so you may need to rename your drives with underscores, or else find a better solution.



  • Shtirlic Level 1 Level 1 (0 points)

    The same here with Seagate FreeAgent Xtreme (USB/ FireWire no matter). When playing games this is really bad experience. Waiting for solution without keeping disk alive all the time.

  • _-ElGordo-_ Level 1 Level 1 (0 points)

    I've had the problem with disks spinning up unexpectedly even when the Mac was completely unused and with all applications closed. I finally managed to fix it and I've put up a blog post here.


    It probably won't help with disks spinning up when file dialogs are displayed, but it has stopped them spinning up when no interaction was taking place.


    Hope it helps some of you.

  • jrawl004 Level 1 Level 1 (0 points)

    This has been a problem for me as well, but after reading though some of the previous posts and digging around my iMac, I found the culprit.  iStatPro.....I have a habit of tracking my system status while editing video and this program does a great job at keeping things up and reportig.  So everytime I made the slightest touch to my iMac or MacMini, it would awake everything so it can report.  I disabled the widget and low and behold, things became extremely quiet quickly.  That problem is solved for now....for me at least.  Hope this helps someone else!

  • patH72 Level 1 Level 1 (30 points)

    I have the same problem as others are reporting here. I'm wondering what is harder on an external dirve--having it continue to spin continuousy by disabling the "Put the hard disk(s) to sleep when possible" setting in System Preferences, or having it wake and spin up spontaneously several times each hour.

  • Kevin Jacobs Level 1 Level 1 (0 points)

    I found this does the same to my internal hard drive when i unplug the External ones too


    probably something wrong with the bus ?


    also this seems to happen a lot when i sleep machine or blank the screen after midnight

  • theSandyBear Level 1 Level 1 (5 points)

    I've changed the harddrive in my TC 2G to a 2.5TB WDgreen. Works fine, but the same issue with the drive spinning up every 10-20 minutes was annoying and not good for the disk's long evity.

    Just tried to exclude TC AirPort Disk in Spotlight preferences (Privacy), seems to have reduced the number of spinups....


Previous 1 2 3 4 5 Next