12 Replies Latest reply: Mar 4, 2010 4:03 PM by hitchner
Tony DeLuca Level 1 Level 1 (80 points)
Is there an east way to import just certain photo fro iPoto to Aperture? I don't want to import everything.

Intel Mac Pro quad core desktop with 4 gigs of ram., Mac OS X (10.5.8)
  • rwboyer Level 4 Level 4 (3,170 points)
    The answer is there is not a really easy way - there are ways but for you I would think that using one of the automated options and then getting rid of images out of Aperture might be easier.

    RB
  • mahani Level 1 Level 1 (0 points)
    Hello,

    Try this, in Aperture, create a new empty album that you want pictures from iPhoto to go into. Then go to Browse, select iPhoto, then choose which album/pictures from the iPhoto thumbnails that you want to import to Aperture. After you select them (like you would do in iPhoto) then DRAG the whole thing into the new empty album in Aperture that you had created at the beginning. In this way, you only select pictures that you want to import to Aperture rather then the whole iPhoto library. I hope this make sense.

    I had tried the route you probably had done ( go to Import iPhoto.......then it import the whole **** thing without giving you any option to choose which of the photos you want to import???? very frustrating!!!)
  • Terence Devlin Level 10 Level 10 (131,765 points)
    Simply:

    Select a target Project in Aperture - where you want the photo to go...

    Then File -> Show iPhoto Browser

    Drag the file to the Project in the Source Pane. It will import all the versions of the shot.

    Regards

    TD
  • Tom Reichner Level 1 Level 1 (0 points)
    Quote from mahani:
    "Try this, in Aperture, create a new empty album that you want pictures from iPhoto to go into. Then go to Browse, select iPhoto, then choose which album/pictures from the iPhoto thumbnails that you want to import to Aperture. After you select them (like you would do in iPhoto) then DRAG the whole thing into the new empty album in Aperture that you had created at the beginning."

    I tried to do this, but was unable to find "browse". Where do I find "browse"?
  • rwboyer Level 4 Level 4 (3,170 points)
    Under the file menu.

    RB
  • Tom Reichner Level 1 Level 1 (0 points)
    I think I see it now, only mine doesn't say "Browse", it says "show iPhoto Browser". Is this the same thing?
  • mahani Level 1 Level 1 (0 points)
    Hi,

    Sorry, I meant go to File, select show iPhoto Browser and then proceed from there as I suggested earlier.
  • Tom Reichner Level 1 Level 1 (0 points)
    Ok, I've done that. When I go to the iPhoto browser I selected the images I wanted to use from iPhoto. I dragged & dropped them into the folder (in Aperture) that I want them in. The little wheel is still spinning around, and there is a little icon that says "importing" that also has the little spinning wheel next to it. It has been importing for over 40 minutes now. Is this normal? I only dragged & dropped 188 images, which is really not very much. When I copy the same 188 images to a folder on my desktop it takes less than a minute to copy them. When I burned them to a DVD it only took about 5 minutes to burn. Why, then, is Aperture taking so, so long to import these 188 images? Is it normal, or do you think my Aperture program is screwed up? And here I thought this was supposed to be easy !
  • mahani Level 1 Level 1 (0 points)
    Hi Tom,

    Sorry to hear that it is taking so long to import those 188 images. Are they mostly RAW or jpeg? Still it should not take that long. I had not experienced this before but I have not import a lot of RAW either.
    Could be yet another 'Snow Leopard-Aperture-Mess'.
    I had not used much of the Aperture lately after I had a disaster with losing 95% of my images in Aperture after trying to relaunch it,etc,etc with the dreaded "Unsupported Image Format" and selected Browser image not corresponding to the View image!!! Luckily, I am using Referenced and not Aperture Managed files, so I have all my original images in iPhoto.
    So, not sure what to tell you, I sure feel sorry for all the professional photographers who depends on Aperture. Based on all the frustrations with Aperture/Snow Leopard from this forum, I am not very optimistic at the moment.
  • Matcha Level 1 Level 1 (5 points)
    Same thing happening to me. I'm using the trial of Aperture, importing 40 photos from iPhoto, the importing wheel just spins and spins, and I can't cancel it. Must force quit Aperture 3. A retry gets the same results.
  • hitchner Level 1 Level 1 (0 points)
    I am having similar problems as Matcha and Tom when I try to use File -> Import -> iPhoto Library
    with Aperture 3 Trial Version (I've purchased the upgrade which is due to arrive in a day or 2), iPhoto '09 version 8.1.1, Snow Leopard version 10.6.2 on a 3 GHz iMac with 4 GB main memory.

    I have a number of small iPhoto libraries plus my main iPhoto library that's about 11,000 photos. I successfully created 3 Aperture 3 libraries plus the default Aperture 3 Trial Library that the A3 install created, and I have successfully imported into the 3 small libraries using File -> Import -> iPhoto Library. One of these iPhoto libraries was about 2,400 photos, i.e., much larger than the problem library described below. I imported into the Trial Library using drag and drop from Show iPhoto Browser.

    But, when I try File -> Import -> iPhoto Library with a 4th iPhoto library of about 560 photos Aperture 3 never completes all its processing. Here is what happens:
    1. import completes and I get the completion message in a pop-up window
    2. The "Processing" spinning wheel spins forever
    3. The Activity window shows that about 13 of 560 photos have been processed, and then it never progresses past that. I presume "Processing" means generating the preview images. I have the Photo Preview preference set at the default: Half Size and Medium, Quality (8). It also shows that something like 1, 2, or 3 thumbnails (that number has varied during different attempts) remain to be generated.
    4. At this stage my whole machine starts to slow way down, i.e., responding to mouse clicks or switching focus to another app takes several seconds, and even quitting Aperture 3 can take 10-20 secs. In one of my earlier experiences with this behavior I was unable to get sufficient response to quit the Aperture 3 process and had to revert to logging in over my network from my laptop to kill the Aperture 3 process.
    5. I have even used Pause and Cancel in the Activity Window on the culprit process, but performance seems to be the same after pausing or canceling.

    As Terrence suggested I rebuilt all my iPhoto libraries using iPhoto (not IPhoto Library Manager) before importing them into Aperture 3, and I disabled Faces. Also, the culprit iPhoto library has no Slide Shows, but the 3 other small iPhoto libraries that I successfully imported did each have a Slide Show that seem to have been successfully imported.

    Finally, while my iPhoto import is stalled in its seemingly infinite processing loop I used the "top" app in a Terminal window to examine the Aperture 3 process, and I discovered that its virtual memory (VSIZE) grows nearly continuously seemingly without bound. The lowest I have observed VSIZE is about 7 GBytes and the largest is somewhere above 13 GBytes. While watching "top" VSIZE nearly always increases, even after I have paused or canceled the process in the Activity Window.

    I am very hesitant to try to import my main 11,000 photo iPhoto library into Aperture 3 after I receive my upgrade copy. And, I don't wish to use the alternative method of dragging and dropping via Show iPhoto Browser because I also want to import all the Faces, Places, and 35 Slide Shows I have in my iPhoto library (as advertised in the Aperture 3 promotional documents).

    In this thread and a few others I have seen a few questions or references to a memory leak wrt Aperture 3 and Snow Leopard. It sure seems to me this is the case based upon what I'm seeing in A3's VSIZE "top" statistics. Can anyone else corroborate this? Does anyone know if Apple is aware of this and working on solving the problem? What is the procedure for informing/asking/complaining to Apple Tech Support about it?
  • hitchner Level 1 Level 1 (0 points)
    After reading a few more posts to the Aperture Discussions I now see that version 3.0.1 was released on 2/24/2010 and the release notes claim to deal with fixing iPhoto import and memory bugs (among many other bugs). I'm still using the Aperture 3 Trial version which is version 3.0, and the download file has a last modified/created date of 1/21/2010. So, hopefully when my upgrade copy arrives i a few days I can start using the latest version. Too bad Apple is still using an out-of-date buggy version for the free 30 day download trial version. The bugs I discovered might scare away some potential paying customers.