7 Replies Latest reply: Mar 25, 2010 3:55 AM by cosmiconnections
Worminger Level 1 Level 1 (0 points)
I persuaded a colleague to switch to a mac and sure enough my reward is that he cannot connect it to his existing wireless network.

He is using a SpeedTouch adsl modem/wireless router as supplied by SingTel (we are in Singapore). He has two Windows laptops both of which connect happily to the router and access teh internet.

When he turns on Airport on the iMac it finds the router and he has put in the correct password. It shows the bars on the airport icon but has an exclamation mark in the middle.

It cannot connect to the internet, however the windows machines continue to be able to do so.

He is obviously fast losing faith in my assurances that this is a better machine. He spent two hours on the phone with a Singtel helpdesk person and that guy was unable to resolve it. He confirms the settings of the modem/router are all correct for accessing the SingTel internet connection and suggest, naturally, that it is an Apple problem.

Does anyone know of any issues that the new (21.5") iMac is likely to have with an existing modem/router that was originally set up for a Windows machine and that continues to work fine for a Windows machine?

- type of security password (eg WEP vs WPA/WPA2)???
- channel?
- anything else known to be an issue?

Thanks in advance


Mac OS X Intel, Mac OS X (10.6.2)
  • Worminger Level 1 Level 1 (0 points)
    And by way of update, it is only airport that cannot connect, a direct ethernet connection does work....
  • Kenichi Watanabe Level 7 Level 7 (30,460 points)
    One reason for that exclamation point appearing is that +Internet Sharing+ is enabled. To check, go to System Preferences Sharing pane, and make sure +Internet Sharing+ is not checked.

    If that's not it, go to System Preferences Network pane. In the sidebar, AirPort should appear first (top) on the list of network services. You can change the service order, by clicking the gear icon at the bottom of the sidebar, and selecting +Set Service Order+. If a change was made, be sure to Apply it, then try restarting. If there is anything connected to the Ethernet port, disconnect it.
  • Worminger Level 1 Level 1 (0 points)
    Thanks Kenichi, trying that...
  • Worminger Level 1 Level 1 (0 points)
    Well between them the ISP and Apple solved this, but I am not entirely sure what they did. Given the reported problems on this subject with the new iMacs we are monitoring to see if it loses the plot again.

    Thanks for the help, much appreciated

  • ejp44 Level 1 Level 1 (0 points)
    I wish you could find out and share it with us so we could try it.
  • milmind Level 1 Level 1 (0 points)
    I would like to know what they did also. I am having airport issues myself. I have a 27 in. imac. the fix the apple tech gives me is always temporary. Everything is fine with my 2wire router. I had AT&T check it and it works perfect. I have a windows laptop and 3 iphones in the house that work perfect on the network. The imac is the only thing that has problems keeping a wireless connection. It always says that the wireless status is unknown.
  • cosmiconnections Level 1 Level 1 (0 points)
    This is really useful information - thank you. I had the same problem and followed your guideline and it worked!

    My only problem is that the internet connection is so slow..on my new imac! I have a window based old laptop (about 5 years old) next to the new imac and it's much faster. I did a speedtest and on the old laptop the download speed was 4.44 mb/s and on the new imac it was only 0.26 mb/s!! The strange this is sometimes the internet speed on the imac is reasonably fast but recently it has been very very slow!

    Do you have any suggestions?