1 2 Previous Next 16 Replies Latest reply: Jun 28, 2010 5:56 AM by South Sider
Martin_C Level 1 Level 1 (0 points)
Okay so I installed SL around Christmas time. I was away for a week around New Years. Come back and for some reason my Unibody Macbook Pro runs at 150-165 degrees F while idle and using roughly 5% of my resources. It use to run at 120 before. I mean it even runs the fanspeed over 3k RPM to maintain that when I watch a simple youtube video.

Now I tried doing the batter reset, but that only fixed the problem for 2 days and then boom back to 150 degrees again. Now should I go to an Apple store and ask them to replace my battery. Or is there something else that I could do to avoid the time spent at the store.

Macbook Pro Unibody 08, Mac OS X (10.6.2)
  • 1. Re: Macbook Pro running hot
    Barry Hemphill Level 7 Level 7 (34,500 points)
    Hello Martin:

    Welcome to Apple discussions.

    I do not monitor temperature, but there is something you could try if you are concerned.

    Reset the SMC (pick your model from the attached instructions):

    http://support.apple.com/kb/HT3964

    Barry
  • 2. Re: Macbook Pro running hot
    Martin_C Level 1 Level 1 (0 points)
    Didn't do anything. Back to the same temperatures withing 15 mins of doing it. Looks like I'm going to go to the Apple store after my last class.
  • 3. Re: Macbook Pro running hot
    jk_baller23 Level 4 Level 4 (2,120 points)
    What kind of activity are you seeing in Activity Monitor?
  • 4. Re: Macbook Pro running hot
    Martin_C Level 1 Level 1 (0 points)
    For example right now I'm in class. I'm running at 155 degrees and 2400 RPM. I have 2%-3% being used by firefox, 2% on activity moniter, 1% on smcFan Control, .5% on Powerpoint, 1.0% on dock, and .2% and .3% on MSN messenger and iChat.
  • 5. Re: Macbook Pro running hot
    GrahamGo Level 1 Level 1 (0 points)
    When you have fixed the problem you might also consider trying the Coolbook Controller. I have been using this for a year and very happy with it. My laptop runs a lot cooler and I get a good extra hour of usage on battery power.

    Right now I have been emailing/browsing for 2 hours, its idling at 1596 mh/z and 33degC (~ 91 degF).
  • 6. Re: Macbook Pro running hot
    Martin_C Level 1 Level 1 (0 points)
    That's cool and all, but why did it jump over 30 degrees in temperature for no reason. That's what I don't understand.
  • 7. Re: Macbook Pro running hot
    GrahamGo Level 1 Level 1 (0 points)
    I don't know and can't offer any suggestions. I also went to SL a month ago. I did a complete fresh install and have not had any issues. Today I did that controller reset thing mentioned earlier in your thread just for the heck of it!

    Good luck. G.
  • 8. Re: Macbook Pro running hot
    magnoliafan Level 1 Level 1 (0 points)
    I am having a similar problem. I'm running a 1st gen late 2008 MBP 15". After one of the Snow Leopard updates late last year, my MBP stopped sleeping with the lid closed, and runs extremely hot with a drained battery if I don't do a manual sleep and wait for the fans to shut down (even when they've shut down it will still fire up in transport and drain the battery).

    I'm super frustrated and can't find any support online. I'm about to rip it apart and look at the reed switch sensor, although my suspicion is that this a software related issue.
  • 9. Re: Macbook Pro running hot
    magnoliafan Level 1 Level 1 (0 points)
    Oh and to Apple Support Guy... Before you offer up the standard script - I've tried every SMC, PRAM, battery pull, light it on fire, smash it against a wall, fix there is. Nothin.
  • 10. Re: Macbook Pro running hot
    Earthlaw Level 1 Level 1 (5 points)
    My MBP 15 inch started running hot about one month ago--after I have had it for nearly three years. It strikes me that it must have been an upgrade that changed what is going on inside the case. Could this be?
  • 11. Re: Macbook Pro running hot
    Allan Eckert Level 8 Level 8 (41,525 points)
    Hi Earthlaw;

    Before jumping to such drastic conclusions, I would suggest that you use Activity Monitor to find out exactly what is using resources in your Mac.

    Allan
    tiger
  • 12. Re: Macbook Pro running hot
    Lawrence Jones1 Level 1 Level 1 (10 points)
    My 15" MBP seemed to be much hotter after updating to 10.6.3. iStat was showing over 70°C with CPU under 5%. Palm rest area was uncomfortably warm. I was sure it was an OS issue, but I was an electronics tech, so, following iFixit instructions, I removed 8 screws on bottom and 6 screws holding 2 fans, cleaned out dust, reassembled. Machine is running 44°C now, after a few hours, about 30°C cooler. Big win.

    A little dust can block a lot of heatsink.

    Do not try this if you care about your warranty, or if you are not comfortable with expert level technical repairs. But it sure worked for me.

    Disassembly, cleaning and reassembly took about 30 minutes, not counting the hour and a half I spent searching for tiny screws after using a blower. Be careful with the screws, they are really hard to find.

    Message was edited by: Lawrence Jones1
  • 13. Re: Macbook Pro running hot
    jmontgomery Level 1 Level 1 (0 points)
    I just took my Macbook Pro to the Apple Store and did a "Quick Drop" because as of yesterday (no software changes / modifications) my idle temperature went from being around 47C to 87C within 3-5 minutes of boot. If I open a browser and start browsing the web we hit the 91C mark where it used to only hit low 50s. After checking the Activity Manager there are NO rouge processes or excessive CPU cycle usage. I don't understand what , besides a hardware fault, could be causing this. Even cranking the fans to full throttle only drops the temp to 78-80C idle. Not good. Not normal. Hopefully I will get a call in a few days telling me the outcome of the diagnostics. This is mid-2009 MBP that I've had for 5 months.

    So, if anyone here was given a solution or could clue me in to what I'm in for, I would appreciate it. I will post the verdict of my machine once I hear from Apple.

    Cheers.
  • 14. Re: Macbook Pro running hot
    jmontgomery Level 1 Level 1 (0 points)
    So, I got my Macbook Pro back from the Apple Store today with the explanation that the thing was super dusty and that is why my temps were shooting up. The representative also stated that he cleaned it and all was back to normal....

    Get home, plug it, boot up... 5 minutes just chilling on the desktop 89C. Open Firefox and browse to Gmail and my school website - 93C. WTH, nothing has changed. Start looking around and really analyzing Activity Monitor. Every few seconds the Lexmark CUPS and Wifi driver for the printer would shoot to the top at 99% CPU usage. Removed all print drivers rebooted and now I'm back in the high 40s. Right where I used to be.

    It appears that 10.6.3 and the Lexmark driver don't play well. Will investigate more and then file a bug with Lexmark.

    So Apple Store 'tech guy', thanks for the cleaning but... you're full of **** and obviously didn't test anything.
1 2 Previous Next