9 Replies Latest reply: Feb 14, 2010 2:30 PM by BDAqua
revDAVE Level 2 Level 2 (260 points)
MAIL 2.13 & gMAIL - seems to auto save drafts without me doing anything - is there a way to turn this off so it is only manual?

MBP (early 2008), Mac OS X (10.5.7)
  • BDAqua Level 10 Level 10 (120,915 points)
    Hmmm, I wonder how it's doing that, mine doesn't even know if it's a Draft unless I chose Save as Draft!?

    Is this when just composing a New Message, or some other way of starting?
  • revDAVE Level 2 Level 2 (260 points)
    yes, just when working on a new message...
  • BDAqua Level 10 Level 10 (120,915 points)
    How long does it have to sit there before it does it on yours? Are you quitting Mail or anything?
  • revDAVE Level 2 Level 2 (260 points)
    1st about 30 seconds...

    assuming you keep editing - it seems as though the draft folder item blinks about every 30 seconds - constantly updating / resaving....

    ** now I see that - when i send it the drafts empties * but all the extra tmp copies are there in the gMAIL REAL trash folder .... this is what i do not want to think about .... is there a way to make all this tmp garbage GO AWAY or NOT HAPPEN..... ? gets too confusing...
  • BDAqua Level 10 Level 10 (120,915 points)
    Hmmm, never caught it in Drafts, but the one sitting there for an hour IS in the Trash.
    Only solution I can see is Mail>Preferences>Accounts, highlight your Gmail account>Mailbox Behaviors tab>Trash>Permantly Erase Trash when... Quitting Mail perhaps?
  • revDAVE Level 2 Level 2 (260 points)
    Thanks BDAqua - thanks for the help,

    if you keep editing - you'll see that there are many in the trash

    - also the Trash folder in the gmail account is empty in APPlE MAIL - even when stuff is there on the webpage - how do i get it to show in apple mail?
  • BDAqua Level 10 Level 10 (120,915 points)
    I assume you right click or control+click on gmail in Mail then choose Syncronize [this] Account.

    It looks like you can Syncronize just the Trash also. The Web end only shows the ones in the last 30 days, even if there are more in Mail Trash!?
  • mctrader Level 1 Level 1 (0 points)
    My suggestion is that you turn off the "Store draft messages on the server" in the Account info settings, under *Mail Behaviors.* (Go to Mail Preferences ==> Accounts; or click on the Associated Mailbox and then Right Click to get Account Info. Either approach will get you to the property pages where you will see the Behaviors tab)

    I noticed this with Gmail (using IMAP) and it appears that by default, Apple Mail will save a draft EVERY 30 seconds. I had a Blackberry that was also set up as an IMAP device and although I only SENT one message, it was causing multiple messages to be sent to my Blackberry. I would have a new message every 30 seconds while I was typing my new message or even on a reply.

    There were also multiple messages in the Trash from the same message as it was being composed.
    Whether this was caused by settings on the Blackberry, I never really pursued, but unchecking the "Store draft messages on the server" solved my problem.
  • BDAqua Level 10 Level 10 (120,915 points)
    Hi mctrader , and a warm welcome to the forums!

    Great tip/post, thanks!