Previous 1 2 Next 24 Replies Latest reply: Apr 27, 2010 10:36 AM by Wilburtron Go to original post
  • Schlurch Level 1 Level 1 (0 points)
    Wow, Ron, you're quite a popular guy on here. I have a similar problem, but different enough that I haven't found an answer yet in this forum. I have 10.5.8 leopard, and I installed the 10.5 usb driver from ralink's site, but after restarting I was no closer to knowing what to do. When I first opened the installer, it offers the advice that "after restarting, you'll still need to configure the device in the network section of system preferences," or something to that effect, but as they don't offer any configure instructions, I'm still in the dark. I messed around with the network panel for a while but didn't figure anything out, and when I insert the usb antenna in my 2.0 port there's no recognition at all. The light doesn't come on, nothing. I can pull it up in the system profiler, so I can see that the computer recognizes that it's an 802.11 b/g device, but nothing beyond that. You suggested to someone else that a search of ralink on the hd might pull up a "ralink wireless utility" and I haven't tried that yet. But I want to specify that this is just one of those small antennae, not a full-on router. Here's the product link: http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=260571409144&ssPageName=ADME: X:AAQ:US:1123#ht2287wt941

    Thanks for any advice.
  • Ron R Level 2 Level 2 (320 points)
    Your device RT3070 chipset is supported by the Ralink driver, it should work. I had used a wireless USB adapter when I had Tiger. So, these instructions may be slightly different in Leopard (have not installed it using Leopard; installed new airport card). Look for the Ralink Utility.

    Go to: http://www.ralinktech.com/support.php?s=3. Download and Install the driver: USB(RT2870 /RT2770 /RT307X /RT2070 /RT3572) If this one you doesn't work, try another driver. Plug in USB Device. The Ralink Wireless Utility will open, in about 20 seconds it should detect the device: connected. You should also set up a profile in the utility. Just add and activate.

    Then open Network Prefs, Network Port Configurations, and Hit Apply. A new port should show; Ethernet Adapter (en2).
    Select SHOW in the Network Prefs and check Ethenet Apdapter (en2).
    Hit APPLY. the TCP/IP info should show IP address/Subnet/Router connections.
  • Schlurch Level 1 Level 1 (0 points)
    Thanks for the help. The latter part of your instructions is where I think the difference between tiger and leopard comes in. Mine shows up as ethernet usb (en3) or something to that effect, but there is no "network port configurations" or "show" in the network prefs, that I can see. I can get the device to detect local wifi networks when in the Ralink Utility, where I did create the profile as you suggest, but in the network preferences it shows the new port, ethernet usb (en3), along with the airport, firewire, modem, etc (all of which are off), but it says that the cable for the (en3) is not connected. I'm not sure how to get it to register as connected and on. Also, I've been getting a lot of emergency shut down notices since I installed the driver and started trying to use the antenna. The screen goes dim, and this block comes up telling me to shut down in about 5 different languages. It happens just about every time I try to use the device, at some point. Thanks for any help.
  • Ron R Level 2 Level 2 (320 points)
    The shutdown notice indicates a software conflict. Since it shows up as en3, it is recognizing the device. Try installing the other ralink driver.
  • Schlurch Level 1 Level 1 (0 points)
    I installed the first usb driver based on the chipset advertised in the ebay description, and nothing at all happened. I then uninstalled that one, and installed the other usb driver, based also on the writing on the chip itself when I opened the device (pretty easy to pry the plastic pieces apart). With this driver, my computer actually recognized the device. Thanks if you have any other ideas. I'm stumped.
  • Ron R Level 2 Level 2 (320 points)
    Are the drivers that came with the device from Ralink ? If not, did you try the Ralink driver?
  • Ron R Level 2 Level 2 (320 points)
    OK. I installed my USB device with Leopard. First, you have to install the Ralink driver for 10.5, since the 10.6 is not compatible yet. After installing, turn off airport. Then plug in your device. The RALINK UTILITY should appear in the dock. Open it. In the SITE SURVEY It should start locating routers. Choose yours and hit CONNECT. Enter your shared-key (password). Then go to SYSTEM PREFS and you should see 802.11 WLAN. Hit ADVANCED. It should automatically configure the IP, Subnet and Router. Return to the main Network screen. Your device should be activated (green dot).
  • Wilburtron Level 1 Level 1 (0 points)
    Hi there,
    Firstly I am using Mac OS 10.5.8
    I recently got a RALINK rt 2870 to boost my signal. As I live nearby my university I hoped to use the USB atennae to boost my signal enough to pick up the university wifi (400m away in a free line of sight - also using a parabolic 'Wokfi' to help). Problem is - having installed drivers from various sources. The EW-7711Uxx_Driver-Utility-for-Mac that came off http://www.edimax.com/en/producedetail.php?pd_id=277&pl1_id=1&pl2id=44
    That one got me no where. So I tried the driver off http://www.ralinktech.com/
    I read these forums trying to read about what to do, but still having problems. Now I have a driver installed, as a folder called RAlink Wireless Utility came up in my Applications. In there is a Scutum something, a Scutum readme file, an AwakeRAlinkUI program and the Wireless Utility. When the dongle-bit is not connected the Utility stays open though you can't do anything in it as nothing's connected. When I connect the dongle it connects in Network Preferences with a USB Ethernet (en3) 2 as its name. But whenever I try to open the Wireless Utility it opens for about 4 seconds with 'No Device!!' showing before that changes to a BTFON or Openzone and closes itself. No chance to click or do anything else.

    How can I stop this? I want to be able to choose what network I use as there are several other free networks I can use to grab my e-mails if the university building proves too far away. But I ideally want to be able to point my wokfi/antennae at the university building, use the Wireless Utility to look for its network and connect to that. But it gives me no chance.

    Do I need to change drivers?
    Is it worth upgrading to Snow Leopard? Would that solve the problem?
    Have tried uninstalling and reinstalling several times likewise, but to no better result.

    Yours

    Will
  • Wilburtron Level 1 Level 1 (0 points)
    I have also had airport, bluetooth etc all off/disconnected while trying but this hasn't helped.

    Wokfi is this sort of thing too,
    http://www.instructables.com/id/Wifi-Signal-Strainer-WokFi/
  • Wilburtron Level 1 Level 1 (0 points)
    Problem solved, I managed to find another driver. For anyone else who struggles with this there are 3 drivers available for the rt2870 - CD, Edimax and Ralink.
Previous 1 2 Next