Previous 1 2 Next 29 Replies Latest reply: Dec 5, 2010 5:26 PM by mountainrivers
Macalima Level 1 Level 1 (0 points)
Every so often, the cursor will jump to a different part of the screen, while I'm typing. My wrists are nowhere near the trackpad when the cursor jumps (just my fingers touching the keys). I'll be typing something and when I look up, the cursor has moved and I'm typing over something I previously wrote.

I'm so frustrated with this issue and I haven't found a solution online. I purchased my MacBook Pro in June 2009 and started to notice this quirk in September. I haven't banged up or spilled anything on it. Does this happen to anyone else? Any ideas before I make an appointment with Apple? It would save me a 40 minute trip in the car with 4 kids.

Thanks so much.

Macbook Pro, Mac OS X (10.5.8)
  • Macalima Level 1 Level 1 (0 points)
    I found this:

    "On MacBook and MacBook Pro computers, Mac OS X provides a feature that enables the trackpad to accept a "tap" as a mouse–click. You may find that if this feature is enabled while you type, your palms or thumbs may accidentally touch the trackpad, moving the cursor unexpectedly or creating a mouse–click in the wrong place.

    To avoid this situation, you can enable the "Ignore accidental trackpad input" option, found in the Trackpad pane of System Preferences. You can open this pane by choosing System Preferences from the Apple () menu in the upper-left of your menu bar, then choosing Trackpad (or Mouse & Keyboard in Mac OS X v10.5 Leopard) from the View menu."

    BUT

    There is no option to "Ignore accidental trackpad input." What do I do now?
  • Kevin Stanchfield Level 1 Level 1 (110 points)
    You ARE touching the track pad. I've seen thousands of support posts like yours for laptops of all kinds, Apple, IBM, Acer, HP, etc... And it's always the same thing.

    Try this, cover the track pad with a piece of cardboard (tape it down) and use a USB mouse. Notice how the pointer stops moving around when you type.
  • Macalima Level 1 Level 1 (0 points)
    Thanks for your reply.

    In the event that I am touching the trackpad (I use my two index fingers only and my hands are above the keyboard), how can I tell my MacBook to ignore accidental trackpad input? As I posted a few minutes ago, it's a known issue and Apple has a publication with a resolution: http://support.apple.com/kb/TS2302 but I cannot find that particular box to uncheck. My MacBook is fairly new (mid-2009). My only other option is to suspend myself via wires, ala Tom Cruise in Mission Impossible to avoid touching the super sensitive trackpad.
  • Macalima Level 1 Level 1 (0 points)
    Thank you again. I really appreciate you taking the time to help me with this.

    I should go see about setting up those ceiling wires...
  • Rod Hagen Level 7 Level 7 (31,985 points)
    Mmm, before you start hanging from the ceiling here are a couple of other thoughts.

    The track pads in these machines rely "capacitance coupling" to work out what is required of them. Various things can interfere with this process. Some are very simple - dirty fingers, a dirty trackpad, a powerful electrical device in close proximity (sticking your MBP next to the microwave probably isn't a good idea) , etc etc.

    Others are maybe less obvious. Some people have found, for example, that the problem will occur only when using the mains adaptor, or only on battery, or only on the mains adaptor when using the two pin "duckhead plug" rather than the three pronged, and properly earthed, cord to attach it to the mains (the body of an MBP can actually carry a current itself at least in in some situations). Sometimes people find that by using an earthed cord AND earthing themselves (not wearing insulating shoes, for example) can affect it.

    Jewellery is sometimes claimed to have an effect, too. Big chunky metal bracelets might not be good things to be wearing while surfing the net, but even rings and pendants have been implicated in some situations(though often the claims I've seen are anecdotal and not very clearly made)

    A few people also indicate that a PRAM reset has fixed the problem for them.

    http://reviews.cnet.com/8301-13727_7-10330102-263.html has some similar observations and suggestions

    Others, however, have had to have the upper case and trackpad replaced under warranty to resolve the issue.

    So don't give up and imagine you have to emulate a circus performer whenever you want to do a bit of typing! If the suggestions above don't resolve it, then take it in to Apple before your warranty runs out.

    Cheers

    Rod
  • eww Level 9 Level 9 (52,975 points)
    As I posted a few minutes ago, it's a known issue and Apple has a publication with a resolution: http://support.apple.com/kb/TS2302 but I cannot find that particular box to uncheck.


    I'll just confirm that in OSX 10.5.8, there is no such option to uncheck. I think it was present in Tiger, but disappeared with the introduction of Leopard. I remember remarking on its absence shortly after I got my MBP 13 months ago.
  • Retired Engineer Level 4 Level 4 (2,735 points)
    I have 10.5.8 and the next to last line of the Trackpad screen in System Preferences is

    Ignore accidental trackpad input

    Check the box to enable the function.
  • eww Level 9 Level 9 (52,975 points)
    That option doesn't exist in 10.5.8 on my machine, RE. I have the original late-'08 2.4GHz 15" unibody MBP. There have been several threads in the past year mourning its absence, so I'm not alone by any means. I'm very surprised to hear that you have it.

    EDIT: Ah, I see you have a 2.0GHz non-unibody MBP. That probably explains it.

    Message was edited by: eww
  • Rod Hagen Level 7 Level 7 (31,985 points)
    Yes, that's the answer, eww. The "ignore accidental trackpad input" still even appears using Snow Leopard on my non-unibody MBP 2.2, but not, of course, on the MBP13.

    (As an aside it is amazing how quickly you get used to using some of the later trackpad features. I'm forever doing a "four finger swipe" in an attempt to switch applications when using the old Santa Rosa and getting a shock when it doesn't work! )

    Cheers

    Rod
  • Macalima Level 1 Level 1 (0 points)
    Rod, sorry it took me so long to reply. I wanted to try a few things first.

    Trackpad clean? Check.

    No jewelry? Check.

    PRAM Reset? Check.

    I've never used the two pin "duckhead plug" with my MBP. So: Check.

    Would sitting 4 feet in front of a 48" LCD television be an issue? That's a big electrical device. There's also a home media dvr. I just can't believe I've paid so much money for such a fussy device.

    I've made a reservation to visit the Genius Bar this Friday. I'm not so certain I will be able to replicate the problem on demand. But maybe I'll come back to this thread and type in a few things, since it's happened 3x since I've started typing out this post. My warranty expires in June, I believe. So I'm hoping they will replace the trackpad.

    Can anyone tell me how to backup my MBP prior to my visit?

    Thanks!
  • Rod Hagen Level 7 Level 7 (31,985 points)
    The TV could be the issue, but I doubt it. Easy to check, really. Just try using the computer somewhere else! (Worth trying it on a completely different power circuit if possible).

    As far as backing up goes, in a situation like this where you probably will want to simply copy the entire drive back if they wipe your internal doing repairs, I'd use SuperDuper to make a clone of your drive on an external HD (firewire drives are faster than USB by a considerable margin, but a little dearer, if you are going to be buying one for the occasion). You can do this with the "free trial" version if you wish, though SuperDuper is so useful for general backups that it is well worth the shareware fee to unlock all its features.

    Cheers

    Rod
  • Macalima Level 1 Level 1 (0 points)
    I completely forgot that this has happened in the dining room too, all the way on the other side of the house.

    Thanks for all of the suggestions and I'll let you know what happens.
  • Rod Hagen Level 7 Level 7 (31,985 points)
    Rod Hagen wrote:
    (As an aside it is amazing how quickly you get used to using some of the later trackpad features. I'm forever doing a "four finger swipe" in an attempt to switch applications when using the old Santa Rosa and getting a shock when it doesn't work! )


    Given the context of this thread, I should note here that by a "shock", I simply meant a "surprise", rather than something of the electrical variety!

    Cheers

    Rod
Previous 1 2 Next