Previous 1 2 3 4 5 6 7 Next 95 Replies Latest reply: Jul 17, 2010 9:20 PM by Anson Huuuuu Go to original post
  • wblink Level 1 Level 1 (0 points)

    Iphone is new (1 week old) update the firmware tot 3.1.3 right away.
    My wifi connection works ok UNTIL I turn on MAC ADDRESS filtering on my router. The address in my router and in the info on the phone are the same so there should not be any problem ... but there is.
    Any further idea's?
  • AWAC Level 1 Level 1 (5 points)
    Ladies and Gents,
    I have ben experiencing this problem of and on more a few months with both my 16GB iPhone 3G and my 32GB iPod Touch.

    I got it big time when I upgraded to 3.1.3 last week.

    GOOD NEWS: I just cracked the problme and now both units work like new.

    Here's what you do:

    1. Make sure that the unit (iPhone or iPod Touch) is NOT connected to WiFi.
    2. Go to Settings, General and scroll down and go to Reset.
    3. FIRST: touch Reset Location Warnings. Wait for the nit to do its stuff.
    4. When that has completed, touch Reset Network Settings. You will see that your unit seems to switch off (Please do not worry) just leave it to do its stuff and switch itself back on.
    5. Press the main button to go back to the "home screen" showing your Apps.
    6. Go to Settings and then WiFi and set up the Wifi as you normally would.
    7. Your WiFi should now be restored and all in working order.

    If it dinna work fer you, well all I can say is that it worked fer me!

    I am VERY happy.

  • wblink Level 1 Level 1 (0 points)
    It didn't work for me: still the same: Mac Address filtering is not possible.
  • clarephile Level 1 Level 1 (0 points)
    thanks for trying AWAC but no joy - i've restored to a new phone, restored from backup, reset network settings, reset location settings... in short, pretty much everything and still no wifi after the 3.1.3 update. it'll find and connect to my wifi at home but it won't use it and reverts to 3G instead. (3G btw seems to be killing my battery life more than before too)

    wifi worked continuously perfectly for MONTHS with 3.1.2! something in this latest update was crap.
  • wblink Level 1 Level 1 (0 points)
    clarephile wrote:
    wifi worked continuously perfectly for MONTHS with 3.1.2! something in this latest update was crap.

    I never used 3.1.2, started wit 3.1.3 in my new phone.
    Can you disable Mac Address filtering in your router?
    This the ony way I can get wifi working.
  • Roru Level 1 Level 1 (0 points)
    Same problem here, Iphone 3.1.3 with wi-fi problem.
    I seen that if i switch off and on the wi-fi connection is ok for few second and then don't work.
    I try everything is write on this post, but with no success.
    any ideas or suggestion are welcome.
  • Graham Outterside Level 4 Level 4 (2,910 points)
    tomagion wrote:
    Reading this and the other posts on Wifi problems is disturbing.

    Not to make light of the issue, but this is a technical support forum for those with problems - you won't get millions of people logging in to say things are okay. By definition, issues here are problems so don't be disturbed.

    FWIW, I think there is an issue but its not as simple as a bad build but is a combination of Apps, setup, Windows and a lot of other variables that have never been tested - nor could they be. Take a new clean iPhone, update it and it'll be fine. Everything after that is down to what individuals do to their iPhones.

    Hope the issue gets fixed for you though. I know I've never had a problem and hope that still means I'm in the silent majority.
  • Roru Level 1 Level 1 (0 points)
    a little update after some testing...
    i done some test on safar:
    url like: doesn't work
    url like (it's my access point) work ok I can access on access point from iphone

    So it's mean that the wi-fi connection between iphone and access point is ok.
    my wi-fi and router config is ok, right now i'm using it on my mac.
    i think there is something on in iphone's network an internal proxy or something like that.

    Please who have same problem can do the same test i done to see if the problem is the same?
  • Graham Outterside Level 4 Level 4 (2,910 points)
    Roru wrote:

    my wi-fi and router config is ok, right now i'm using it on my mac.

    Not necessarily - your router could be allowing Mac traffic and blocking iPhone traffic. It shouldn't do that but it COULD be as its acting up.

    Disable the router firewall completely, or look at the config of the router in its control panel, find the phone IP address and set it specifically as a DMZ address so it appears 'outside the firewall'.
  • Roru Level 1 Level 1 (0 points)
    Thank you for suggestion.
    All test done, but with no success.
    Do you know a really strange thing that i couldn't explain... just yesterday everything was ok after upadte to 3.1.3 fw I installed various apps from app store, wi-fi conn worked really nice, then it just stopped with apparently no reason.
    I really would like to understund!!!
  • John Christopher1 Level 1 Level 1 (15 points)
    Does the app WiFiFoFum find networks and connect to them for those of you with this problem running 3.1.3?
    I have the same problem with a 3GS and 3.1.2 (and there's a huge thread on this) and I can connect to WiFi with WiFiFoFum--even though the networks still don't show up under the iPhone's network.
    BTW I have two wireless networks at home, one with a Airport Extreme, one a Netgear--both show up with WiFiFoFum, but not the iPhone system.

    Message was edited by: John Christopher1
  • IftiBashir Level 1 Level 1 (70 points)
    I can find and connect to wifi networks ok - its just once connected things are so slow, and my wifi speed is around 0.03MB! Hardly worth having at all since its almost unusable!
    Even after resetting the network settings, which I initially thought cured the problem, I get the same.
  • gansan Level 1 Level 1 (0 points)
    I also had my wifi stop working on my 3gs after the 3.1.3 update. The base station shows as connected in the wifi screen with full strength. However, the phone remains in 3g mode. I have tried:

    1. Reboot
    2. Forget wifi network, then re-join
    3. Reset network settings
    4. Phone restore from backup
    5. Phone restore as new phone
    6. Static IP

    The static IP seems closest to working. Setting the address and gateway results in the phone switching to wifi mode. However, the DNS lookups are failing. I am not sure yet whether this is because I am using the router as my DNS lookup.

    The fact that a static IP address makes the phone connect seems to point at something to do with DHCP being a problem. As a previous poster noted, a bogus address 169.<something> appears instead of the correct internal 192.168.1.x address that I would expect.

    All other devices connected to the base station seem to be working fine.
  • Lawrence Finch Level 7 Level 7 (33,330 points)
    If there is a 3.1.4 it will at best be a couple of months. And it may not fix whatever problems you have, because, while it is hard to believe, there are very few people who have your problem. So if you just sit and wait it won't get fixed. If you want it fixed take it to an Apple store, demonstrate it to someone at the genius bar, and the will exchange your phone for one that works. And they will test it to verify that it works.
  • Lawrence Finch Level 7 Level 7 (33,330 points)
    That's easy; DHCP is not working on your router. Sometimes you can fix it by simply power cycling the router. It's very common on inexpensive routers (meaning under $500) for the DHCP server to quit after a few weeks of operation.