6 Replies Latest reply: Mar 11, 2010 7:46 PM by zack341
Nicole S 1305 Level 1 Level 1 (0 points)
I have had problems for about two weeks now connecting to my wifi at home. I kept trying at different times thinking maybe the iphone needed to be reset. finally, today, I fully restored my iphone (and unfortunately upgrading to 3.1.3) I'm still having the same problem- I go to enter the wifi password, and it says unable to join the network. I can connect to other networks too.

Is there a way I could have locked out my own wifi signal?

PC, Windows Vista
  • ironman1964 Level 1 Level 1 (5 points)
    I am having the same problem. I had to get a new modem today and hooked it up. All seems to be working well except connecting my iphone to the wi-fi. I am using the correct pin #.
  • Nicole S 1305 Level 1 Level 1 (0 points)
    I haven't changed anything though. I cannot figure out why I'm having this problem.

    I did notice right before I started having the problem that I accidentally connected to another network nearby. I disconnected, and "forgot" the network, then tried to connect to my own, and started having problems.

    ugh.

    I'm probably just going to have to schedule an appointment with the genius bar, becuz I can connect to any other network (including that original nearby network) instead of my own.
  • Tom Smith3 Level 1 Level 1 (45 points)
    I, too had problems connecting my iTouch with my home computer. I did everything suggested and then called Apple. They worked very hard for me to find the problem ... even the engineers got involved. They found that the Symantec firewall downloaded from my ISP, Comcast, interfered with the iTouch communicating with the computer. As soon as I disabled the Symantec wall (not the internal mac firewall) my iTouch was back communicating with my computer. Apple deserves a lot of credit for isolating the problem. So, for those of you with this problem, check out your third party security software and remove what you must. Kudos to Apple customer service on this one.
  • zack341 Level 1 Level 1 (0 points)
    I too am having problems connecting to WiFi with an iPhone 3GS after updating to 3.1.3 (it's my wife's) mine is still on 3.1.2 and it's fine. Seems that you can't go back without hacking your phone?
  • zack341 Level 1 Level 1 (0 points)
    interesting - on a whim I shut off the bluetooth - don't want to jump the gun here but it's much much better - hasn't failed yet - browsing and email respond immediately - wouldn't connect at all before. Possible that 3.1.3 introduced a routing issue between WiFi and bluetooth interfaces? technically I suppose it's possible....
  • zack341 Level 1 Level 1 (0 points)
    nope - jumped the gun - it worked fine for awhile though - false alarm