5 Replies Latest reply: Feb 14, 2010 9:01 AM by kocorap
kocorap Level 1 Level 1 (0 points)
Every couple of minutes I have to run Network Diagnostic because my ISP, Internet, and Server lights have gone red. I've read tons of identical topics with people complaining of the same thing, I'm just posting this to know if there's a possible quickfix, seeing as there is no apprent solution. I'm not computer savvy so I am completely oblivious to terms like: tcp, dhcp, ip, dns, subnet mask, router, ipv4, etcetera. So if anyone has an answer to how to fix this crap, please use "computers for dummies" language.

Macbook Pro, Mac OS X (10.6.2)
  • sig Level 8 Level 8 (35,780 points)
    Some info about your set up might be useful. How are you connected? Cable modem? Router? Make and model? What have you tried? Have you checked your airport connection at a wireless hot spot? Have you power cycled your equipment? What does your ISP say if anything. See no terms like tcp, dhcp, ip, dns, subnet mask, router, ipv4, etcetera. Opps, I did say router. But I didn't say crap.
  • kocorap Level 1 Level 1 (0 points)
    The wireless router is called "linksys wireless-g broadband router", model wrt54g2 v1. The only thing I've tried is just disconnecting everything and leaving it off for a while... That wasn't really doing anything so whenever I'm surfing and I notice it stops loading I know the connectivity is down. When that happens I have to run the Network Diagnostic for it to fix it. When the window opens, I can see the lights for ISP, Internet, and Server are red and underneath each one it says "Failed". I tried accessing http://192.168.1.1 but I have no clue what to look for there so I didnt touch anything. If it helps, it says:

    connection type: automatic configuration - dhcp
    local ip address: 192.168.1.1
    subnet mask: 255.255.255.0
    dhcp server: enabled
    starting ip address: 192.168.1.100
    maximum number of dhcp users: 50
    all the static dns say 0.0.0.0

    While I desperately googled for answers, I found something that said:

    "With certain routers, OS X will choose to use the address of the router as the DNS server's IP address. Therefore, it will first try and contact the router to get DNS info, and only after a while will it find it's way to the net. The solution is to go in the Network System Preferences panel and select 'Manually' instead of 'Using DCHP'. Then fill in the IP address, subnet mask, router address, and DNS server address. Click 'Advanced' and then go to the 'DNS' tab to verify whether the correct DNS IP has been entered, or to enter multiple DNS IP addresses. While in the Advanced section, make sure that under the 'TCP/IP' tab, 'Configure Ipv4' is set to 'Manually,' and 'Configure IPv6' is set to 'off.' "

    Problem is, it doesn't say what to fill in for all those values.

    Let me know if I need to provide any more info.
  • sig Level 8 Level 8 (35,780 points)
    Try this: System Preferences>Network>Advanced>DNS. In the box on the left side click on the + and add the following:
    208.67.222.222
    288.67.220.220
    Then click OK button. Then click Apply button.
    Post back with any issues.
  • Xephremon Level 1 Level 1 (0 points)
    i've been plagued by this problem shortly after i purchased my 15" MBP in early september 2009, but i always thought it was the uni internet provider (keysurf lol) however no one else with a MBP was experiencing this issue. my wireless kept continuously disconnecting but that only happened sparingly so i didnt make much of it...

    it wasn't much of an issue until i found my snow leopard installation disk in my MBP packaging. apparently i had bought one that didn't have snow leopard installed. a couple of weeks after the installation the airport started messing up ALOT. i have to turn the airport off and on multiple times to get it to work at all. i spent hours yesterday looking the issue up and after 3 hours i realized that all the posts i was looking at were dated EARLY 2008!!! it was quite shocking but heres what i think i learned:

    FIRSTLY: this is a MBP software issue. i will double check on my windows partition after i post this message.

    SECONDLY: only certain MBP's have the problem. in certain cases put up on the forums users complained and contacted apple support enough times to get a new MBP. the one case i read reported that the problem did not plague his new laptop. i HAVE checked the ISP wireless connection on my girlfriends windows laptop (which has survived 3 different drinks being spilled on it, been sprayed with glue, trampled on and dropped numerous times) and the internet works just fine. it connects immediately and does not disconnect like my MBP airport does.

    THIRD: apple will NOT comment on the problem or let you know that its their product that is defective. you will NOT be told that its a known issue. you WILL run around in circles until you get a new macbook IF you do. you will ALWAYS be told its a router/ISP problem

    FOURTH: some of the listed fixes include the alternate DNS settings the guy above me posted. i personally knew about this through windows experience and manually setting up a MBP Xbox Live connection which requires these parameters to be manually entered which doesn't bode well for a PORTABLE device... (this solution did not work for me)

    FIFTH: some people listed that the solution that worked for them was to disabled the airport from remembering the wireless network that they joined. everytime the disconnect occurred, they simply go to the list of wireless connections in the network preferences and remove that network and then add it again.

    SIXTH: another proposed solution stated that the issue was regarding the airport frequency type... alt (or as mac users call it-- OPTION) clicking the airport indicator by the battery button brings up some additional airport information including the PHY mode which for me and all the people who reported the issue was 802.11b... this is the frequency that the airport card is using to connect. you will also get your SSID information (which is basically the ID that the airport/computer broadcasts in order to get a connection)

    by default most routers/laptop wireless cards use the 802.11b frequency AND most laptops have their SSID broadcast disabled which means that when someone is "looking for a wireless connection", they will not see your computer on the list.

    the proposed solution stated that you must find a way to turn your airport settings so that it enables SSID broadcast and switch to a combination of frequencies (802.11b/a/g etc...) when i tried doing this, i went to applications > utilities > AirPort Utility WHICH LEADS ME TO THE NEXT COMMON PROBLEM!

    SEVENTH: lots of people have been reporting back in the early 2008 posts that it appeared that their airport cards were not installed at all. now, in my AirPort Utility tool, my airport card appears to be missing in there. i called my friend who also has a 15" macbook purchased at the same time as mine but with snow leopard preinstalled (so im assuming its a slightly newer one) and his airport utility tool showed some options whereas mine simply says:

    "AirPort Utility was unable to find any Apple wireless devices. Make sure the Apple wireless device you want to set up is plugged in and in range of your computer then click rescan to try again." <<Rescan button below>>

    however when i went to the System Profiler tool (top left apple icon in the toolbar > About this Mac > More Info) the airport card seems to be identified in the list of hardware installed on the MBP

    now i dont know if im looking in the wrong place to change my PHY mode or my SSID broadcast but i found numerous posts claiming that apple customer support recommended the command + Option + P + R solution.

    basically they instructed users to turn off their laptop, take out their power cord and battery, put the battery back in, HOLD DOWN command + Option (also known as ALT) + P + R then push the power button while continuing to hold these buttons down. the laptop restarts itself when it reaches the greyscreen / when u hear the startup chimes. the instructions stated that you must hear the chimes/hold down the buttons while the laptop restarts 2 or 3 times (i cant remember...)

    this is supposed to flush your something something RAM, i have no idea what thats on about but you can google the command to find out what it does. i tried this solution but i didn't want to take out my battery because i was afraid of tampering with the sealed/tightly screwed case... and i didnt have a screwdriver small enough. ">_> sure enough the solution did not work but i didnt exactly follow it to the letter. the airport utility tool showed no change and my airport was still very troublesome. which finally brings me to

    EIGHTH: some vague solutions i found from the old early 2008 posts stated that you must take out a certain file named AppleAirPortSOMETHINGSOMETHING.kext found in MaccintoshHD > System > Library > Extensions... however the file was missing from my list of *.kext files... i was perplexed. this was the first thing i looked up before all the above solutions. i happened to stumble back into this folder looking for the file because of the System Profiler Tool (Mac Icon > About this Mac > More info)

    i had accidentally stumbled into the "extensions" section listed under "Software" in the list to the left of the system profiler tool. my mac gave me the spinning beach ball of death as i had been manically clicking around to find anything relating to the airport settings... so i couldnt do anything until the beachball stopped spinning and the list was finally compiled afew seconds later. thats were i found a list of AppleSOMETHINGSOMETHING files! and sure enough, the file mentioned in the fix (appleAirport"blahblah".kext) was listed there with its proper location which for my system architecture was:

    Mac HD > System > Library > Extensions > IO80211Family.kext
    (right click that file and select show package contents)
    then navigate as follows: Contents > Plugins > *list of files*

    the file most resembling the one proposed to be deleted was called "AppleAirPortBrcm4311.kext" along with it were 3 other files named as follows:
    "AppeAirPortBrcm43224.kext"
    "AirPortAtheros.kext" <<<< does NOT contain APPLE at the start. this is NOT a typo
    "AirPortAtheros21.kext" <<<< does NOT contain APPLE at the start. this is NOT a typo

    at first i only removed the first file from the folder and that did nothing to my airport (even after i restarted) so i went back and removed all the rest of them, restarted and now i can safely say my airport is FIXED! all this happened just yesterday (oh yea i also managed to download the airport software update which did nothing for me) so thats why all these steps are detailed.

    now be careful with this solution. before you take these files out of there TAKE A SCREENSHOT showing you were the files are!!! take a screenshot showing you the files listed in the System Profiler Utility > Software > Extensions... take a screenshot of anything and everything you do to REMIND YOU HOW TO UNDO IT! and for the love of God do NOT delete those files! save them somewhere safe along with the screenshots and back them up in any hard disk AND flash memory sticks (at least more than one!) who knows what will happen after the next update if those files are missing, so at least you will know how to put them back!

    and please please please try all the proposed solutions before resorting to taking files out of your system architecture... im NOT going to claim that i know what im doing but this solution worked for me. good luck and report back any success or failures you get. im going to check this post later today and at least for the rest of the week while im checking that my airport is indeed working correctly. (note i tested my airport. after putting it to sleep several times and/or turning the airport on and off several times it has been working without glitches (it was slow ONCE! but it sped up when i pushed command+R = refresh on my safari and firefox browsers)

    good luck
    -abe

    ps: sorry for the long read... :/
  • kocorap Level 1 Level 1 (0 points)
    is there a way to downgrade from snow leopards? or atleast downgrade the airport? because everyone complains that this all started after the upgrade...