5 Replies Latest reply: Jul 3, 2010 2:37 AM by sniccet
Björn Steiner Level 1 Level 1 (15 points)
I have an Apple Fax Modem connected to a Macmini Server - how do I enable Fax sharing?

Macmini late 2009, Mac OS X (10.6.2), Snow Leopard Server
  • Erich Wetzel Level 2 Level 2 (315 points)
    One other thing to look out for is the fact that the Apple USB modem does not seem to work when the server is running in 64 bit mode. I cannot remember how I got the server to boot in 32 bit. Take a look around the net for how to do that. I imagine there are a variety of methods.

    There do appear to be other USB fax modems that will work with the 64 bit mode around that might be worth trying.
  • Bill Eccles Level 1 Level 1 (130 points)

    The answers in the other threads seem to apply to 10.6 Client and how to share a 10.6 Client fax over multiple subnets.

    I'm stuck trying to figure out how to share a fax modem (a non-Apple USB fax modem which seems to be quite well supported within the OS, as faxing from the server works just fine) from 10.6 Server to 10.6 Client machines.

    There used to be a hack (I can't find it at the moment) which would allow you to make a 10.5 Server machine boot as a client machine and allow turning on the sharing for the Fax modem.

    Any clues?

  • Bill Eccles Level 1 Level 1 (130 points)
    Hmm. I think maybe I found it.

    I monkeyed around with /etc/cupsd.conf, got it to work, but ended up just doing this:

    1 - Create the fax printer using the usual MacOS X Server System Preferences. I also set it up to answer and receive, and that works OK. I then tested the fax printer to make sure it works. (The modem is a MultiModem USB, FYI, so no Apple Stick-Of-Gum Modem problems to deal with.)

    2 - Use Safari to visit localhost:631/printers/. Selected "MultiModemUSB".

    3 - Selected "Maintenance" and "Modify Printer" from the drop downs. Entered my administrator username and password.

    4 - After some Carousel spinning, clicked "Current Connection" and "Continue".

    5 - Checked "Share this printer" and "Continue".

    6 - Left all settings as-is and clicked "Modify Printer".

    7 - Clicked the "Administration" tab.

    8 - Checked "Share printers connected to this system".

    9 - Clicked "Change Settings".

    After cupsd restarted, I was able to browse on 10.6 client machines to see the fax machine using the Default browser!

    Could it really be that easy? Is this going to work? Will Superman be able to save Lois Lane in time?

    Tune in next time...
  • sniccet Level 1 Level 1 (0 points)
    Great. It also works with the apple usb modem.

    thx for the howto