5 Replies Latest reply: Feb 12, 2010 1:14 PM by bikrgran
icculuss Level 1 Level 1 (0 points)
Ipod Touch 2nd Gen 16G frozen during an app use. When restarted showed the Apple Icon screen for less than 2 sec. and goes to the Itunes USB screen. Plugging it into my computer results in a Found New Hardware pop-up (Ipod Recover Mode). Downloaded latest updates successfully, but Itunes doesn't recognize my device is plugged in so I can't restore it or anything. Yet I know my computer knows it's there from the New Hardware messages I'm getting.

Windows XP
  • Ingo2711 Level 7 Level 7 (20,335 points)
    Welcome to the discussions,
    did you check your drivers and Apple Mobile Device Service? See this article for more details: http://support.apple.com/kb/TS1538
  • Grandmaina Level 1 Level 1 (0 points)
    Did you get this problem worked out? I followed the link in the reply that you had and have not made any progress toward resolving my problem--Apple logo for a few seconds, then the USB connecting to iTunes logo (even when iTunes is already running). right now this 32 G iPod touch is a totally worthless piece of hardware.
  • Ingo2711 Level 7 Level 7 (20,335 points)
    Did you try to connect in recovery mode? http://support.apple.com/kb/HT1808
  • BonnyL Level 1 Level 1 (0 points)
    I am also having this problem. I updated my iTouch to firmware 3.1.3 as suggested, however now all I get is the "connect to itunes" screen and when I plug the USB cable into the computer I get a popup that tells me "found new hardware" with "windows needs to install driver software for your apple mobile device (recovery mode)"

    I have checked the Device Manager, and beside the apple device recovery mode, there is a small yellow triangle, which signals that the driver is not installed. I have tried to link the driver install location to C:\Windows\system32\drivers or C:\Windows\inf and even C:\PROGRAM FILES\COMMON FILES\APPLE\MOBILE DEVICE SUPPORT\DRIVERS or C:\PROGRAM FILES (X86)\COMMON FILES\APPLE\MOBILE DEVICE SUPPORT\, but to no avail. The device remains uninstalled.

    I have reinstalled iTunes three times, but problem remains - PLEASE HELP!!!
  • bikrgran Level 1 Level 1 (0 points)
    I'm having basically the same problem, but my I-tunes window says restoring I-POD software, and I have the I-Tunes/USB picture on my Touch. It's been this way for hours, so I'm sure it's locked up. I've tried resetting, and all the other ideas I've seen, to no avail. I've unplugged, plugged, turned off/on, rebooted, and nothing changes. I spent too much on this to just let it go up in flames. I was trying to update my I-Tunes software, which I'd gotten a pop-up for. HELLLLPPPP!

    Thanks!