4 Replies Latest reply: May 10, 2010 1:21 PM by Egreen
caw35slr Level 1 Level 1 (10 points)
When using Safari 4.0.4 on OSX 10.6.3 I occasionally load a page that is bigger than my window but Safari doesn't display scrollbars.

Right now I have the same page (my Facebook home page) open in two tabs. One rendered with a scroll bar, the other did not.

It's pretty annoying. A quick Google tells me that this has happened to previous versions of Safari. I've reported the bug, but does anybody know a workaround or fix?

iMac: 2 GHz Core 2 Duo, 4 GB RAM. MacBook: 2.13 GHz Core 2 Duo, 4 GB RAM, Mac OS X (10.6.2)
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    HI,

    When using Safari 4.0.4 on OSX 10.6.3 ????????

    It's not a bug... do maintenance.

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Go here for trouble shooting 3rd party plugins or input managers which might be causing the problem.

    http://support.apple.com/kb/TS1594

    Third party software has caused issues for others with the scroll bar issue... http://discussions.apple.com/thread.jspa?messageID=10623053&#10623053

    Since you are running Snow Leopard make sure Safari is running in 32-bit mode, not 64. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Also, (in that same window) make sure Safari is NOT running in Rosetta.

    From MacGuides... http://guides.macrumors.com/Speedup_Safari#Erase_WebsiteFavicons



Most web pages now include a small icon or 'favicon' which is visible in the address bar and next to bookmarks. With the vast amount of websites available over the internet, it is obvious that these icons can potentially take up a fair amount hard disk space. This will cause slow downs due to Safari having to 'sift' through the collection to find the right image. It is possible to erase the icons from your computer and start fresh.

 *To delete Safari's icon cache using the Finder, open your user folder, navigate to ~/Library/Safari/ and move this file "webpageIcons.db to the Trash*

    Clear Google History...

    1. Go to the Safari Menu
    2. Select Preferences
    3. Select Autofill tab
    4. Select the Edit button from the Other Forms Line
    5. From the AutoFill list of sites select Google.com
    6. Select Remove
    7. Select Done



    Relaunch Safari.










    Carolyn
  • caw35slr Level 1 Level 1 (10 points)
    Indeed. 10.6.2...

    Thanks very much for the comprehensive reply! I'll work through your suggestions and will update this topic accordingly...
  • thucydides' elbow Level 1 Level 1 (0 points)
    if it's not a bug, what is it? a feature?
  • Egreen Level 1 Level 1 (0 points)
    ROFL! Yeah, the Apple II manual defined "feature: A bug as described by marketing" .

    I've been encountering this bug off and on for a couple of years now and end up having to open the page in a different browser window to deal with it. It irritates me enough that I even switched to Chrome for a while, but Chrome has its own issues (mostly to do with not being compatible with some of the more complex web sites out there due to its limited plugin capabilities). I still have not heard of a reasonable explanation for why it happens, the old nonsense "it's something the web site did!" doesn't make any sense -- it doesn't affect Chrome (which similarly uses Webkit to render its pages), so why would it affect Safari but not Chrome? I suppose a plugin could be doing something to turn off the scrollbar -- but why does Safari allow plugins to do things like that in the first place? That sounds to me like a "feature" akin to a bullethole through the head!