10 Replies Latest reply: Mar 2, 2010 9:19 AM by Taro-71
Taro-71 Level 1 Level 1 (0 points)
Hi, using Aperture 3 Trial (I'm waiting the deliver of full one from AppleStore) with few Canon RAW images I've experienced very often crash of the application and two kernel panic (sad), especially using brush tool like skin smoothing:

0x98c93fc8 : 0x29e44d (0x2113c164 0x1 0x10 0x0)
Kernel Extensions in backtrace (with dependencies):
com.apple.ATIRadeonX2000(6.0.6)@0x99753000->0x998adfff
dependency: com.apple.iokit.IOPCIFamily(2.6)@0x8eea3000
dependency: com.apple.iokit.IONDRVSupport(2.0)@0x98cfc000
dependency: com.apple.iokit.IOGraphicsFamily(2.0)@0x98958000

After that I've tried to replace the ATI Radeon HD 4870 with my old Nvidia 8800 GT and the crashes are disappeared completely, also the kenel panic.

The 8800GT however is noticeable slower than ATi 4870 and Aperture3 is very slow with ATi, sadly slow with 8800 GT: using brush skin tool with zoom 1:1 (Z key) with color overlay and RAW images give refresh from a stoke to other until about 2 minutes! Unusable.

Also in that "wait state", activity window always reports: Generating Thumbnails (every says that)

Sorry to see that, because quality and features in this version are very exciting!

Maybe most other issues are mainly connected to graphics drivers.

macpro 8 Core 3GHz early 2007- cinema display 30", Mac OS X (10.6.2), 24 GB ram - ATI Radeon HD 4870
  • Mark Booth2 Level 1 Level 1 (45 points)
    I've played pretty extensively with Aperture 3 Trial on my Mac Pro with ATI Radeon 4870. After reading your message, I spent some time using the skin smoothing brush on a couple different Canon 5D Mark II RAW images. No crashes or kernel panics.

    That said, I didn't import a large number of photos into Aperture 3 Trial. I am waiting for the full version and will simply convert my entire existing Aperture 2 library. Maybe that's when I'll see more slowdown or crashes? But I plan to let it run overnight doing the conversion.

    Mark
  • Taro-71 Level 1 Level 1 (0 points)
    Mark thank you for your trial, with your token the mystery grows...

    I've reinstalled the ATi card in MacPro and the problems with Aperture3 returned same as before

    I also use RAW from 5D mark II and 7D, the library is small (only a dozen of photos) just for trial.

    A question: which screen resolution are you using?
    Maybe the issue is a combination of hi-res and video card, with CinemaDisplay 30" I work in 2560x1600 (using DVI dual-link). :/

    here, system profiler for more infos:

    ATI Radeon HD 4870:

    Chipset Model: ATI Radeon HD 4870
    Type: GPU
    Bus: PCIe
    Slot: Slot-1
    PCIe Lane Width: x16
    VRAM (Total): 512 MB
    Vendor: ATI (0x1002)
    Device ID: 0x9440
    Revision ID: 0x0000
    ROM Revision: 113-B7710C-176
    EFI Driver Version: 01.00.318
    Displays:
    Cinema HD:
    Resolution: 2560 x 1600
    Pixel Depth: 32-Bit Color (ARGB8888)
    Main Display: Yes
    Mirror: Off
    Online: Yes
    Rotation: Supported
    Display Connector:
    Status: No Display Connected
  • Stefan Haupt Level 1 Level 1 (0 points)
    Hi there

    I also have no problems and I have the same video card. My images are only tiff and jpeg.

    Regards
    Stefan
  • Taro-71 Level 1 Level 1 (0 points)
    Maybe I've found the heart of problem.
    Seems to be a combination of graphics board and screen resolution:

    I've temporarily lowered screen res at 1920x1200 and problems (crash and kernel panics) disappeared and Aperture3 works almost smooth.

    resuming:

    Radeon at 1920x1200, Aperture3 works like a charm
    Radeon at 2560x1600, Aperture3 crashes often and sometime kernel panic on ATi driver
    Nvidia 8800 at 2560x1600, Aperture3 works (but slowly)

    (No other application have problems)

    I think it's time to upgrade ATi driver (Apple engeneers are you reading?) :P
  • Taro-71 Level 1 Level 1 (0 points)
    Update:

    Now I'm working in SnowLeopard at 64Bit:
    ATi crashes often but a little less, speed is good.

    I've noticed that Aperture 3 crash are always on canon 5D & 7D RAW images, working on jpegs seems to not have problems.

    Only one time on a jpeg, using repair brush, the screen became black and a forced shutdown was obligatory (by power button).

    After reboot system logs reports:

    12/02/10 12.55.55 kernel ** GPU Debug Info Start **
    12/02/10 12.55.55 kernel 0x00009440
    12/02/10 12.55.55 kernel 0x000000cb
    12/02/10 12.55.55 kernel 0x00000001
    12/02/10 12.55.55 kernel 0x00000018
    12/02/10 12.55.55 kernel 0x000090c2
    12/02/10 12.55.55 kernel 0x00000001
    12/02/10 12.55.55 kernel 0x00000001
    12/02/10 12.55.55 kernel 0x00009440
    12/02/10 12.55.55 kernel 0x00000001
    12/02/10 12.55.55 kernel 0x00000015
    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel 0x00000001
    12/02/10 12.55.55 kernel 0x00000047
    12/02/10 12.55.55 kernel 0x00000000

    .......... very long cut .........

    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel 0x00000000
    12/02/10 12.55.55 kernel ** GPU Debug Info End **


    a very strange log file :/
  • firstlaunch Level 3 Level 3 (620 points)
    Does it still happen without using the dual link dvi adapter? And just plugged directly into the dvi port on his card?
  • Matthew Bergsma Level 3 Level 3 (600 points)
    Thanks for the long report.

    My nvidia 8800 Flies on my 3.2 8 core, but I use a 1920x1200 resolution...

    I was curious if you noticed a difference in launching the actual application itself in 32 bit mode, not just the system kernel.

    You should definitely file a bug with apple so they see this.
  • Taro-71 Level 1 Level 1 (0 points)
    uhm, the only DVI connector on this card is declared "dual-link DVI" (the only capable to drive a 30" cinema display)

    see the specs here:
    http://store.apple.com/it/product/MB999ZM/A?mco=MTY3ODQ5OTY

    no adapter is needed :/
  • Taro-71 Level 1 Level 1 (0 points)
    Before report to Apple I would like to find most precisely the reason for the crashes :/

    In those days I'm going to be crazy...

    Now I've had aperture crash, some time, also in 1920x1200, so maybe resolution is a false positive :/

    The last trials booting in 64 Bit kernel:

    - ATi - Aperture crash during editing RAW file from canon 50D 7D and 5D mark II
    - ATi - No crash editing jpegs
    - ATi - kernel panic on ATi kernel module during editing RAW file from canon 50D 7D and 5D mark II
    - ATi - Black screen and CPU/GPU hang editing jpegs

    - NVidia 8800 - Aperture crash during editing RAW file from canon 50D 7D and 5D mark II (with 64 Bit kernel is a bit faster)
    - NVidia 8800 - no kernel panic
    - NVidia 8800 - no hang editing jpegs

    I've tried editing the same kind of RAW file on the macbook pro 17" C2D and Aperture crashed...

    So, maybe is a combination between RAW file (crash Aperture) and ATi under pressure (kernel panic & hang)

    p.s under macbook pro (ATi Radeon X1600), during edit, often the screen become corrupted

    On macpro, I've tried also 64 Bit kernel and 32 Bit Aperure, but RAW file editing hanged anyway.

    Interesting the use of memory in 64 vs 32 bit, at 64 Bit (Aperture not kernel) editing a 5D mark II RAW file rise the memory up to 6 GB ram !!! in 32 Bit mode the same image and the same filtering reach only 3 GB of ram

    weird
  • Taro-71 Level 1 Level 1 (0 points)
    After Aperture 3.0.1 update, most of crashes are disappeared
    No kernel panic until now, only some sporadic apps crashes editing RAW file.
    Memory usage seems well-improved and speed also.

    Good work, now it's more usable