Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Canon MF8450 and UFR II, communication issues

We ended up having a Canon MF8450 planted to our office, and so far it has refused to provide reliable printing support for any of the (10.6.2) Macs we have.
Tried different configurations, using the printer's printer server and sharing the printer connected via USB to a mac. Local USB connections have proved to be working most of the time, returning 10322 errors every now and then. However, "Open Printer Utility" button on printer settings returns "Cannot monitor this printer with the current connection", even though printing works otherwise through USB.
As for drivers, tried the 2.00 UK and US 2.05 drivers, and out of countless attempts only once did one of the macs succeed in networked printing through LPD, for a short while before reverting to 10322 or 3150 errors like the rest. On that one attempt the Print & Fax displayed the printer URL as "cntdbmu://MCD UFR2_LPR/CanonMF8450/lpd://[IP]/" while adding the printer to other macs resulted only "lpd://[IP]" to be displayed with no printing support when printer installation steps were the same otherwise. Curiously, the other macs added the printer that time without any errors, neither was there any 10322 error displayed when a print job was carried out, the print job was only displayed on the queue for a few seconds until it vanished without a print.

As for the MF8450's network connection, I am able to access the http server of the MF8450 as well as its settings also from Canon NetSpot Device Installer, and both USB and network printing works from Windows applications in parallels using windows drivers.

For some reason, v2.0 UFR II UK drivers appear to have been pulled from software.canon-europe.com, providing v1.80 mac drivers as the only option. I managed to download the UK drivers from there 2 days ago.

Preferences > Print&Fax > Reset Printing System and re-adding the printer has no effect, neither has repairing disk permissions.
As the printer is added it appears "Idle", and once a job is queued the printer pauses and returns a 10322 "Cannot communicate with the printer, or the printer is not supported." error message. Resuming the printer queue also results with a 10322 or a -3150 "cannot find output destination".


Any clues on how to get this solved?

Mac Pro 8-core '09 + 8-core '08 + MBP15 '08 + iMac24" & iMac20" '08 + Mac Mini '08 + Mac Mini Server, Mac OS X (10.6.2)

Posted on

Reply

Page content loaded

Feb 11, 2010 9:21 PM in response to tmui In response to tmui

Hello and welcome to Apple Discussions.

Canon has released version 2.06 of the UFR2 driver. You can download the UK English version via this link.

http://support-au.canon.com.au/contents/AU/EN/0100212606.html

The new version does not include and uninstaller. So I suggest you remove the current print queue and manually trash the UFR2 folder, which is located in HD > Library > Printers > Canon. Before you can empty the Trash you may have to open Activity Monitor and quit the Canon UFRII BackGrounder.

With the new driver installed, add the printer via IP > LPD. Ensure you enter a queue name of LP.

Pahu

Feb 11, 2010 9:21 PM

Reply Helpful

Feb 12, 2010 5:54 AM in response to PAHU In response to PAHU

I removed the old drivers manually and thoroughly, installed the 2.06uk.
UFR II Printmonitor indicates 2.06 for its version, yet Pref > Print > (MF8450) > Options displays Driver Version 2.0?

192.168.0.15 being the printer, now installed at
cntdbmu://MCD UFR2_LPR/_192_168_015/lpd://192.168.0.15/LP
using "Canon MF8400 Series UFRII LT (UK)" 2.06 driver, print queue of "LP"

Still, Printer Utility / 2.06 UFR II Printmonitor can't connect to the printer; "Printer is not responding".
When trying to print from any application, the application freezes for 45-60 seconds before displaying the print dialog. Once the print job is queued, Canon UFR II Printer Driver dialog appears with the familiar 10322 "Cannot communicate with the printer, or the printer is not supported" dialog.

Printing with Windows drivers from Parallels or any native Windows computer still works flawlessly. So does direct USB printing, except for the lack of printer status info.

So far no luck with any UFR2 driver I've tried

(interesting, once trying to log in to Apple discussions my other id 'tmui' had disappeared from my profile, neither was i able to recreate 'tmui' again. Go figure, didn't even get an error message or anything.. oh well)

Feb 12, 2010 5:54 AM

Reply Helpful

Feb 12, 2010 4:18 PM in response to tmuin In response to tmuin

Not sure why you would be getting this error. I've seen this error when attempting to connect to an imageRUNNER model (bigger brothers of the MF series) that is not listed as a supported model with the UFR2 driver. But with the MF8450 available as a printer model, then there is possibly some sort of communication issue existing between the Mac and the machine. This could also explain the problem with the PrintMonitor.

Next thing I suggest is trashing the plist for the UFR2 print monitor. This is located in your user Library > Preferences and is called "jp.co.canon.mcd.CUPS.UFR2.Printmonitor.plist". Before trashing the file you should stop the UFRII Backgrounder service.

You may also notice in the this folder another couple of UFR2 plists.

jp.co.canon.mcdcups.ufr2.mcc
jp.co.canon.UFR2.PDEPref.plist

The first file appears to be related to multicast discovery, based on its file name, and the second file is related to job accounting. You could also try removing these files from this folder to Desktop rather than trashing. When you restart these files should get created again automatically, or at least when you attempt to print. If they don't get created again, then you can put the originals from the Desktop back.

Pahu

Feb 12, 2010 4:18 PM

Reply Helpful

Feb 15, 2010 1:55 AM in response to PAHU In response to PAHU

Some troubleshooting steps i've taken:

System Preferences > Print & Fax > Reset Printing system

sudo rm /Library/LaunchAgents/jp.co.canon.UFR2.BG.plist

top
11949- UFR II BackG 0.0 00:00.08 2 1 66 213 1044K 7616K 2864K
sudo kill 11949

- No items found starting with "jp.co.canon." at /Library/Preferences/

found /Library/Preferences/com.canon.ImageBrowser.ColorManagement.plist - removed
found /Library/Preferences/com.canon.ic_installer.plist - removed

sudo rm -R /Library/Printers/Canon/UFR2/

sudo rm /Library/Printers/PPDs/Contents/Resources/en.lproj/CNTDMF8400ZUK.ppd.gz


Running UFR II 2.06uk Installer

System Preferences > Print & Fax > Add ➕
Add Printer > IP
Protocol: Line Printer Daemon - LPD
Address: 192.168.0.15
Valid and complete address.
Queue: LP
Name: MF8450
Location:
Print Using: Canon MF8400 Series UFRII LT (UK)
Installable Options:
Paper Source Options: 500 Sheet Drawer
(X) Duplex Unit
( ) Job Accounting


Once added, printer status appears "Idle"

Options & Supplies...
URL: cntdbmu://MCD UFR2LPR/MF8450/lpd://192.168.0.15/LP
Supply Levels: "Information Not Available"
Utility: (Open Printer Utility)
UFR II Printmonitor:
Window title: 192.168.0.15
"Printer is not responding. Check the printer power connection, and select the printer form the printer menu again. If this error occurred in printing, documents may not have been printed correctly. Check your documents."


While trying to initiate a print job, the printing application freezes for a minute, and displays a Canon UFR II Printer Driver 10322 error.
MF8450 Print Queue pauses the printer.



Still, opening up Windows XP on the same Mac under Parallels 5, prints without a hitch with Windows XP UFRII drivers.

Feb 15, 2010 1:55 AM

Reply Helpful

Feb 15, 2010 5:25 PM in response to tmuin In response to tmuin

Maybe Parallels is causing your issue? Earlier versions of Parallels were the cause of stopping the networked Canon inkjet printer from being seen when attempting to add. Maybe 5 is also doing something with the virtual ports to block the comms from the printer back to the Mac?

A previous post stated that they were able to stop Parallels 4 temporarily by typing in Terminal;

sudo launchctl stop com.parallels.desktop.launchdaemon

This then allowed them to see the Canon inkjet. Not sure if this command will also work with Parallels 5 but it may be worth you trying to see if this is your issue. I use the same UFR2 driver to Canon imageRUNNER copiers and I have not had these comms problems when the printer model is supported.

Pahu

Feb 15, 2010 5:25 PM

Reply Helpful

Feb 16, 2010 12:21 AM in response to PAHU In response to PAHU

Unfortunately the problem was there prior to the installation of Parallels 5, and occurred on any mac I tried from a freshly installed Mac mini server to a Mac Pro to MacBook Pro to an iMac, regardless whether Parallels was installed or not.
I would rule physical network failures or routing problems out since network printing works fine from both native and virtual Windows environments.
What leaves me more puzzled is why did I manage to get some few prints out once using 2.00uk drivers (Parallels 5 was installed during that time), a condition I couldn't manage to recreate since...

And yeah, tried sudo launchctl stop com.parallels.desktop.launchdaemon

Thanks for your efforts.. this still remains a tough one, hoping for a new release of the UFR II set, this might be an isolated issue to the MF8400 series

Relaying print jobs directly from OS X to Windows printing host under Parallels would be a clumsy workaround I'd be willing to use, being better than nothing.. but I'm afraid that is yet without support.
Except for manually sending files to Windows to be printed under Windows applications, which is least to say frustrating and requires duplicate installations of certain programs for Mac and Windows versions

Feb 16, 2010 12:21 AM

Reply Helpful

Feb 16, 2010 3:42 AM in response to PAHU In response to PAHU

Ok. Found something I didn't check before

On the MF8450's web Remote UI,
System Manager Logon > Add. Func. > Settings > Dedicated Port was unchecked by default
After enabling Dedicated Port, I am able to print from OS X - however, UFR II Printmonitor still gives a 'Printer is not responding message', neither am I able to see the supply levels. Initiating the print job from OS X takes a considerably longer period of time than from Windows.
The print quality is a lot darker and the colour tones are way off, unalike while printing from Windows.

At least something is coming through, and even from multiple computers at once..

Feb 16, 2010 3:42 AM

Reply Helpful

Feb 17, 2010 2:50 AM in response to tmuin In response to tmuin

The dedicated port is a good find. The same setting exists on the imageRUNNER copiers, however it is turned on by default. Disabling this setting does block a number of the Canon ports, such as 47545 which is used by the Job Accounting function.

Regarding the Printmonitor, with it open, if you click on Printer in the menubar, you should see the MF8450 with a network icon beside it and some other options below this. If you click Search for Printer, the utility will do a multicast discovery on your network. It should find the MF8450 again, and if you select this and then click Get Device Information, it should update the plist with the correct network information and machine settings.

Regarding the longer time to print, this is most likely related to the Printmonitor not working correctly. I think that once this is resolved, the speed may improve. The same would apply to the toner supply levels.

Regarding the print quality, from the print dialog, if you change to the Quality menu and then select Quality Settings, you can change the Graphics mode from UFRII to Raster. This will produce lighter colours.

And regarding the 10.6.2 support, nothing has changed for the printing system since 10.6.1 so I wouldn't be too concerned with this. The Canon Australia site, which links to Canon's global download server in Singapore, shows 10.6.2 for this driver.

http://support-au.canon.com.au/contents/AU/EN/0100212606.html

And if you check the Readme for the v2.06 driver, it shows 10.4.9 or later...

Pahu

Feb 17, 2010 2:50 AM

Reply Helpful

Feb 17, 2010 7:39 AM in response to PAHU In response to PAHU

The 'Search for Printer' appears to work this time, now that the dedicated port is enabled. The printmonitor rediscovered the printed correctly, and communication works both ways. The random delays are still there though.

Thanks for your help.

Luckily don't need to wrestle with any scanning software, the MF8450 can scan to FTP.

Feb 17, 2010 7:39 AM

Reply Helpful
User profile for user: tmui

Question: Canon MF8450 and UFR II, communication issues