8 Replies Latest reply: Feb 15, 2010 1:36 PM by luvlabs
oddbob72 Level 1 Level 1 (0 points)
2 days ago my Ipod Touch suddenly failed to connect to my wi-fi netwrok at home after a year or more with no problems. I have made no changes to the settings on my Ipod, no changes to my iMac and no changes to my router. At the same time I also found the iPod would not be recognised by the iMac when I connected it so it would charge. I have since reset the iPod and it is now recognised by the iMac and will charge. However, no matter what I try to do via settings the ipod cannot find my home network. I have even tried removing all security from my router but still nothing. The only thing I haven't been able to check is whether it will pick up another network somewhere else. Why should this suddenly happen and what can I do to get the thing working again? I spent several hours trying all the options from the trouble shooting menus and nothing has worked. Help please!

oddbob72

iPod Touch, Mac OS X (10.4.1)
  • Ingo2711 Level 7 Level 7 (20,170 points)
    Welcome to the discussions,
    did you try to restore "as new ipod" without using the backup to restore your settings?
    Restoring: http://support.apple.com/kb/HT1414
    Make sure to transfer your purchases before you start restoring.
  • oddbob72 Level 1 Level 1 (0 points)
    Unfortunately I tried that and it didn't work either.
    Any other ideas?
  • luvlabs Level 4 Level 4 (3,610 points)
    If WiFi suddenly stopped working, I would reset network settings on the touch and power cycle the router. Try resetting the touch network settings - tap Settings > General > Reset > Reset Network Settings.

    Also, you might want to review this article on troubleshooting WiFi issues: http://support.apple.com/kb/TS1398
  • Jordan Bazylewski Level 1 Level 1 (0 points)
    hi i just bought a ipod touch 8g. it doesnt see my home network router. ive tried entering it in other and it says it cant find my network. my laptop connects fine. ive tried reseting the router, reseting the ipod settings, using password protected and unprotected, and setting up a whole new network. i must not be doing something right. my wi fi is on. i have a linksys router. please any help?
  • oddbob72 Level 1 Level 1 (0 points)
    I think I have now narrowed it down to the WiFi network and not the iPOD. I took the iPOD next door and it picked up my neighbours network. I've tried resetting the router but no luck. Not sure what to try next......
  • wendyj22 Level 1 Level 1 (0 points)
    I'm in the same boat as you guys. New ipod touch 1 day old, won't connect to my wi-fi system, tried everything suggested by Apple and various other forums and now ready to chuck it in the bin! What a useless piece of technology this is. Now no longer looking for connection solutions but suggested other use's for it i.e. beer mat, wedge for wobbly table, windscreen scraper or pooper scooper! your suggestions please?
  • luvlabs Level 4 Level 4 (3,610 points)
    So tell us about your WiFi network.

    Broadcasting in N mode? The touch will never see the network as it is b/g modes only.
    Hidden SSID? It's not going to find it either. You will have to type in the network name the first time.
  • luvlabs Level 4 Level 4 (3,610 points)
    You have provided us with no useful information about the network you are trying to connect to, error messages you might have received, etc.

    I'm happy to try and help you but this rather sophisticated piece of electronics is only useless when you don't expend the effort to get it to work. It could be you; it could be the device. Share some info and we will try and get it connected.