3 Replies Latest reply: Feb 20, 2010 1:25 PM by Neil Paisnel
Neil Paisnel Level 1 Level 1 (15 points)
Is it possible to use the Disk utility or the ASR command to create a Disk Image of an SD card?
I have been trying for a week or so now, and cant get it to work.

I have a Tom Tom GPS unit, and the complete software, and maps to run the GPS are stored solely on an SD card (NOT SDHC. I was trying to make a backup of the card by creating an image.

Yes, I can just copy the files off using Finder, and that works fine. But having initially tried using D.U. and failed, I would like to know why it did not work, and if it is possible to do what I am attempting.

I created a Read/write image using Disk Utility of the original SD card. Then tried using the Restore tab of Disk Utility to Restore the Image to a new SD card....but I get this error:

*Could not find any scan information. The source image needs to be imagescanned before it can be restored.*

I try the Image/Scan for restore Menu item and get this:
Unable to scanXYZ.dmg (Invalid argument)

A second image DID scan correctly, but then I get the same error as using ASR ...that there is not enough space....trying to restore a 2 gb image to a 4gb card.


I also and recently tried the ASR command, using the original disk as Source and a second (bigger 4Gb) SD card as the target.

Here is what I got with ASR

Last login: Sun Feb 14 12:02:02 on ttys000
Bon-Air-Mac-Pro:~ neil$ /usr/sbin/asr restore --source /Volumes/TOMTOMDISK -target /Volumes/Untitled -erase -noprompt -timeout 0 -puppetstrings -noverify --verbose
XSTA start 139 client
XSTA setup
Validating target...done
XSTA metadata
Validating source...done
Repartitioning target device...done
Erasing target device /dev/disk6s2...done
Validating sizes...
Not enough space on /dev/disk6s2 to restore
XSTA fail
Bon-Air-Mac-Pro:~ neil$



The source SD card is 2Gb and the target 4 GB yet I get the Not enough space error.

The disk is FAT32....

I have also tried to create blank images using Disk Utility..And get the same errors.

I wondered if this was a FAT format issue, so tried creating images in Mac OS formats, but they also fail with the same errors that I get using the FAT Format images

So now I am wondering if it is an SD card or USB card reader problem....I have tried 4 different brands of SD card, in 5 different reader devices (printer slot, 2 different USB readers, the Tom Tom itself and a camera)

Anyone shed any light on this? It is not critical , as I said earlier I CAN create the backups using Finder and copying the files off the SD card....but would like to know what the 'problem' is using either D.U. or the terminal and ASR.




Neil

Mac Pro 2 x Quad Core 3.0Ghz 10Gb RAM 4 x 1Tb HD's, Mac OS X (10.6.1), FreeNAS servers and Other Windoze and Linux machines