Previous 1 2 Next 16 Replies Latest reply: Mar 25, 2010 7:54 AM by Alan Goodall
Alan Goodall Level 1 (130 points)
Further to my earlier post on the huge 'Aperture hanging... thread"..

By watching the Aperture 3 Activity window I see that each time it fairly zips through 'Processing 'n' of 'n' items - BUT - mine hangs when it reaches about 120. These are all large (110 MB files)

So, Each time it has hung I did a quit Process from the Activity window (NOTForce quit in case I lost all that had been processed. (It takes ages to quit) _ - then re-opened Aperture and started off again. However, as I write it hung again on the last part - 67 of 77!) Repeated the process and it hung on 3 of 10, 4 of 6 and even 1 of 2 and finally 0 of 1. After several tries I cannot get the last one processed! I have heard of the law of diminishing returns but this seems crazy!

This is a library of 174 GB on an external WB Firewire 800. My smallest library of 5.4 GB processed Ok eventually. However, my largest one - of 633 Gb - which is on my 1 TB iMac internal drive has hung so many times that I will now leave that until Apple provide a fix SOON!

iMac 3.06 GHz, MacBook Pro Duo 2.4 GHz, Powerbook G4, Mac OS X (10.6)
  • LanceK713 Level 1 (0 points)
    Try repairing your library. Close Aperture, then launch your library from finder while holding Option + Command, then select Repair. It helped me.

    You might also try holding Shift when you launch Aperture. This prevents generation of thumbnails. I think there is where my installation was getting hung up, due to some corruption in the library.
  • Alan Goodall Level 1 (130 points)
    Thanks - I have tried both of these. I had already done a repair as per this method earlier - and now again. However, it still hangs after processing (now down to 13 of 19 ) in my huge 633GB library. Will persist this evening to see if I can repeat the success with this method that I had with the two smaller libraries

    Holding the shift at Launch reveals that there is no processing to be done - so perhaps the problem lies in the generation of thumbnails?
  • Robert Rogers Level 2 (360 points)
    I have a 750GB iphoto library and could not import it via A3. I finally made a duplicate of my drive and decided to import the library and leave it in its current position and although we are at about 24 hours things seem to be importing. Probably better to leave IPhoto as is and move pictures and folders in as I need them. Just a thought,
  • Alan Goodall Level 1 (130 points)
    Hi Thanks - mine are all from Aperture 2 libraries. I have been trying - unsuccessfully - for the last three hours to get the final 5 items 'processed' I have tried everything that worked for me earlier (quitting via Activity monitor) re-building all that I could via alt and command when opening Aperture. I have also tried pausing and/or canceling the task and then tried to resume - but it does not. It still shows a spinning "Processing" in my main Aperture window but no activity in the Aperture Activity window. It also hangs when I try to do any editing.

    I feel that IF I could get these last 5 'processed' then I 'could' start to try and enjoy this new version. Wishful thinking???????
  • gavinthain Level 1 (0 points)
    My Library is 216Gb. Totally fed up with this.
    My symptoms - Aperture3 launches, opens after about 30 seconds ish, then consumes all free RAM, and creates MASSIVE swap file - like GB's... kills iMac. Have to Hard Reboot.
    Tried creating a new library, and importing upgraded library.
    This works, then when I relaunch Aperture it dies again.
    Processing... gets to 5 of 20 (whatever that means) and then goes into this crazy memory leak.
    I'm now going to try importing again but renaming the Thumbnails and Previews folders in the Library package. Lets see if that makes any difference what so ever.
    This must be a code bug, too many people are getting this issue!!!
  • Matthew Bergsma Level 3 (600 points)
    Are you using referenced or managed masters?
  • Alan Goodall Level 1 (130 points)
    My Activity Monitor (from Utilities) shows that Aperture is using 3.36 GB of my 4 GB Real Memory and 7.42 GB of virtual memory. The black spinning wheel in my main Aperture window still reads "processing" but my Aperture Activity window still shows no progress on processing the last 5 items (as per the last few hours) I am now so tired that I am giving up. I will leave it to run overnight - but I guess it will just hang again.

    I am so disappointed in this. I have waited for so long for this update! I had huge problems in version 2 with the 'Red Screen of Death' - when using large files. This problem was never even acknowledged by Apple - let alone solved. So, I hoped that version 3 would solve this. Perhaps it has .... I just have not yet had access to my main library to work on it and find out!

    I think that for all the time and effort that has been put in by many people on these posts - Apple owes us an apology and a solution - FAST!
  • Alan Goodall Level 1 (130 points)
    This (633GB) library is in my new Aperture 3 Library - in my Pictures folder on my iMac, 1 TB internal hard drive. This has 278 GB free.
  • Alan Goodall Level 1 (130 points)
    Update on this

    I left it to run all night hoping that the last 5 items would be processed - but
    This morning it had hung with the out of application memory message

    So, I tried a suggestion from someone else re booting in 32 bit and it worked!

    The trick to get past the final 'processing' of the remaining items (and hanging with running out of Application memory) was

    to open in 32 bit using the check box (via get info for Aperture 3)
    Do a library rebuild at the same time (alt + cmd)
    let it finish the processing
    then close Aperture
    un check the 32 bit box and re-open
    It then works fine in 64 bit (as shown in my Utilities, Activity monitor
    and all 'Processing' as shown in the Aperture Activity window has ended!

    I hope it all works now - as it 'says on the box'

    I am now going to explore editing images in my 600GB + AP 3 Library (which is on my 1TB iMac internal drive)

    will keep you posted
  • martinizer Level 1 (0 points)
    Launching while holding the shift key worked for me. No more hanging or crashing.
  • wallrat1975 Level 1 (0 points)
    This worked for me too! My problem was identical to yours. It would process "x of y" then just freeze, eventually sitting at "0 of 1". 32bit solved it, even allowed face detection to run and finish.

  • Alan Goodall Level 1 (130 points)
    Hi Bill

    Glad this worked for you - enjoy! I really like Aperture 3 more and more as I use it. Managed to import several large libraries now from Aperture 2 OK. Problems this evening importing a 74GB iPhoto library (insufficient space message - even on a new, clean 1TB external, Firewire 800 drive!) It is now importing OK via leaving them in their current location so will try and consolidate them later.

    It is such a pity we had so many initial problems - especially importing with memory leakage and processing forever! Now I am looking forward to really enjoying editing - with this fab new Aperture 3

    What a difference a week - and lots of help via these discussions - can make!
  • Gobucky Level 1 (0 points)
    I had similar problems. 80 GB library. Continual processing. Ran the 32-bit solution and it appeared to work. Processed everything. Ran face detection and finished successfully all 35,000 pictures. Shut down Aperture and restarted in 64 bit mode. Now it hangs on processing 4 of 21 items and 1 of 28 thumbnails for faces. I dont understand how it could be needing to do this since I did no work in the program after the rebuild and the processing finished. Any tips? Run through the 32 bit solution one more time? I'm desparate.
  • imigra Level 2 (220 points)
    I am guessing that a library of 633Gb on your internal iMac system drive is not a very good idea. That together with the system and some more stuff makes that things are probably so fragmented that a simple write to the Library database takes forever, let alone writing to the Thumbnail files (depending on the size of your projects), sometimes broken up into thousands of bits and pieces. OSX is fairly fragmentation resistant, but I think that incremental writing to a file fragments it if there's no contiguous free space available right at the end of the file, and with the disk filling up, this becomes worse over time. You might find temporary solace in a full defrag of your system drive, but consider getting a fast external drive. Get one with firewire 800 and eSata (you next system might have it), and/or USB 3 (they're starting to show up). Firewire 800 is as fast as the iMac goes, but I've found it to be fast for Aperture, and it's always better no to have the rest of your system come to a halt because the disk system can't keep up with the fragmentation.
Previous 1 2 Next