1 Reply Latest reply: Feb 18, 2010 4:47 PM by luvlabs
DCFreak28 Level 1 (0 points)
Hi, I've had my 3rd generation Iphone Touch for about 3 weeks now and ever since I got it, the wireless connection has been finicky at home. It usually works fine everywhere else (sometimes have to turn the wireless or unit on/off), but I have to turn the wireless on and off several times and turn the whole unit on and off several times to get it to connect at home. I've spent over an hour looking at solutions online - both in this discussion forum and ones out on the rest of the internet. Still no luck. It asks me to enter the network password, which I know I'm doing correctly but it says that it "failed to join x" (where x is my network). After about 50 tries it connects, but this is clearly a problem. I am running iPhone OS 3.1.3. My laptop (windows based) continues to connect fine to my router. Here's what I've done:

1. Check for new firmware for my router - it has the newest version. Reset my router settings to the factory defaults, then set the band to only broadcast wireless G, the channel is set to 11, and I am using a WPA2 encryption key, as I read these settings were better for the itouch. I've also done a reset by just disconnecting the power to the router for 20 seconds then plugging it back in.
2. Reset the network settings from the system menu on my itouch.
3. I tried both selecting my network from the list of available networks on my itouch and manually entering the name, encryption type, and password. Every time I enter the password, it says it "failed to connect" and I obviously have no internet connectivity.

What kind of solutions do I have? My router is a cheap off-brand "CNet" router. Maybe I need a new one.

iPhone OS 3.1.3