10 Replies Latest reply: May 15, 2010 7:39 PM by satcomer
jaguirre2 Level 1 Level 1 (0 points)
**I need help please** !!!! I recently purchased my macbook pro about 3weeks ago and i was enjoying every youtube video until recently. I noticed that only random videos will play. At first i thought it was youtube its self but then after some days i decided to open the same videos on another mac or pc and they worked perfectly. i also checked my internet and its working properly. When i click the video everything will load perfectly normal except that the bar showing the load time of the video will never appear hence all im left with is the page and the black window where the actual video should b playing. please anyone!!!

MACBOOK PRO 13", Mac OS X (10.6.2)
  • dechamp Level 4 Level 4 (3,495 points)
    Have you tried FireFox 3.6?
    http://www.mozilla.com/en-US/
  • Carolyn Samit Level 10 Level 10 (96,750 points)
    HI and Welcome to Apple Discussions..

    YouTube content streams using the Flash Player plugin.

    Your Flash Player plugin may need updating but make sure and uninstall the current copy first.

    Uninstall Flash

    Install Flash

    Repair disk permissions...

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility.

    Since you are running Snow Leopard, make sure Safari is running in 32-bit mode, not 64. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Also, (in that same window) make sure Safari is NOT running in Rosetta.

    Restart your Mac.









    Carolyn
  • Simon (UK) Level 4 Level 4 (3,565 points)
    Carolyn Samit wrote:

    Since you are running Snow Leopard, make sure Safari is running in 32-bit mode, not 64.


    Hi Carolyn, I was just wondering why you say this? I run Safari in 64-bit mode without a problem. I also run the 64-bit kernel too.

  • dkiang Level 1 Level 1 (5 points)
    I just recently updated my MBP to 10.6 (Snow Leopard) and the Flash functions are wonky. There has been some YouTube videos with faulty controls. I only did the Flash update, not uninstall though. Will give the uninstall a try then update again.
  • dkiang Level 1 Level 1 (5 points)
    The uninstall didn't solve the problem. I think 10.6 still has problems with the browser and bugs in general.
  • William Kucharski Level 6 Level 6 (14,890 points)
    There are literally millions of Mac OS X 10.6 users with no issues watching YouTube videos.

    There's got to be an answer for you here.
  • baltwo Level 9 Level 9 (61,945 points)
    Then, post your own thread and you'll most likely get help. Wonky doesn't tell anyone anything of import.
  • dkiang Level 1 Level 1 (5 points)
    You're right, the term "wonky" doesn't address the specifics of the problem. But the next sentence about the faulty controls in YouTube, gave a simple description. Followed by my next post saying I tried the installation routine, which didn't seem to solve it.

    Message was edited by: dkiang
  • marctamm Level 1 Level 1 (0 points)
    I just got off the phone with Apple regarding a similar issue with my MacBook Pro 15" that I just bought last August. My situation: when watching videos in HD on Youtube/Vimeo/etc., when playing, the video will pause, the load ring will start spinning in the middle of the screen for about 2 seconds, video will continue, only to restart the process all over again. This only did it in fullscreen HD (720 or greater), but worked fine in the default mini-screen on the page.

    The only reason I bring all this up is hopefully you can use it to troubleshoot your system with the same methods and rule out possibilities. The tech asked me if I had Firefox and to check and see if I had the same problem in that browser. To my surprise, it worked just fine in Firefox, so that means that it is a Safari issue. In Safari, click on the "Safari" name in the header (up by the apple where you do your software updates and so forth) and choose "Reset Safari". From there, I simply selected "Empty the Cache", "Clear The Downloads Window", "Remove All Cookies", and "Remove All Website Icons". You can choose whichever ones you like. If you are experiencing the same problems in Firefox, click "Tools", "Clear Private Data...", and follow the same procedures.

    Mine works just fine now! It makes sense as I didn't have this problem when I first got my computer. They recommend that you do this at least once a month as all of these temporary files and so forth can bog the system down. Anyway, I really hope that this helps.

    In Him,
    m.
  • satcomer Level 4 Level 4 (1,110 points)
    Plus clear the hidden Flash cookies (read about it at the Wired article You Deleted Your Cookies? Think Again) with the simple program Flush. The amount of Flash cookies will surprise you.