Previous 1 2 3 Next 37 Replies Latest reply: Jun 14, 2011 6:38 PM by Ross from Sydney
Tom Wardle Level 1 Level 1 (0 points)
I can't seem to find a way to always open in list view for my iDisk folder, the only option is to always open in icon view. Should I be looking somewhere other than view options?

MacBook Pro 17" 2.4GHz, Mac OS X (10.6.2), iPhone 3GS 32GB
  • Meherally Level 4 Level 4 (1,115 points)
    Hi Tom,

    Welcome to the forums.

    Yes there is a way. Select your iDisk. On top left select the list view. Now go to the menu 'view' and select view options or hit cmd-J. A window will pop up. on top of the window is check box 'always open in list view' check that. You are done.

    Hope that helps.
  • Professor Jason Level 1 Level 1 (0 points)
    Thanks for this thread! I'm so irritated with the problem I have with iDisk. It ALWAYS opens in icon view. After following the steps provided in the answer above, I've discovered that I don not have the checkbox "always show in list view". I only have a checkbox "always show in icon view". What gives? Why wont' iDisk be nice and open in list view every time?
  • Meherally Level 4 Level 4 (1,115 points)
    Hi Professor,

    Welcome to the forums.

    Try this. Select your iDisk in the Finder side bar.
    As you say, it will open in icon view.
    Next, select 'view options' from 'view' menu. As you say, the window will have "always show in icon view" but note if the box next to is checked or unchecked. If checked, uncheck it.

    Next, from 'View' menu, select 'as list'. Now note if the view option window changes the 'always in icon view' to 'always in list view' . Once you get the veiw option you want, THEN check the box next to it in the view option window.

    In short, before you do anything, first uncheck the box in the view option window, then select the view you want.

    Hope this helps.

    Message was edited by: Meherally
  • Professor Jason Level 1 Level 1 (0 points)
    Hi Meherally. Thanks for the tip, but my problem isn't related to the process for setting default viewing options. Perhaps some clarification will help.
    ----
    "Next, select 'view options' from 'view' menu. As you say, the window will have "always show in icon view" but note if the box next to is checked or unchecked. If checked, uncheck it."
    ----
    This box is always unchecked. The problem is that when I change views in the finder window (from icon, to list or coverflow, or whatever, the "view options"menu always says "always open in icon view". It does not change according to whatever view I am using. this only happens in iDisk. All other folders and disks open just the way I have set them.

    In my office I have an iMac G5 running Leopard that works perfectly (in other words, I can set my iDisk view default to always open in whatever view I please), but my new MacBook Pro running Snow Leopard appears to have a bug that prevents this option with iDisk only. The checkbox always says "Always open in icon view" no matter what view I switch to in the finder window. As mentioned above, the iDisk is the only problem. It always opens in icon view and the checkbox does not change with the current window view. All other folders and disks on the MacBook open jsut the way I want. But I'm getting irritated with iDiks always opening in icon view.

    Thanks!


    I've not come across anyone else reporting this problem on any other forum.
  • Meherally Level 4 Level 4 (1,115 points)
    Hi

    Understand now. Can offer only one more suggestion. Please check in your system preference > mobileme>idisk if the syncing is on or off. If on, suggest turn it off and then go back to view option and see if it solves the problem.

    If it does, do come back here and mark as solved so others can look for similar solution. Thanks.
  • Meherally Level 4 Level 4 (1,115 points)
    Hi Tom Wardle,

    Were you able to work this out? Maybe it will give us all some pointers here although I am sure the professor's problem is that idisk sync is ON.
  • Timo Level 1 Level 1 (110 points)
    Hi,

    I got the very same problem here, with 2 different macs using the same iDisk under SL. The funny thing is that it started first when I stopped and restarted the iDisk sync on both systems (I had to do this because of another problem).

    No matter what view I select, the option pane always shows "always open in icon view". I also tried to delete the .DS_store file. Didn't help.

    It seems to be a bug (a quiet annoying one...).
  • Meherally Level 4 Level 4 (1,115 points)
    Hi Timo

    Welcome to the forums.

    You say it started after you stopped and restarted. So are you trying to change the default view with syncing ON? if so, try the view options with syncing 'off'. I duplicated this on my MBP. When the sync is on, the view option window is icon view only. When I stop the sync, the view option window works fine.
  • Timo Level 1 Level 1 (110 points)
    Hi Meherally,

    thanks for your answer. To work in sync=off mode is no option for me, as I have to use my iDisk offline.

    Do you know if it works when switching the sync to off, then adjust the view settings and finally reenable sync again? I would try this only when it worked for sure, as syncing my whole iDisk takes several hours and I cannot work during this time.

    Best,
    Timo
  • Meherally Level 4 Level 4 (1,115 points)
    Hi Timo,

    I could do this on my MBP. Switched sync off, selected iDisk, made it always open in List view, then for a good measure selected desktop and made it always open in column view, then selected applications and made it always open in coverflow.

    I then switched on the sync. All three items opened as designated and during the sync, idisk opened in list view as designated.

    Not sure why you say you cannot work during syncing. I can.
  • Timo Level 1 Level 1 (110 points)
    Thanks a lot, I will do this.

    Not sure why you say you cannot work during syncing. I can.

    Because I work with audio and Logic and I have several projects for university that are stored on my iDisk. This would be much too slow when streamed over the internet...
  • lerosings Level 1 Level 1 (0 points)
    Hi everyone
    I had been having the same problem with not being able to change my view options from icon to my preferred view (column) on my iDisk. I took the forum's advice (meherally, I think), went to the mobile me section in system preferences, then sync, and unchecked the box for "sync w/mobile me automatically". I then went back to the iDisk window, and was able to change the view option from icon to column. As soon as I did that, I went back to the sync option in mobile me (system preferences) and re-checked "sync with mobile me automatically".
    I've not had a problem since...though that was 10 minutes ago. My point is you'd only have to not be in sync with mobile me for mere seconds!
    Thanks for the post
  • Ryan Cabell Level 1 Level 1 (35 points)
    I tried this as well; turned off sync, verified that iDisk was set to "Always open in list view", turned on sync -- and now I'm back to Icon view. Frustrating! (this was on 10.6.2)

    What I did notice is that if I have another Finder window open, in list view, and I choose 'iDisk' from the Devices sidebar, it will stay in list view when showing iDisk. I don't really remember if this was the case before. But in any case, double-clicking from the Desktop brings up Icon View... every... single... %#@*(... time!

    I frequently 'live' on the iDisk with large files that just take way to long to load/save when not using Sync. With sync turned on the local read/write is fast and the sync plods along on doing its thing on a background task.
  • Timo Level 1 Level 1 (110 points)
    I have news to this topic:

    As I still couldn't get rid of the permanent icon view, I remembered to have activated a hidden finder function with tinker tool, that prevents the finder from writing the .DS_Store files on network volumes.

    So here's my solution:
    - download tinker tool and activate the mentioned setting on finder tab.
    - click restart finder
    - open iDisk
    - open View Options (Cmd+J)
    - change to list view
    - deactivate the "always open in icon view" which still was shown
    - then it turns to "alawys open in list view" and check it
    - buff - you get it! Works finally here!

    Maybe you have also to delete the .DS_Store file, but I didn't had to. Just in case, activate the "Show hidden and system files" in tinker tool to make it visible.

    Hope that helps!
Previous 1 2 3 Next