4 Replies Latest reply: Feb 21, 2010 12:09 AM by Tarsip
iphone16gb Level 1 Level 1 (0 points)
I tried to add new apps to my iphone, but I was asked to update my itunes software first. Now it asks me to restore my iphone before I continue but each time I click on restore its says restore failed. I looked at the troubleshooting guide and restarted the computer and then updated all new softwares, but its still doesn't work. Now I can't use my iphone at all because it displays a usb and itunes symbol even if i switch it on and off. Could someone help me and tell me what I can do??

Thank you so much

iphone 16gb
  • Graham Outterside Level 4 Level 4 (2,910 points)
    Have you been through this ? http://support.apple.com/kb/HT1414
  • Tarsip Level 1 Level 1 (0 points)
    Crickey, how many people have got the Error 29 iphone when it gets to the firmware upgrade and now the iphone is stuck in the recovery mode loop just because the owner having faith in APPLE innocently pressed update in Itunes unconsciously thinking it would be ok just like they have done before...??? Suddenly they find they have to contemplate a nightmare life without an iphone, questioning weather they can recover data, songs etc...? Even just to get it working again... Well I am stuck in this position. I have been through all the recommendations by Apple to no avail. Is using the third party "Irecovery" the only solution? Or is Apple sorting this issue out? Help APPLE please give us direction and hope for this bug in the latest upgrade for the iphone...Emotions are running high....Please...
  • Graham Outterside Level 4 Level 4 (2,910 points)
    Nobody from Apple reads these boards.

    Take it to a Genius Bar and get them to sort it out if you cannot do so yourself, and it froze in mid-update.
  • Tarsip Level 1 Level 1 (0 points)
    No genius bars where I am...could not find any support from Apple, looked though forums found about about error 29 on the 3.1.3 iphone upgrade,I ended up using the third party irecovery on a windows XP platform ( could not get it to work on the mac platform) and now after 7 hours have finally got my iphone to at least work... using my back up now but it did not give me all the apps, so I am reinstalling them. (I had over 200). Will not be upgrading to 3.1.3 till it is fixed. Very wary. I would recommend people reading the forums on Error 29 on the update before they inadvertently press the update button!