3 Replies Latest reply: Mar 25, 2010 8:00 PM by dee808
dee808 Level 1 Level 1 (0 points)
Hi I'm new to the forums,

I'm having problems booting into my windows partition on my MacBook. Everything was fine until I had a recent power failure while using Windows 7 for office work. My Macbook just turned off with no warning. Upon turning on the macbook I get the "No Bootable Device" black screen.

I figured the Windows partition corrupted itself after the power failure. I proceed to delete the windows partition via Boot Camp Assistant in OSX, divide the hard drive again, and go ahead with reinstalling Windows 7. But here's the problem I can't seem to figure out. When formatting the BOOTCAMP partition in the Windows Installer to NTFS, I run into this error:

http://i49.tinypic.com/1043i53.jpg
http://i48.tinypic.com/167mux4.jpg
http://i49.tinypic.com/1zxulo1.jpg

Probably the entire hard disk corrupted after the power failure? Okay, so I freshly reinstall Snow Leopard deleting all the contents on the HD. I even performed a complete format using the Zero Out method in Disk Utility. When the OSX install completed I divided the partition again with Boot Camp Assistant and ran the windows installer only to run into the same error like pictured above. Tried this method again but also ressetted NVRAM/PRAM and SMC. Still no luck.

So I'm thinking some part of the HD isn't working. I remove the HD from the macbook and replace it with the original 80GB hard drive that came with it. This time, instead of installing OSX, I formatted the hard drive in FAT32 with Disk Utility, and proceeded to install Windows 7 without OSX. I STILL get the same error though. Can't ever get passed this error. Arghh. I guess its not an HD problem so I replace my 250gb HD back in.

Did some research on google and decided to run rEFIT for its custom boot screen. For the heck of it I decided to run the Windows Partition that was listed on boot screen. Here is where I run into this error:

http://i49.tinypic.com/2mq6og5.jpg

It says: "The firmware refused to boot from the selected volume."

Could this be an EFI problem? Is something corrupted in the boot rom that is restricting me from booting into the windows partition? I already performed a reset for the NVRAM/PRAM and SMC.

I've tried to reflash the EFI again but OSX won't let me. It says: "This computer does not need this update"

Anybody have any suggestion to what I should do? I'm way out of warranty and have no Apple Care. There are no Apple Store within a 100 miles.

Macbook 2,1 2GHZ Intel Core 2 Duo 2GB RAM, Mac OS X (10.6)
  • jaykog Level 2 Level 2 (225 points)
    Hi,
    I am not sure what to suggest regarding the errors that you are having but I am also running Win7 on my Mac. When I first got my MB, I used BootCamp but I quickly changed to Fusion and then to Parallels (which I like the most) - primarily so I could boot into OSX and still have access to my PC VM's. Maybe you should look into switching your PC environment to VM. Most of the VM software has a feature to 'snapshot' your VM session. This way, if your MB should abruptly power off, you can always revert to one of the snapshots without having to re-install. Anyway, good luck I hope you get the problem resolved.
  • dee808 Level 1 Level 1 (0 points)
    Hi jaykog,

    Thanks for the quick response. I've been running Parallels for now but the performance just doesn't cut it for me. I really need Windows to run natively.

    Anybody else had a similar problem? I just can't figure out why the boot rom firmware would corrupt itself from a power failure. I'm hoping my macbook doesn't need a logic board replacement. I mean, why would I? Everything else works fine.
  • dee808 Level 1 Level 1 (0 points)
    Bump?