2 Replies Latest reply: Feb 23, 2010 11:40 AM by MJM233
MJM233 Level 1 Level 1 (0 points)
I just got a macally microphone for the ipod touch and I found out that it's not compatible with the 3.1.3 firmware. So I have to downgrade to the 3.0 Firmware in order for the mic to work. But that's the problem, it won't let me downgrade at all! I tried holding in shift, then pressing restore. That didn't work. Every time I try to downgrade it says "The ipod could not be restored. An unknown error occurred (20)" Does anyone know how to fix this?

Windows XP